Re: rename mail queue table

2013-03-15 Thread seba.wag...@gmail.com
And I would propose to write the last error/exception not only to the log
but also to a field in the database.
So for example "last_error".
For "non geeks" it might be easier to have a look in the database then to
read log files.
And for database columns I would propose that we stick to the standard
database naming pattern.

In Java and JavaScript the naming pattern is
CamelWritingAlwaysFirstLetterBig
in C#, PHP, scripts, databases you would normally translate that to:
camel_writing_always_first_letter_big

I think we have such tables and columns already, its not 100% consistent
but I would suggest that at least for new tables and columns we use that
naming convention.

Sebastian


2013/3/16 seba.wag...@gmail.com 

> Hi Maxim,
>
> I would propose to rename the table "email". I think it would make more
> sense to call that table for example "message_queue" or "mail_queue" or
> something like that.
> A table "email" suggests to me that this table contains all emails of the
> system. But actually its just the queue.
>
> What do you think?
>
> --
> Sebastian Wagner
> https://twitter.com/#!/dead_lock
> http://www.webbase-design.de
> http://www.wagner-sebastian.com
> seba.wag...@gmail.com
>



-- 
Sebastian Wagner
https://twitter.com/#!/dead_lock
http://www.webbase-design.de
http://www.wagner-sebastian.com
seba.wag...@gmail.com


Re: rename mail queue table

2013-03-15 Thread seba.wag...@gmail.com
But I think its working really nice with that queuing.
I just have not yet been able to test it on a server with working mail
settings,
but I can at least confirm that the errorCount works :))

Sebastian


2013/3/16 seba.wag...@gmail.com 

> And I would propose to write the last error/exception not only to the log
> but also to a field in the database.
> So for example "last_error".
> For "non geeks" it might be easier to have a look in the database then to
> read log files.
> And for database columns I would propose that we stick to the standard
> database naming pattern.
>
> In Java and JavaScript the naming pattern is
> CamelWritingAlwaysFirstLetterBig
> in C#, PHP, scripts, databases you would normally translate that to:
> camel_writing_always_first_letter_big
>
> I think we have such tables and columns already, its not 100% consistent
> but I would suggest that at least for new tables and columns we use that
> naming convention.
>
> Sebastian
>
>
> 2013/3/16 seba.wag...@gmail.com 
>
> Hi Maxim,
>>
>> I would propose to rename the table "email". I think it would make more
>> sense to call that table for example "message_queue" or "mail_queue" or
>> something like that.
>> A table "email" suggests to me that this table contains all emails of the
>> system. But actually its just the queue.
>>
>> What do you think?
>>
>> --
>> Sebastian Wagner
>> https://twitter.com/#!/dead_lock
>> http://www.webbase-design.de
>> http://www.wagner-sebastian.com
>> seba.wag...@gmail.com
>>
>
>
>
> --
> Sebastian Wagner
> https://twitter.com/#!/dead_lock
> http://www.webbase-design.de
> http://www.wagner-sebastian.com
> seba.wag...@gmail.com
>



-- 
Sebastian Wagner
https://twitter.com/#!/dead_lock
http://www.webbase-design.de
http://www.wagner-sebastian.com
seba.wag...@gmail.com


Re: rename mail queue table

2013-03-17 Thread Maxim Solodovnik
done:
the table is renamed to be "email_queue";
"last_error" field is added


On Sat, Mar 16, 2013 at 11:53 AM, seba.wag...@gmail.com <
seba.wag...@gmail.com> wrote:

> But I think its working really nice with that queuing.
> I just have not yet been able to test it on a server with working mail
> settings,
> but I can at least confirm that the errorCount works :))
>
> Sebastian
>
>
> 2013/3/16 seba.wag...@gmail.com 
>
> And I would propose to write the last error/exception not only to the log
>> but also to a field in the database.
>> So for example "last_error".
>> For "non geeks" it might be easier to have a look in the database then to
>> read log files.
>> And for database columns I would propose that we stick to the standard
>> database naming pattern.
>>
>> In Java and JavaScript the naming pattern is
>> CamelWritingAlwaysFirstLetterBig
>> in C#, PHP, scripts, databases you would normally translate that to:
>> camel_writing_always_first_letter_big
>>
>> I think we have such tables and columns already, its not 100% consistent
>> but I would suggest that at least for new tables and columns we use that
>> naming convention.
>>
>> Sebastian
>>
>>
>> 2013/3/16 seba.wag...@gmail.com 
>>
>> Hi Maxim,
>>>
>>> I would propose to rename the table "email". I think it would make more
>>> sense to call that table for example "message_queue" or "mail_queue" or
>>> something like that.
>>> A table "email" suggests to me that this table contains all emails of
>>> the system. But actually its just the queue.
>>>
>>> What do you think?
>>>
>>> --
>>> Sebastian Wagner
>>> https://twitter.com/#!/dead_lock
>>> http://www.webbase-design.de
>>> http://www.wagner-sebastian.com
>>> seba.wag...@gmail.com
>>>
>>
>>
>>
>> --
>> Sebastian Wagner
>> https://twitter.com/#!/dead_lock
>> http://www.webbase-design.de
>> http://www.wagner-sebastian.com
>> seba.wag...@gmail.com
>>
>
>
>
> --
> Sebastian Wagner
> https://twitter.com/#!/dead_lock
> http://www.webbase-design.de
> http://www.wagner-sebastian.com
> seba.wag...@gmail.com
>



-- 
WBR
Maxim aka solomax