[jira] [Commented] (PIG-3089) Implicit relation names

2012-12-13 Thread Jonathan Coveney (JIRA)

[ 
https://issues.apache.org/jira/browse/PIG-3089?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13531342#comment-13531342
 ] 

Jonathan Coveney commented on PIG-3089:
---

Thejas: I implemented your suggested here 
https://issues.apache.org/jira/browse/PIG-3090

> Implicit relation names
> ---
>
> Key: PIG-3089
> URL: https://issues.apache.org/jira/browse/PIG-3089
> Project: Pig
>  Issue Type: New Feature
>  Components: grunt, parser
>Reporter: Russell Jurney
>Assignee: Jonathan Coveney
>
> A = load foo;
> B = load bar;
> filter A by id > 5;
> join A_1 by id, B by id;
> // or A_filter
> foreach A_1_B generate id;
> store into foobar; // A_1_B_1 or A_filter_B_generate
> Or some such routine?
> We don't have to be explicit no more!

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (PIG-3089) Implicit relation names

2012-12-13 Thread Russell Jurney (JIRA)

[ 
https://issues.apache.org/jira/browse/PIG-3089?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13531339#comment-13531339
 ] 

Russell Jurney commented on PIG-3089:
-

I sit there for minutes trying to name my relations. Thats what I want to fix.

I like Thejas' suggestion better.

> Implicit relation names
> ---
>
> Key: PIG-3089
> URL: https://issues.apache.org/jira/browse/PIG-3089
> Project: Pig
>  Issue Type: New Feature
>  Components: grunt, parser
>Reporter: Russell Jurney
>Assignee: Jonathan Coveney
>
> A = load foo;
> B = load bar;
> filter A by id > 5;
> join A_1 by id, B by id;
> // or A_filter
> foreach A_1_B generate id;
> store into foobar; // A_1_B_1 or A_filter_B_generate
> Or some such routine?
> We don't have to be explicit no more!

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (PIG-3089) Implicit relation names

2012-12-11 Thread Jonathan Coveney (JIRA)

[ 
https://issues.apache.org/jira/browse/PIG-3089?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13529171#comment-13529171
 ] 

Jonathan Coveney commented on PIG-3089:
---

I like this idea, generally. Daniel and I had discussed something similar a 
while back. Agree that we need to pin down the syntax.

What are we trying to fix? Is it extra keystrokes? Is it a proliferation of 
useless relation names?

I think there are a couple of things we can make better. I think that Thejas's 
idea is one of them...a syntax to refer to the previously defined relation 
would be really cool. I think that should be another JIRA.

> Implicit relation names
> ---
>
> Key: PIG-3089
> URL: https://issues.apache.org/jira/browse/PIG-3089
> Project: Pig
>  Issue Type: New Feature
>  Components: grunt, parser
>Reporter: Russell Jurney
>Assignee: Jonathan Coveney
>
> A = load foo;
> B = load bar;
> filter A by id > 5;
> join A_1 by id, B by id;
> // or A_filter
> foreach A_1_B generate id;
> store into foobar; // A_1_B_1 or A_filter_B_generate
> Or some such routine?
> We don't have to be explicit no more!

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (PIG-3089) Implicit relation names

2012-12-11 Thread Thejas M Nair (JIRA)

[ 
https://issues.apache.org/jira/browse/PIG-3089?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13529125#comment-13529125
 ] 

Thejas M Nair commented on PIG-3089:


In my opinion, too many rules for implicit relation names would make pig 
scripts (written by others) hard to read, specially for people who are new to 
pig. I think it is better to just allow name of preceding relation to be 
referred using a special notation. 

> Implicit relation names
> ---
>
> Key: PIG-3089
> URL: https://issues.apache.org/jira/browse/PIG-3089
> Project: Pig
>  Issue Type: New Feature
>  Components: grunt, parser
>Reporter: Russell Jurney
>Assignee: Jonathan Coveney
>
> A = load foo;
> B = load bar;
> filter A by id > 5;
> join A_1 by id, B by id;
> // or A_filter
> foreach A_1_B generate id;
> store into foobar; // A_1_B_1 or A_filter_B_generate
> Or some such routine?
> We don't have to be explicit no more!

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (PIG-3089) Implicit relation names

2012-12-10 Thread Russell Jurney (JIRA)

[ 
https://issues.apache.org/jira/browse/PIG-3089?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13528678#comment-13528678
 ] 

Russell Jurney commented on PIG-3089:
-

The other way to do this is... just stick with the last defined relation. 
Although... I can see that getting tricky to keep up with internally? Unless we 
just reassign after doing the above?


> Implicit relation names
> ---
>
> Key: PIG-3089
> URL: https://issues.apache.org/jira/browse/PIG-3089
> Project: Pig
>  Issue Type: New Feature
>  Components: grunt, parser
>Reporter: Russell Jurney
>Assignee: Jonathan Coveney
>
> A = load foo;
> B = load bar;
> filter A by id > 5;
> join A_1 by id, B by id;
> // or A_filter
> foreach A_1_B generate id;
> store into foobar; // A_1_B_1 or A_filter_B_generate
> Or some such routine?
> We don't have to be explicit no more!

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira