[jira] Commented: (QPID-2248) QMF: proposed API for QMFv2

2009-12-07 Thread Ted Ross (JIRA)

[ 
https://issues.apache.org/jira/browse/QPID-2248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12786940#action_12786940
 ] 

Ted Ross commented on QPID-2248:


A couple of reasons:

First, the distinction was used to separate the transmission of properties 
(possibly bulky) from the transmission of statistics (change frequently) in an 
attempt to make bandwidth usage more efficient.  Furthermore, it was the intent 
(but never implemented) that changes to properties would be transmitted 
immediately and that changes to statistics would be bundled and sent 
periodically.

With the map-message format, there is no need to separate the data elements in 
an object into separate classes (i.e. properties and statistics) because it is 
easy to send an update message that contains only the elements that have 
changed.

In the new structure, "described data" (i.e. a data structure described by a 
schema) has "properties" and "methods".  Properties, as described by the 
scheme, have attributes (amqp-type, access-rule, optional/mandatory, 
description, units, etc.).  We will add an additional attribute describing 
whether a property is discrete or continuous which will determine whether it 
should be periodically sampled or whether updates should be triggered on any 
change.

This new structure simplifies the code and the related concepts but retains 
(and improves) the current functionality.

-Ted


> QMF: proposed API for QMFv2 
> 
>
> Key: QPID-2248
> URL: https://issues.apache.org/jira/browse/QPID-2248
> Project: Qpid
>  Issue Type: New Feature
>  Components: Qpid Managment Framework
>Reporter: Ken Giusti
>Assignee: Ted Ross
> Attachments: qmf-ng-api-12012009.txt, qmf-ng-api-12042009.patch, 
> qmf-ng-api-12042009.txt
>
>
> Track the evolution of the QMFv2 api document.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


-
Apache Qpid - AMQP Messaging Implementation
Project:  http://qpid.apache.org
Use/Interact: mailto:dev-subscr...@qpid.apache.org



[jira] Commented: (QPID-2248) QMF: proposed API for QMFv2

2009-12-07 Thread Ken Giusti (JIRA)

[ 
https://issues.apache.org/jira/browse/QPID-2248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12786938#action_12786938
 ] 

Ken Giusti commented on QPID-2248:
--

My summary is a bit oversimplified: I'm proposing that we move the distinction 
between what is a "statistic" and what is a non-statistic out of the functional 
API and make it part of the schema that describes the data instead.

This results in QMF not needing to know if a bit of data is considered a 
"statistic" or a "property" - that's left to the application that uses the 
data.  QMF becomes more data-agnostic.

An additional benefit is that this simplifies the API proper quite a bit.  
Looking at the code as it stands now, for every "getProperty()"-like call, 
there is a parallel "getStatistic()" call.  In reality, QMF doesn't really 
distinguish between the two.  Removing this distinction in the API makes a lot 
of code duplication go away.

We kept the term "property" because it's generic - it now applies to all data 
(non-method) items.

thanks,

-K



> QMF: proposed API for QMFv2 
> 
>
> Key: QPID-2248
> URL: https://issues.apache.org/jira/browse/QPID-2248
> Project: Qpid
>  Issue Type: New Feature
>  Components: Qpid Managment Framework
>Reporter: Ken Giusti
>Assignee: Ted Ross
> Attachments: qmf-ng-api-12012009.txt, qmf-ng-api-12042009.patch, 
> qmf-ng-api-12042009.txt
>
>
> Track the evolution of the QMFv2 api document.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


-
Apache Qpid - AMQP Messaging Implementation
Project:  http://qpid.apache.org
Use/Interact: mailto:dev-subscr...@qpid.apache.org



[jira] Commented: (QPID-2248) QMF: proposed API for QMFv2

2009-12-05 Thread Carl Trieloff (JIRA)

[ 
https://issues.apache.org/jira/browse/QPID-2248?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12786418#action_12786418
 ] 

Carl Trieloff commented on QPID-2248:
-


why did we remove the distinction between properties and statistics?

> QMF: proposed API for QMFv2 
> 
>
> Key: QPID-2248
> URL: https://issues.apache.org/jira/browse/QPID-2248
> Project: Qpid
>  Issue Type: New Feature
>  Components: Qpid Managment Framework
>Reporter: Ken Giusti
>Assignee: Ted Ross
> Attachments: qmf-ng-api-12012009.txt, qmf-ng-api-12042009.patch, 
> qmf-ng-api-12042009.txt
>
>
> Track the evolution of the QMFv2 api document.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


-
Apache Qpid - AMQP Messaging Implementation
Project:  http://qpid.apache.org
Use/Interact: mailto:dev-subscr...@qpid.apache.org