[jira] [Commented] (SLING-3169) Job state and related enumerations

2013-10-16 Thread Stefan Seifert (JIRA)

[ 
https://issues.apache.org/jira/browse/SLING-3169?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13797264#comment-13797264
 ] 

Stefan Seifert commented on SLING-3169:
---

thanks!

> Job state and related enumerations
> --
>
> Key: SLING-3169
> URL: https://issues.apache.org/jira/browse/SLING-3169
> Project: Sling
>  Issue Type: New Feature
>  Components: Extensions
>Reporter: Carsten Ziegeler
>Assignee: Carsten Ziegeler
> Fix For: Extensions Event 3.3.0
>
>
> This is a follow up from SLING-3028 based on comments by Stefan Seifert:
> I find the enum name Job.JobType not ideal, because it does not stand of 
> a type but for a state of the job. But there is a JobState enum in the 
> consumer API package already.
> I find the enum and class names JobState and JobStatus in the consumer 
> package not ideal, because they do not stand for a state, but for a job 
> result.
>   



--
This message was sent by Atlassian JIRA
(v6.1#6144)


[jira] [Commented] (SLING-3169) Job state and related enumerations

2013-10-16 Thread Stefan Seifert (JIRA)

[ 
https://issues.apache.org/jira/browse/SLING-3169?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13796555#comment-13796555
 ] 

Stefan Seifert commented on SLING-3169:
---

from a job admin GUI perspective if find this a good solution to be sure what 
happened with the job exactly if it was not successful.

> Job state and related enumerations
> --
>
> Key: SLING-3169
> URL: https://issues.apache.org/jira/browse/SLING-3169
> Project: Sling
>  Issue Type: New Feature
>  Components: Extensions
>Reporter: Carsten Ziegeler
>Assignee: Carsten Ziegeler
> Fix For: Extensions Event 3.3.0
>
>
> This is a follow up from SLING-3028 based on comments by Stefan Seifert:
> I find the enum name Job.JobType not ideal, because it does not stand of 
> a type but for a state of the job. But there is a JobState enum in the 
> consumer API package already.
> I find the enum and class names JobState and JobStatus in the consumer 
> package not ideal, because they do not stand for a state, but for a job 
> result.
>   



--
This message was sent by Atlassian JIRA
(v6.1#6144)


[jira] [Commented] (SLING-3169) Job state and related enumerations

2013-10-16 Thread Carsten Ziegeler (JIRA)

[ 
https://issues.apache.org/jira/browse/SLING-3169?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13796544#comment-13796544
 ] 

Carsten Ziegeler commented on SLING-3169:
-

I could imagine the following enum:

enum JobState {
  QUEUED, // waiting in queue after adding or for restart after failing
  ACTIVE,   // job is currently processed
  SUCCEEDED,  // processing finished successfully
  STOPPED,  // processing was stopped by a user
  GIVEN_UP // number of retries reached
  ERROR  // processing signaled CANCELLED or throw an exception
  DROPPED // dropped due to queue configuration

};

[~sseif...@pro-vision.de] WDYT?

> Job state and related enumerations
> --
>
> Key: SLING-3169
> URL: https://issues.apache.org/jira/browse/SLING-3169
> Project: Sling
>  Issue Type: New Feature
>  Components: Extensions
>Reporter: Carsten Ziegeler
>Assignee: Carsten Ziegeler
> Fix For: Extensions Event 3.3.0
>
>
> This is a follow up from SLING-3028 based on comments by Stefan Seifert:
> I find the enum name Job.JobType not ideal, because it does not stand of 
> a type but for a state of the job. But there is a JobState enum in the 
> consumer API package already.
> I find the enum and class names JobState and JobStatus in the consumer 
> package not ideal, because they do not stand for a state, but for a job 
> result.
>   



--
This message was sent by Atlassian JIRA
(v6.1#6144)


[jira] [Commented] (SLING-3169) Job state and related enumerations

2013-10-16 Thread Stefan Seifert (JIRA)

[ 
https://issues.apache.org/jira/browse/SLING-3169?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13796541#comment-13796541
 ] 

Stefan Seifert commented on SLING-3169:
---

good solution for the ResultBuilder interface.

concerning the JobState: you are right. i think the enum names/method names are 
not fully intuitive for ones that have used similar states in other systems but 
with different meanings. so for the JobState from the job endinge POV the 
states are fine (although it had used FAILED instead of CANCELLED, but this is 
only my personal preference, i'm fine with CANCELLED as well). but now its in 
synch with the old JobResult enum from the JobConsumer interface, so it's at 
least consistent now.

together with the javadocs the methods in the ResultBuilder method should be 
clear now.

> Job state and related enumerations
> --
>
> Key: SLING-3169
> URL: https://issues.apache.org/jira/browse/SLING-3169
> Project: Sling
>  Issue Type: New Feature
>  Components: Extensions
>Reporter: Carsten Ziegeler
>Assignee: Carsten Ziegeler
> Fix For: Extensions Event 3.3.0
>
>
> This is a follow up from SLING-3028 based on comments by Stefan Seifert:
> I find the enum name Job.JobType not ideal, because it does not stand of 
> a type but for a state of the job. But there is a JobState enum in the 
> consumer API package already.
> I find the enum and class names JobState and JobStatus in the consumer 
> package not ideal, because they do not stand for a state, but for a job 
> result.
>   



--
This message was sent by Atlassian JIRA
(v6.1#6144)