Re: Article: Functional image processing in D

2014-03-22 Thread Philippe Sigaud
On Fri, Mar 21, 2014 at 12:04 PM, Vladimir Panteleev
vladi...@thecybershadow.net wrote:
 http://blog.thecybershadow.net/2014/03/21/functional-image-processing-in-d/

 Some highlights from a recent overhaul of the graphics package from my D
 library. It makes use of a number of D-specific language features, so I've
 tried to make the article accessible to people new to D as well.

The article is wonderful, very clear and a good introduction to many D
idioms. I'd like to use your graphics package as well, but I don't see
any documentation (ddoc, wiki?). Is there some somewhere?


Re: Article: Functional image processing in D

2014-03-22 Thread Graham Fawcett

On Saturday, 22 March 2014 at 13:35:01 UTC, Philippe Sigaud wrote:

On Fri, Mar 21, 2014 at 12:04 PM, Vladimir Panteleev
vladi...@thecybershadow.net wrote:

http://blog.thecybershadow.net/2014/03/21/functional-image-processing-in-d/

Some highlights from a recent overhaul of the graphics package 
from my D
library. It makes use of a number of D-specific language 
features, so I've
tried to make the article accessible to people new to D as 
well.


The article is wonderful, very clear and a good introduction to 
many D
idioms. I'd like to use your graphics package as well, but I 
don't see

any documentation (ddoc, wiki?). Is there some somewhere?


I think this is it:

https://github.com/CyberShadow/ae

Graham


Re: 1st draft of complete class-based std.random successor

2014-03-22 Thread bearophile

Joseph Rushton Wakeling:

Latest patches rename randomSample = sample, again offering a 
documented alias to assist migration.


Perhaps it's better to not document this alias.


permutation seems good to me (or permute?), but perhaps 
others have suggestions or can point to a typical naming 
practice from other languages?


I'd like a permutations() range in std.range or 
std.combinatorics.  permutation() sounds a bit too much close, 
despite it is inside another module.


Bye,
bearophile


Re: 1st draft of complete class-based std.random successor

2014-03-22 Thread Joseph Rushton Wakeling
Latest patches rename randomSample = sample, again offering a 
documented alias to assist migration.


It would be nice to complete the set and eliminate randomCover, 
but in this case cover seems too vague a name to use.  Any 
suggestions for alternatives?  I wasn't able to readily find an 
equivalent in other random number libraries.


permutation seems good to me (or permute?), but perhaps 
others have suggestions or can point to a typical naming practice 
from other languages?


Re: 1st draft of complete class-based std.random successor

2014-03-22 Thread Joseph Rushton Wakeling

On Saturday, 22 March 2014 at 20:09:00 UTC, bearophile wrote:

Perhaps it's better to not document this alias.


For now it will be documented, for clarity if nothing else.  
Whether that documentation makes it into a Phobos submission, I 
think should depend on formal review.


I'd like a permutations() range in std.range or 
std.combinatorics.  permutation() sounds a bit too much close, 
despite it is inside another module.


How does your desired concept relate to the existing 
std.algorithm.nextPermutation ... ?


Re: 1st draft of complete class-based std.random successor

2014-03-22 Thread bearophile

Joseph Rushton Wakeling:

How does your desired concept relate to the existing 
std.algorithm.nextPermutation ... ?


The API of the lazy permutations/combinations ranges is similar 
to the one I have written here:

http://rosettacode.org/wiki/Permutations#Fast_Lazy_Version

That is also very similar to the permutations/combinations here 
(with the r optional argument):

http://docs.python.org/2/library/itertools.html


To the one in Phobos is used like:

auto items = [1, 2, 3];
do
writeln(items);
while (items.nextPermutation());


The permutations/combinations range is used like (the boolean 
template argument is to specify if it has to copy the buffer or 
not):


[1, 2, 3].permutations!false.writeln;

Bye,
bearophile


Re: Article: Functional image processing in D

2014-03-22 Thread Philippe Sigaud
On Sat, Mar 22, 2014 at 4:10 PM, Graham Fawcett fawc...@uwindsor.ca wrote:

 I think this is it:

 https://github.com/CyberShadow/ae

Hmm, there is the /demo directory, that can be useful. But I don't see
any documentation per se.


Re: 1st draft of complete class-based std.random successor

2014-03-22 Thread Joseph Rushton Wakeling
Latest patches just pushed to repo make the randomSample = 
sample change and introduce a fast uniform01 and 
uniform01Distribution :-)


Re: 1st draft of complete class-based std.random successor

2014-03-22 Thread bearophile

Joseph Rushton Wakeling:

Latest patches just pushed to repo make the randomSample = 
sample change and introduce a fast uniform01 and 
uniform01Distribution :-)


They seem good.

More ideas:

Three suggestions for std.random:
https://d.puremagic.com/issues/show_bug.cgi?id=4851

Strongly pure random generator:
https://d.puremagic.com/issues/show_bug.cgi?id=5249

I hope a gaussian (normal distribution) generator is planned or 
present.


Bye,
bearophile


Happy Tenth Birthday, GDC!

2014-03-22 Thread Andrei Alexandrescu

Hello everyone,


Today GDC celebrates 10 years of existence.

Please join me in expressing sincere congratulations to everyone who 
contributed to the project. I would like to emphasize that GDC is a key 
component of D's present and future success, and I am looking forward to 
more awesome progress from Iain, Johannes and hopefully an ever-growing 
gang!



Happy Birthday!

Andrei


Re: Happy Tenth Birthday, GDC!

2014-03-22 Thread Rikki Cattermole
On Sunday, 23 March 2014 at 02:06:13 UTC, Andrei Alexandrescu 
wrote:

Hello everyone,


Today GDC celebrates 10 years of existence.

Please join me in expressing sincere congratulations to 
everyone who contributed to the project. I would like to 
emphasize that GDC is a key component of D's present and future 
success, and I am looking forward to more awesome progress from 
Iain, Johannes and hopefully an ever-growing gang!



Happy Birthday!

Andrei


So who brought the cake? It better not be GLaDOS ;)

Keep up the good work guys! Its really appreciated.