[PATCH 07/12] drm/rcar-du: Rename async to nonblock.

2016-04-27 Thread Laurent Pinchart
Hi Maarten,

Thank you for the patch.

On Tuesday 26 Apr 2016 16:11:40 Maarten Lankhorst wrote:
> The async name is deprecated and should be changed to nonblocking.
> 
> Cc: Laurent Pinchart 
> Signed-off-by: Maarten Lankhorst 

Acked-by: Laurent Pinchart 

> ---
>  drivers/gpu/drm/rcar-du/rcar_du_kms.c | 5 +++--
>  1 file changed, 3 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/gpu/drm/rcar-du/rcar_du_kms.c
> b/drivers/gpu/drm/rcar-du/rcar_du_kms.c index 24725bf859b4..e70a4f33d970
> 100644
> --- a/drivers/gpu/drm/rcar-du/rcar_du_kms.c
> +++ b/drivers/gpu/drm/rcar-du/rcar_du_kms.c
> @@ -283,7 +283,8 @@ static void rcar_du_atomic_work(struct work_struct
> *work) }
> 
>  static int rcar_du_atomic_commit(struct drm_device *dev,
> -  struct drm_atomic_state *state, bool async)
> +  struct drm_atomic_state *state,
> +  bool nonblock)
>  {
>   struct rcar_du_device *rcdu = dev->dev_private;
>   struct rcar_du_commit *commit;
> @@ -328,7 +329,7 @@ static int rcar_du_atomic_commit(struct drm_device *dev,
> /* Swap the state, this is the point of no return. */
>   drm_atomic_helper_swap_state(dev, state);
> 
> - if (async)
> + if (nonblock)
>   schedule_work(&commit->work);
>   else
>   rcar_du_atomic_complete(commit);

-- 
Regards,

Laurent Pinchart



[PATCH 07/12] drm/rcar-du: Rename async to nonblock.

2016-04-26 Thread Maarten Lankhorst
The async name is deprecated and should be changed to nonblocking.

Cc: Laurent Pinchart 
Signed-off-by: Maarten Lankhorst 
---
 drivers/gpu/drm/rcar-du/rcar_du_kms.c | 5 +++--
 1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/rcar-du/rcar_du_kms.c 
b/drivers/gpu/drm/rcar-du/rcar_du_kms.c
index 24725bf859b4..e70a4f33d970 100644
--- a/drivers/gpu/drm/rcar-du/rcar_du_kms.c
+++ b/drivers/gpu/drm/rcar-du/rcar_du_kms.c
@@ -283,7 +283,8 @@ static void rcar_du_atomic_work(struct work_struct *work)
 }

 static int rcar_du_atomic_commit(struct drm_device *dev,
-struct drm_atomic_state *state, bool async)
+struct drm_atomic_state *state,
+bool nonblock)
 {
struct rcar_du_device *rcdu = dev->dev_private;
struct rcar_du_commit *commit;
@@ -328,7 +329,7 @@ static int rcar_du_atomic_commit(struct drm_device *dev,
/* Swap the state, this is the point of no return. */
drm_atomic_helper_swap_state(dev, state);

-   if (async)
+   if (nonblock)
schedule_work(&commit->work);
else
rcar_du_atomic_complete(commit);
-- 
2.5.5