Re: [PATCH 1/9] drm: Move the GET_CAP macros next to the corresponding ioctl structure

2013-09-08 Thread David Herrmann
Hi

On Fri, Sep 6, 2013 at 8:57 PM, Damien Lespiau damien.lesp...@intel.com wrote:
 It's a tiny bit more logical to find the different capabilities you can
 use with the GET_CAP ioctl next to the structure rather than putting
 them at the end of the file.

 Signed-off-by: Damien Lespiau damien.lesp...@intel.com
 ---
  include/uapi/drm/drm.h | 20 ++--
  1 file changed, 10 insertions(+), 10 deletions(-)

 diff --git a/include/uapi/drm/drm.h b/include/uapi/drm/drm.h
 index 272580c..4b683f9 100644
 --- a/include/uapi/drm/drm.h
 +++ b/include/uapi/drm/drm.h
 @@ -611,6 +611,16 @@ struct drm_gem_open {
 __u64 size;
  };

 +#define DRM_CAP_DUMB_BUFFER 0x1
 +#define DRM_CAP_VBLANK_HIGH_CRTC 0x2
 +#define DRM_CAP_DUMB_PREFERRED_DEPTH 0x3
 +#define DRM_CAP_DUMB_PREFER_SHADOW 0x4
 +#define DRM_CAP_PRIME 0x5
 +#define DRM_CAP_TIMESTAMP_MONOTONIC 0x6
 +
 +#define DRM_PRIME_CAP_IMPORT 0x1
 +#define DRM_PRIME_CAP_EXPORT 0x2
 +

Makes sense. Would you mind also adding tabs between the name and
literal? Makes it much more readable. And I think it's fine to use
moves to fix coding-style issues.

Thanks
David

  /** DRM_IOCTL_GET_CAP ioctl argument type */
  struct drm_get_cap {
 __u64 capability;
 @@ -774,16 +784,6 @@ struct drm_event_vblank {
 __u32 reserved;
  };

 -#define DRM_CAP_DUMB_BUFFER 0x1
 -#define DRM_CAP_VBLANK_HIGH_CRTC 0x2
 -#define DRM_CAP_DUMB_PREFERRED_DEPTH 0x3
 -#define DRM_CAP_DUMB_PREFER_SHADOW 0x4
 -#define DRM_CAP_PRIME 0x5
 -#define DRM_CAP_TIMESTAMP_MONOTONIC 0x6
 -
 -#define DRM_PRIME_CAP_IMPORT 0x1
 -#define DRM_PRIME_CAP_EXPORT 0x2
 -
  /* typedef area */
  #ifndef __KERNEL__
  typedef struct drm_clip_rect drm_clip_rect_t;
 --
 1.8.3.1

 ___
 dri-devel mailing list
 dri-devel@lists.freedesktop.org
 http://lists.freedesktop.org/mailman/listinfo/dri-devel
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel


[PATCH 1/9] drm: Move the GET_CAP macros next to the corresponding ioctl structure

2013-09-06 Thread Damien Lespiau
It's a tiny bit more logical to find the different capabilities you can
use with the GET_CAP ioctl next to the structure rather than putting
them at the end of the file.

Signed-off-by: Damien Lespiau damien.lesp...@intel.com
---
 include/uapi/drm/drm.h | 20 ++--
 1 file changed, 10 insertions(+), 10 deletions(-)

diff --git a/include/uapi/drm/drm.h b/include/uapi/drm/drm.h
index 272580c..4b683f9 100644
--- a/include/uapi/drm/drm.h
+++ b/include/uapi/drm/drm.h
@@ -611,6 +611,16 @@ struct drm_gem_open {
__u64 size;
 };
 
+#define DRM_CAP_DUMB_BUFFER 0x1
+#define DRM_CAP_VBLANK_HIGH_CRTC 0x2
+#define DRM_CAP_DUMB_PREFERRED_DEPTH 0x3
+#define DRM_CAP_DUMB_PREFER_SHADOW 0x4
+#define DRM_CAP_PRIME 0x5
+#define DRM_CAP_TIMESTAMP_MONOTONIC 0x6
+
+#define DRM_PRIME_CAP_IMPORT 0x1
+#define DRM_PRIME_CAP_EXPORT 0x2
+
 /** DRM_IOCTL_GET_CAP ioctl argument type */
 struct drm_get_cap {
__u64 capability;
@@ -774,16 +784,6 @@ struct drm_event_vblank {
__u32 reserved;
 };
 
-#define DRM_CAP_DUMB_BUFFER 0x1
-#define DRM_CAP_VBLANK_HIGH_CRTC 0x2
-#define DRM_CAP_DUMB_PREFERRED_DEPTH 0x3
-#define DRM_CAP_DUMB_PREFER_SHADOW 0x4
-#define DRM_CAP_PRIME 0x5
-#define DRM_CAP_TIMESTAMP_MONOTONIC 0x6
-
-#define DRM_PRIME_CAP_IMPORT 0x1
-#define DRM_PRIME_CAP_EXPORT 0x2
-
 /* typedef area */
 #ifndef __KERNEL__
 typedef struct drm_clip_rect drm_clip_rect_t;
-- 
1.8.3.1

___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel