Re: [PATCH v2 1/4] drm/dp_mst: Rename drm_dp_mst_is_dp_mst_end_device() to be less redundant

2020-03-09 Thread Alex Deucher
On Fri, Mar 6, 2020 at 6:46 PM Lyude Paul  wrote:
>
> It's already prefixed by dp_mst, so we don't really need to repeat
> ourselves here. One of the changes I should have picked up originally
> when reviewing MST DSC support.
>
> There should be no functional changes here
>
> Cc: Mikita Lipski 
> Cc: Sean Paul 
> Cc: Hans de Goede 
> Signed-off-by: Lyude Paul 

Reviewed-by: Alex Deucher 

> ---
>  drivers/gpu/drm/drm_dp_mst_topology.c | 10 +-
>  1 file changed, 5 insertions(+), 5 deletions(-)
>
> diff --git a/drivers/gpu/drm/drm_dp_mst_topology.c 
> b/drivers/gpu/drm/drm_dp_mst_topology.c
> index 6c62ad8f4414..6714d8a5c558 100644
> --- a/drivers/gpu/drm/drm_dp_mst_topology.c
> +++ b/drivers/gpu/drm/drm_dp_mst_topology.c
> @@ -1937,7 +1937,7 @@ static u8 drm_dp_calculate_rad(struct drm_dp_mst_port 
> *port,
> return parent_lct + 1;
>  }
>
> -static bool drm_dp_mst_is_dp_mst_end_device(u8 pdt, bool mcs)
> +static bool drm_dp_mst_is_end_device(u8 pdt, bool mcs)
>  {
> switch (pdt) {
> case DP_PEER_DEVICE_DP_LEGACY_CONV:
> @@ -1967,13 +1967,13 @@ drm_dp_port_set_pdt(struct drm_dp_mst_port *port, u8 
> new_pdt,
>
> /* Teardown the old pdt, if there is one */
> if (port->pdt != DP_PEER_DEVICE_NONE) {
> -   if (drm_dp_mst_is_dp_mst_end_device(port->pdt, port->mcs)) {
> +   if (drm_dp_mst_is_end_device(port->pdt, port->mcs)) {
> /*
>  * If the new PDT would also have an i2c bus,
>  * don't bother with reregistering it
>  */
> if (new_pdt != DP_PEER_DEVICE_NONE &&
> -   drm_dp_mst_is_dp_mst_end_device(new_pdt, 
> new_mcs)) {
> +   drm_dp_mst_is_end_device(new_pdt, new_mcs)) {
> port->pdt = new_pdt;
> port->mcs = new_mcs;
> return 0;
> @@ -1993,7 +1993,7 @@ drm_dp_port_set_pdt(struct drm_dp_mst_port *port, u8 
> new_pdt,
> port->mcs = new_mcs;
>
> if (port->pdt != DP_PEER_DEVICE_NONE) {
> -   if (drm_dp_mst_is_dp_mst_end_device(port->pdt, port->mcs)) {
> +   if (drm_dp_mst_is_end_device(port->pdt, port->mcs)) {
> /* add i2c over sideband */
> ret = drm_dp_mst_register_i2c_bus(>aux);
> } else {
> @@ -2169,7 +2169,7 @@ drm_dp_mst_port_add_connector(struct drm_dp_mst_branch 
> *mstb,
> }
>
> if (port->pdt != DP_PEER_DEVICE_NONE &&
> -   drm_dp_mst_is_dp_mst_end_device(port->pdt, port->mcs)) {
> +   drm_dp_mst_is_end_device(port->pdt, port->mcs)) {
> port->cached_edid = drm_get_edid(port->connector,
>  >aux.ddc);
> drm_connector_set_tile_property(port->connector);
> --
> 2.24.1
>
> ___
> dri-devel mailing list
> dri-devel@lists.freedesktop.org
> https://lists.freedesktop.org/mailman/listinfo/dri-devel
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel


[PATCH v2 1/4] drm/dp_mst: Rename drm_dp_mst_is_dp_mst_end_device() to be less redundant

2020-03-06 Thread Lyude Paul
It's already prefixed by dp_mst, so we don't really need to repeat
ourselves here. One of the changes I should have picked up originally
when reviewing MST DSC support.

There should be no functional changes here

Cc: Mikita Lipski 
Cc: Sean Paul 
Cc: Hans de Goede 
Signed-off-by: Lyude Paul 
---
 drivers/gpu/drm/drm_dp_mst_topology.c | 10 +-
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/drivers/gpu/drm/drm_dp_mst_topology.c 
b/drivers/gpu/drm/drm_dp_mst_topology.c
index 6c62ad8f4414..6714d8a5c558 100644
--- a/drivers/gpu/drm/drm_dp_mst_topology.c
+++ b/drivers/gpu/drm/drm_dp_mst_topology.c
@@ -1937,7 +1937,7 @@ static u8 drm_dp_calculate_rad(struct drm_dp_mst_port 
*port,
return parent_lct + 1;
 }
 
-static bool drm_dp_mst_is_dp_mst_end_device(u8 pdt, bool mcs)
+static bool drm_dp_mst_is_end_device(u8 pdt, bool mcs)
 {
switch (pdt) {
case DP_PEER_DEVICE_DP_LEGACY_CONV:
@@ -1967,13 +1967,13 @@ drm_dp_port_set_pdt(struct drm_dp_mst_port *port, u8 
new_pdt,
 
/* Teardown the old pdt, if there is one */
if (port->pdt != DP_PEER_DEVICE_NONE) {
-   if (drm_dp_mst_is_dp_mst_end_device(port->pdt, port->mcs)) {
+   if (drm_dp_mst_is_end_device(port->pdt, port->mcs)) {
/*
 * If the new PDT would also have an i2c bus,
 * don't bother with reregistering it
 */
if (new_pdt != DP_PEER_DEVICE_NONE &&
-   drm_dp_mst_is_dp_mst_end_device(new_pdt, new_mcs)) {
+   drm_dp_mst_is_end_device(new_pdt, new_mcs)) {
port->pdt = new_pdt;
port->mcs = new_mcs;
return 0;
@@ -1993,7 +1993,7 @@ drm_dp_port_set_pdt(struct drm_dp_mst_port *port, u8 
new_pdt,
port->mcs = new_mcs;
 
if (port->pdt != DP_PEER_DEVICE_NONE) {
-   if (drm_dp_mst_is_dp_mst_end_device(port->pdt, port->mcs)) {
+   if (drm_dp_mst_is_end_device(port->pdt, port->mcs)) {
/* add i2c over sideband */
ret = drm_dp_mst_register_i2c_bus(>aux);
} else {
@@ -2169,7 +2169,7 @@ drm_dp_mst_port_add_connector(struct drm_dp_mst_branch 
*mstb,
}
 
if (port->pdt != DP_PEER_DEVICE_NONE &&
-   drm_dp_mst_is_dp_mst_end_device(port->pdt, port->mcs)) {
+   drm_dp_mst_is_end_device(port->pdt, port->mcs)) {
port->cached_edid = drm_get_edid(port->connector,
 >aux.ddc);
drm_connector_set_tile_property(port->connector);
-- 
2.24.1

___
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel