Re: [PATCH v2 1/8] dt-bindings: display/msm/dsi: allow specifying TE source

2024-06-19 Thread Abhinav Kumar




On 6/13/2024 10:05 AM, Dmitry Baryshkov wrote:

Command mode panels provide TE signal back to the DSI host to signal
that the frame display has completed and update of the image will not
cause tearing. Usually it is connected to the first GPIO with the
mdp_vsync function, which is the default. In such case the property can
be skipped.

Acked-by: Krzysztof Kozlowski 
Reviewed-by: Rob Herring (Arm) 
Signed-off-by: Dmitry Baryshkov 
---
  .../bindings/display/msm/dsi-controller-main.yaml   | 17 +
  1 file changed, 17 insertions(+)



Reviewed-by: Abhinav Kumar 


Re: [PATCH v2 1/8] dt-bindings: display/msm/dsi: allow specifying TE source

2024-06-13 Thread Dmitry Baryshkov
On Thu, 13 Jun 2024 at 21:16, Marijn Suijten
 wrote:
>
> On 2024-06-13 20:05:04, Dmitry Baryshkov wrote:
> > Command mode panels provide TE signal back to the DSI host to signal
> > that the frame display has completed and update of the image will not
> > cause tearing. Usually it is connected to the first GPIO with the
> > mdp_vsync function, which is the default. In such case the property can
> > be skipped.
> >
> > Acked-by: Krzysztof Kozlowski 
> > Reviewed-by: Rob Herring (Arm) 
> > Signed-off-by: Dmitry Baryshkov 
> > ---
> >  .../bindings/display/msm/dsi-controller-main.yaml   | 17 
> > +
> >  1 file changed, 17 insertions(+)
> >
> > diff --git 
> > a/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml 
> > b/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml
> > index 1fa28e976559..e1cb3a1fee81 100644
> > --- a/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml
> > +++ b/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml
> > @@ -162,6 +162,22 @@ properties:
> >  items:
> >enum: [ 0, 1, 2, 3 ]
> >
> > +  qcom,te-source:
> > +$ref: /schemas/types.yaml#/definitions/string
> > +description:
> > +  Specifies the source of vsync signal from the panel used 
> > for
> > +  tearing elimination.
> > +default: mdp_vsync_p
> > +enum:
> > +  - mdp_vsync_p
> > +  - mdp_vsync_s
> > +  - mdp_vsync_e
>
> When discussing that these should be renamed, was it also documented what the
> suffix means?  I can only guess something like primary/secondary/e...?

external. Note, these names match the name in the datasheets.

>
> Are the mdp_intfX variants missing here that you're handling in patch 7/8?

I didn't test them, so I didn't document them.

>
> > +  - timer0
> > +  - timer1
> > +  - timer2
> > +  - timer3
> > +  - timer4
> > +
> >  required:
> >- port@0
> >- port@1
> > @@ -452,6 +468,7 @@ examples:
> >dsi0_out: endpoint {
> > remote-endpoint = <_in>;
> > data-lanes = <0 1 2 3>;
> > +   qcom,te-source = "mdp_vsync_e";
> >};
> >};
> > };
> >
> > --
> > 2.39.2
> >



-- 
With best wishes
Dmitry


Re: [PATCH v2 1/8] dt-bindings: display/msm/dsi: allow specifying TE source

2024-06-13 Thread Marijn Suijten
On 2024-06-13 20:05:04, Dmitry Baryshkov wrote:
> Command mode panels provide TE signal back to the DSI host to signal
> that the frame display has completed and update of the image will not
> cause tearing. Usually it is connected to the first GPIO with the
> mdp_vsync function, which is the default. In such case the property can
> be skipped.
> 
> Acked-by: Krzysztof Kozlowski 
> Reviewed-by: Rob Herring (Arm) 
> Signed-off-by: Dmitry Baryshkov 
> ---
>  .../bindings/display/msm/dsi-controller-main.yaml   | 17 
> +
>  1 file changed, 17 insertions(+)
> 
> diff --git 
> a/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml 
> b/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml
> index 1fa28e976559..e1cb3a1fee81 100644
> --- a/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml
> +++ b/Documentation/devicetree/bindings/display/msm/dsi-controller-main.yaml
> @@ -162,6 +162,22 @@ properties:
>  items:
>enum: [ 0, 1, 2, 3 ]
>  
> +  qcom,te-source:
> +$ref: /schemas/types.yaml#/definitions/string
> +description:
> +  Specifies the source of vsync signal from the panel used 
> for
> +  tearing elimination.
> +default: mdp_vsync_p
> +enum:
> +  - mdp_vsync_p
> +  - mdp_vsync_s
> +  - mdp_vsync_e

When discussing that these should be renamed, was it also documented what the
suffix means?  I can only guess something like primary/secondary/e...?

Are the mdp_intfX variants missing here that you're handling in patch 7/8?

> +  - timer0
> +  - timer1
> +  - timer2
> +  - timer3
> +  - timer4
> +
>  required:
>- port@0
>- port@1
> @@ -452,6 +468,7 @@ examples:
>dsi0_out: endpoint {
> remote-endpoint = <_in>;
> data-lanes = <0 1 2 3>;
> +   qcom,te-source = "mdp_vsync_e";
>};
>};
> };
> 
> -- 
> 2.39.2
>