Re: [stable] [PATCH] drm/kms: remove spaces from connector names

2010-12-13 Thread Sergej Pupykin
At Fri, 10 Dec 2010 19:05:13 +0100,
Peter Stuge pe...@stuge.se wrote:
 append can contain any arbitrary string, which will be parsed by the
 kernel. I e.g. use:

 append=root=/dev/sda2 snd_ac97_codec.power_save=1 usbcore.autosuspend=1 
 hpet=force quiet drm_kms_helper.poll=0

 And grub also supports an append string with spaces, that is probably
 used by every distribution.

 The question is, what will the kernel parser do about that space?

It seems lilo also have no support for such parameters.

append=video=9-pin DIN:1024x768...@60e

does not work (kernel panic: DIN: bad variable name)

As I understand, I should pass somehow to kernel string like:

video=9-pin DIN:1024x768...@60e, but lilo uses doublequotes as
r-value bounds.

in_quote variable in next_arg() is set only for  character.
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [stable] [PATCH] drm/kms: remove spaces from connector names

2010-12-13 Thread Sergej Pupykin
At Mon, 13 Dec 2010 13:43:48 +0300,
Sergej Pupykin m...@sergej.pp.ru wrote:

 video=9-pin DIN:1024x768...@60e, but lilo uses doublequotes as
 r-value bounds.
 
 in_quote variable in next_arg() is set only for  character.

Sorry, biggest part of this problem is in my linux distribution (in
/init executable from initcpio image)
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [stable] [PATCH] drm/kms: remove spaces from connector names

2010-12-10 Thread Sergej Pupykin
At Thu, 9 Dec 2010 09:18:14 -0800,
Jesse Barnes jbar...@virtuousgeek.org wrote:
 
 And it's ugly; can't we fix grub instead?

I am searching for bootloader which can pass whitespaces. It looks
like we should patch grub-legacy (0.97), grub (1.98) and lilo...

(I did not try lilo yet, but man page says nothing about passing
spaces in 'append=' option description)
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [stable] [PATCH] drm/kms: remove spaces from connector names

2010-12-10 Thread Peter Stuge
Sergej Pupykin wrote:
  And it's ugly; can't we fix grub instead?
 
 I am searching for bootloader which can pass whitespaces. It looks
 like we should patch grub-legacy (0.97), grub (1.98) and lilo...
 
 (I did not try lilo yet, but man page says nothing about passing
 spaces in 'append=' option description)

append can contain any arbitrary string, which will be parsed by the
kernel. I e.g. use:

append=root=/dev/sda2 snd_ac97_codec.power_save=1 usbcore.autosuspend=1 
hpet=force quiet drm_kms_helper.poll=0

And grub also supports an append string with spaces, that is probably
used by every distribution.

The question is, what will the kernel parser do about that space?


//Peter
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [stable] [PATCH] drm/kms: remove spaces from connector names

2010-12-09 Thread Jesse Barnes
On Wed, 8 Dec 2010 15:30:26 -0800
Greg KH g...@kroah.com wrote:

 On Wed, Dec 08, 2010 at 06:14:03PM -0500, Alex Deucher wrote:
  Grub doesn't parse spaces in parameters correctly, so
  this makes it impossible to force video= parameters
  for kms on the grub kernel command line.
  
  Reported-by: Sergej Pupykin m...@sergej.pp.ru
  
  Cc: Sergej Pupykin m...@sergej.pp.ru
  Signed-off-by: Alex Deucher alexdeuc...@gmail.com
  Cc: sta...@kernel.org
  ---
   drivers/gpu/drm/drm_crtc.c |8 
   1 files changed, 4 insertions(+), 4 deletions(-)
  
  diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
  index 6985cb1..7ee7a2f 100644
  --- a/drivers/gpu/drm/drm_crtc.c
  +++ b/drivers/gpu/drm/drm_crtc.c
  @@ -156,12 +156,12 @@ static struct drm_conn_prop_enum_list 
  drm_connector_enum_list[] =
  { DRM_MODE_CONNECTOR_SVIDEO, SVIDEO, 0 },
  { DRM_MODE_CONNECTOR_LVDS, LVDS, 0 },
  { DRM_MODE_CONNECTOR_Component, Component, 0 },
  -   { DRM_MODE_CONNECTOR_9PinDIN, 9-pin DIN, 0 },
 
 What kernel version did these options first show up in?  Does any
 other tools rely on the spaces?

And it's ugly; can't we fix grub instead?

-- 
Jesse Barnes, Intel Open Source Technology Center
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [stable] [PATCH] drm/kms: remove spaces from connector names

2010-12-09 Thread Sergej Pupykin
At Thu, 9 Dec 2010 09:18:14 -0800,
Jesse Barnes jbar...@virtuousgeek.org wrote:
 
 On Wed, 8 Dec 2010 15:30:26 -0800
 Greg KH g...@kroah.com wrote:
  What kernel version did these options first show up in?  Does any
  other tools rely on the spaces?
 
 And it's ugly; can't we fix grub instead?

I think renaming connectors is good idea anyway. It should be typed
before system boot, so names should be short and easy kept in mind.

Such as TV, DIN, VGA, DVI, etc...
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [stable] [PATCH] drm/kms: remove spaces from connector names

2010-12-09 Thread Peter Stuge
Jesse Barnes wrote:
 An alternative to fixing grub would be to add aliases like you mention,
 and/or change the parser to accept _ as an alias for  .  Then we
 could leave the sysfs values and string table alone.

Is it already case insensitive?


//Peter
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [stable] [PATCH] drm/kms: remove spaces from connector names

2010-12-08 Thread Greg KH
On Wed, Dec 08, 2010 at 06:14:03PM -0500, Alex Deucher wrote:
 Grub doesn't parse spaces in parameters correctly, so
 this makes it impossible to force video= parameters
 for kms on the grub kernel command line.
 
 Reported-by: Sergej Pupykin m...@sergej.pp.ru
 
 Cc: Sergej Pupykin m...@sergej.pp.ru
 Signed-off-by: Alex Deucher alexdeuc...@gmail.com
 Cc: sta...@kernel.org
 ---
  drivers/gpu/drm/drm_crtc.c |8 
  1 files changed, 4 insertions(+), 4 deletions(-)
 
 diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
 index 6985cb1..7ee7a2f 100644
 --- a/drivers/gpu/drm/drm_crtc.c
 +++ b/drivers/gpu/drm/drm_crtc.c
 @@ -156,12 +156,12 @@ static struct drm_conn_prop_enum_list 
 drm_connector_enum_list[] =
   { DRM_MODE_CONNECTOR_SVIDEO, SVIDEO, 0 },
   { DRM_MODE_CONNECTOR_LVDS, LVDS, 0 },
   { DRM_MODE_CONNECTOR_Component, Component, 0 },
 - { DRM_MODE_CONNECTOR_9PinDIN, 9-pin DIN, 0 },

What kernel version did these options first show up in?  Does any
other tools rely on the spaces?

thanks,

greg k-h
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel


Re: [stable] [PATCH] drm/kms: remove spaces from connector names

2010-12-08 Thread Dave Airlie
On Thu, Dec 9, 2010 at 9:30 AM, Greg KH g...@kroah.com wrote:
 On Wed, Dec 08, 2010 at 06:14:03PM -0500, Alex Deucher wrote:
 Grub doesn't parse spaces in parameters correctly, so
 this makes it impossible to force video= parameters
 for kms on the grub kernel command line.

 Reported-by: Sergej Pupykin m...@sergej.pp.ru

 Cc: Sergej Pupykin m...@sergej.pp.ru
 Signed-off-by: Alex Deucher alexdeuc...@gmail.com
 Cc: sta...@kernel.org
 ---
  drivers/gpu/drm/drm_crtc.c |    8 
  1 files changed, 4 insertions(+), 4 deletions(-)

 diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c
 index 6985cb1..7ee7a2f 100644
 --- a/drivers/gpu/drm/drm_crtc.c
 +++ b/drivers/gpu/drm/drm_crtc.c
 @@ -156,12 +156,12 @@ static struct drm_conn_prop_enum_list 
 drm_connector_enum_list[] =
       { DRM_MODE_CONNECTOR_SVIDEO, SVIDEO, 0 },
       { DRM_MODE_CONNECTOR_LVDS, LVDS, 0 },
       { DRM_MODE_CONNECTOR_Component, Component, 0 },
 -     { DRM_MODE_CONNECTOR_9PinDIN, 9-pin DIN, 0 },

 What kernel version did these options first show up in?  Does any
 other tools rely on the spaces?

No, X doesn't use the names and I can't think of anything shipped that
uses the interfaces that would care.

Dave.
___
dri-devel mailing list
dri-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/dri-devel