RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-09-06 Thread Dexuan Cui
> From: Bjorn Helgaas [mailto:helg...@kernel.org]
> Sent: Wednesday, September 7, 2016 1:25
> To: Dexuan Cui <de...@microsoft.com>
> Cc: Bjorn Helgaas <bhelg...@google.com>; linux-...@vger.kernel.org;
> gre...@linuxfoundation.org; KY Srinivasan <k...@microsoft.com>; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jasow...@redhat.com; vkuzn...@redhat.com; Haiyang
> Zhang <haiya...@microsoft.com>; Hadden Hoppert
> <hadd...@microsoft.com>; Stephen Hemminger <sthem...@microsoft.com>
> Subject: Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
> 
> On Tue, Aug 23, 2016 at 04:42:41AM +, Dexuan Cui wrote:
> >
> > 1. use zero-length array to make the code more readable.
> > 2. remove an unused struct member.
> > 3. small error handling improvement to some error cases.
> >
> > Dexuan Cui (5):
> >   PCI: hv: use zero-length message in struct pci_packet
> >   PCI: hv: use pci_function_description[0] in struct definitions
> >   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
> >   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
> >   PCI: hv: hv_pci_generic_compl(): handle the error case
> >
> >  drivers/pci/host/pci-hyperv.c | 56 
> > ++
> -
> >  1 file changed, 29 insertions(+), 27 deletions(-)
> 
> Applied with KY's ack to pci/host-hv for v4.9, thanks!

Thanks!

BTW, it looks I forgot to CC Jake Oshins somehow... sorry for that.

@Jake: these are just small cleanups. :-)

Thanks,
-- Dexuan
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-09-06 Thread Bjorn Helgaas
On Tue, Aug 23, 2016 at 04:42:41AM +, Dexuan Cui wrote:
> 
> 1. use zero-length array to make the code more readable.
> 2. remove an unused struct member.
> 3. small error handling improvement to some error cases.
> 
> Dexuan Cui (5):
>   PCI: hv: use zero-length message in struct pci_packet
>   PCI: hv: use pci_function_description[0] in struct definitions
>   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
>   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
>   PCI: hv: hv_pci_generic_compl(): handle the error case
> 
>  drivers/pci/host/pci-hyperv.c | 56 
> ++-
>  1 file changed, 29 insertions(+), 27 deletions(-)

Applied with KY's ack to pci/host-hv for v4.9, thanks!
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-09-06 Thread KY Srinivasan


> -Original Message-
> From: Bjorn Helgaas [mailto:helg...@kernel.org]
> Sent: Tuesday, September 6, 2016 9:11 PM
> To: Dexuan Cui <de...@microsoft.com>
> Cc: Bjorn Helgaas <bhelg...@google.com>; linux-...@vger.kernel.org;
> gre...@linuxfoundation.org; KY Srinivasan <k...@microsoft.com>; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jasow...@redhat.com; vkuzn...@redhat.com; Haiyang
> Zhang <haiya...@microsoft.com>; Hadden Hoppert
> <hadd...@microsoft.com>; Stephen Hemminger <sthem...@microsoft.com>
> Subject: Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
> 
> On Tue, Aug 23, 2016 at 04:42:41AM +, Dexuan Cui wrote:
> >
> > 1. use zero-length array to make the code more readable.
> > 2. remove an unused struct member.
> > 3. small error handling improvement to some error cases.
> >
> > Dexuan Cui (5):
> >   PCI: hv: use zero-length message in struct pci_packet
> >   PCI: hv: use pci_function_description[0] in struct definitions
> >   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
> >   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
> >   PCI: hv: hv_pci_generic_compl(): handle the error case
> >
> >  drivers/pci/host/pci-hyperv.c | 56 
> > ++
> -
> >  1 file changed, 29 insertions(+), 27 deletions(-)
> 
> I'm waiting for an ack from the Hyper-V maintainers:

I have Acked these patches.

K. Y
> 
>   Hyper-V CORE AND DRIVERS
>   M:  "K. Y. Srinivasan" <k...@microsoft.com>
>   M:  Haiyang Zhang <haiya...@microsoft.com>
>   L:  de...@linuxdriverproject.org
>   S:  Maintained
>   ...
>   F:  drivers/pci/host/pci-hyperv.c
>   ...
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


RE: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-09-06 Thread KY Srinivasan


> -Original Message-
> From: Dexuan Cui
> Sent: Tuesday, August 23, 2016 10:13 AM
> To: Bjorn Helgaas <bhelg...@google.com>; linux-...@vger.kernel.org;
> gre...@linuxfoundation.org; KY Srinivasan <k...@microsoft.com>; linux-
> ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de;
> a...@canonical.com; jasow...@redhat.com; vkuzn...@redhat.com; Haiyang
> Zhang <haiya...@microsoft.com>; Hadden Hoppert
> <hadd...@microsoft.com>; helg...@kernel.org; Stephen Hemminger
> <sthem...@microsoft.com>
> Subject: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups
> 
> 
> 1. use zero-length array to make the code more readable.
> 2. remove an unused struct member.
> 3. small error handling improvement to some error cases.
> 
> Dexuan Cui (5):
>   PCI: hv: use zero-length message in struct pci_packet
>   PCI: hv: use pci_function_description[0] in struct definitions
>   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
>   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
>   PCI: hv: hv_pci_generic_compl(): handle the error case

Acked-by: KY Srinivasan <k...@microsoft.com>

K. Y
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-09-06 Thread Bjorn Helgaas
On Tue, Aug 23, 2016 at 04:42:41AM +, Dexuan Cui wrote:
> 
> 1. use zero-length array to make the code more readable.
> 2. remove an unused struct member.
> 3. small error handling improvement to some error cases.
> 
> Dexuan Cui (5):
>   PCI: hv: use zero-length message in struct pci_packet
>   PCI: hv: use pci_function_description[0] in struct definitions
>   PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
>   PCI: hv: hv_compose_msi_msg: handle the 'ret' value
>   PCI: hv: hv_pci_generic_compl(): handle the error case
> 
>  drivers/pci/host/pci-hyperv.c | 56 
> ++-
>  1 file changed, 29 insertions(+), 27 deletions(-)

I'm waiting for an ack from the Hyper-V maintainers:

  Hyper-V CORE AND DRIVERS
  M:  "K. Y. Srinivasan" 
  M:  Haiyang Zhang 
  L:  de...@linuxdriverproject.org
  S:  Maintained
  ...
  F:  drivers/pci/host/pci-hyperv.c
  ...
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


[PATCH 0/5] PCI: hv: some minor bug fixes and cleanups

2016-08-22 Thread Dexuan Cui

1. use zero-length array to make the code more readable.
2. remove an unused struct member.
3. small error handling improvement to some error cases.

Dexuan Cui (5):
  PCI: hv: use zero-length message in struct pci_packet
  PCI: hv: use pci_function_description[0] in struct definitions
  PCI: hv: remove the unused 'wrk' in struct hv_pcibus_device
  PCI: hv: hv_compose_msi_msg: handle the 'ret' value
  PCI: hv: hv_pci_generic_compl(): handle the error case

 drivers/pci/host/pci-hyperv.c | 56 ++-
 1 file changed, 29 insertions(+), 27 deletions(-)

-- 
2.7.4

___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel