Re: [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable

2016-02-15 Thread Colin Vidal
On Sun, 2016-02-14 at 16:39 -0800, Greg Kroah-Hartman wrote:
> On Fri, Feb 12, 2016 at 07:05:53PM +0100, Colin Vidal wrote:
> > Signed-off-by: Colin Vidal 
> > ---
> >  drivers/staging/rtl8188eu/core/rtw_iol.c | 10 +++---
> >  1 file changed, 3 insertions(+), 7 deletions(-)
> > 
> > diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c
> > b/drivers/staging/rtl8188eu/core/rtw_iol.c
> > index 2e2145c..ba6c492 100644
> > --- a/drivers/staging/rtl8188eu/core/rtw_iol.c
> > +++ b/drivers/staging/rtl8188eu/core/rtw_iol.c
> > @@ -18,11 +18,7 @@
> >  
> >  bool rtw_IOL_applied(struct adapter *adapter)
> >  {
> > -   if (adapter->registrypriv.fw_iol == 1)
> > -   return true;
> > -
> > -   if ((adapter->registrypriv.fw_iol == 2) &&
> > -   (!adapter_to_dvobj(adapter)->ishighspeed))
> > -   return true;
> > -   return false;
> > +   return adapter->registrypriv.fw_iol == 1 ||
> > +   (adapter->registrypriv.fw_iol == 2 &&
> > +    !adapter_to_dvobj(adapter)->ishighspeed);
> >  }
> 
> I'm sorry, but this patch does not do what you said it does, it's
> much
> harder to read now :(
> 
> Also, I can't take a patch without a changelog text :(
> 
> thanks,
> 
> greg k-h

Hi Greg,

Thanks for you replie!

OK, I thought it was a better idea (as suggests Joe Perches) to group
the test in a way to avoid multiples - and maybe confusing - returns.
So, I'll remove this one.

Sorry about the changelot, I missed it while making patch series, I'll
resend it.

Thanks,

Colin
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel


Re: [PATCH v3 5/5] Staging: rtl8188eu/core: make core more readable

2016-02-14 Thread Greg Kroah-Hartman
On Fri, Feb 12, 2016 at 07:05:53PM +0100, Colin Vidal wrote:
> Signed-off-by: Colin Vidal 
> ---
>  drivers/staging/rtl8188eu/core/rtw_iol.c | 10 +++---
>  1 file changed, 3 insertions(+), 7 deletions(-)
> 
> diff --git a/drivers/staging/rtl8188eu/core/rtw_iol.c 
> b/drivers/staging/rtl8188eu/core/rtw_iol.c
> index 2e2145c..ba6c492 100644
> --- a/drivers/staging/rtl8188eu/core/rtw_iol.c
> +++ b/drivers/staging/rtl8188eu/core/rtw_iol.c
> @@ -18,11 +18,7 @@
>  
>  bool rtw_IOL_applied(struct adapter *adapter)
>  {
> - if (adapter->registrypriv.fw_iol == 1)
> - return true;
> -
> - if ((adapter->registrypriv.fw_iol == 2) &&
> - (!adapter_to_dvobj(adapter)->ishighspeed))
> - return true;
> - return false;
> + return adapter->registrypriv.fw_iol == 1 ||
> + (adapter->registrypriv.fw_iol == 2 &&
> +  !adapter_to_dvobj(adapter)->ishighspeed);
>  }

I'm sorry, but this patch does not do what you said it does, it's much
harder to read now :(

Also, I can't take a patch without a changelog text :(

thanks,

greg k-h
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel