Re: [dwm] Java patch

2008-05-14 Thread Anselm R. Garbe
Hi any joy regarding this?

Kind regards,
 Anselm

On Tue, Apr 29, 2008 at 09:22:08AM -0300, Luiz Ribeiro wrote:
 Great idea!
 I'll work on it and post the source code later.
 
 On Tue, Apr 29, 2008 at 7:57 AM, Tuncer Ayaz [EMAIL PROTECTED] wrote:
 
  On Tue, Apr 29, 2008 at 12:56 PM, Tuncer Ayaz [EMAIL PROTECTED] wrote:
   
On Tue, Apr 29, 2008 at 11:27 AM, Anselm R. Garbe [EMAIL PROTECTED] 
  wrote:
 
  On Sun, Apr 27, 2008 at 01:43:14PM -0700, Don Stewart wrote:
luizribeiro:
 On Sun, Apr 27, 2008 at 4:59 PM, Jukka Salmi [EMAIL PROTECTED] 
  wrote:
   It doesn't work for me. Just tested with jdk 1.5.0 and 
  netbeans...

 I think the LG3D Java compatibility came with jdk 1.6. Remember 
  that
 the hack sets the NET_WM_NAME to LG3D.
 Maybe setting it to a different name could work with jdk 1.5. 
  But I'm
 not sure about that, or what window manager name you should use.
   
This patch has been in xmonad for a while, there's some more
documentation here,
   
  
  http://xmonad.org/xmonad-docs/xmonad-contrib/XMonad-Hooks-SetWMName.html
   
Several users have reported this as useful.
   
 
   So why not converting this patch into a standalone setwmname
   application written in C, then we can delete the patches in dwm
   and XMonad and people just run setwmname FooBarBaz to work
   around the XToolkit bug(s)?
   
 assuming that's possible, +1.
 
   I still prefer using a fixed OpenJDK-6 build, btw.
 
 
 
 
 
 -- 
 Luiz Ribeiro
 http://luizribeiro.org/
 

-- 
 Anselm R. Garbe  http://www.suckless.org/  GPG key: 0D73F361



Re: [dwm] more consistent codestyle patch

2008-05-14 Thread Marc Andre Tanner
On Tue, May 13, 2008 at 06:08:59PM +0200, Szabolcs Nagy wrote:
 On 5/13/08, Diego Biurrun [EMAIL PROTECTED] wrote:
 XGrabButton(dpy, AnyButton, AnyModifier, c-win, False,
   - BUTTONMASK, GrabModeAsync, GrabModeSync, None, 
   None);
   + BUTTONMASK, GrabModeAsync, GrabModeSync, None, None);
 
  Well, before it was indented to align with the XGrabButton call.  This
 
 used spaces to achieve this which is wrong

A lot of people seem to argue over tab vs. spaces but somehow don't realize
that the best (at least in my opinion) is to combine them in a smart
way. That is, use tabs for indention and spaces for further alignment:

---XGrabButton(dpy, AnyButton, AnyModifier, c-win, False,
---BUTTONMASK, GrabModeAsync, GrabModeSync, None, None);

This way the user can set the tabwidth to whatever he likes and the code
will still look decent.

Regards,
Marc

-- 
 Marc Andre Tanner  http://www.brain-dump.org/  GPG key: CF7D56C0



Re: [dwm] [ANNOUNCE] dvtm-0.4.1

2008-05-14 Thread Marc Andre Tanner
Hi,

 Hi Marc,
 
 I tried using dvtm in console (using frame buffer) and I had a few
 problems: 
 
 * Fonts in Midnight Commander looks terrible

I can't reproduce it here, did you compile it with make unicode?

 * Background color from vim gets stuck after closing program

What exactly do you mean by that? Didn't notice it so far.

Thanks,
Marc

-- 
 Marc Andre Tanner  http://www.brain-dump.org/  GPG key: CF7D56C0



Re: [dwm] more consistent codestyle patch

2008-05-14 Thread Anselm R. Garbe
On Wed, May 14, 2008 at 03:54:10PM +0200, Marc Andre Tanner wrote:
 On Tue, May 13, 2008 at 06:08:59PM +0200, Szabolcs Nagy wrote:
  On 5/13/08, Diego Biurrun [EMAIL PROTECTED] wrote:
XGrabButton(dpy, AnyButton, AnyModifier, c-win, False,
-   BUTTONMASK, GrabModeAsync, GrabModeSync, 
None, None);
+   BUTTONMASK, GrabModeAsync, GrabModeSync, None, 
None);
  
   Well, before it was indented to align with the XGrabButton call.  This
  
  used spaces to achieve this which is wrong
 
 A lot of people seem to argue over tab vs. spaces but somehow don't realize
 that the best (at least in my opinion) is to combine them in a smart
 way. That is, use tabs for indention and spaces for further alignment:
 
 ---XGrabButton(dpy, AnyButton, AnyModifier, c-win, False,
 ---BUTTONMASK, GrabModeAsync, GrabModeSync, None, None);
 
 This way the user can set the tabwidth to whatever he likes and the code
 will still look decent.

Actually that's the way I intend to have the source code -- imho
I used this already quite a lot.

I didn't bother that much so far, because I'm going to polish
the code anyways for the upcoming dwm-5.0 release.

Kind regards,
-- 
 Anselm R. Garbe  http://www.suckless.org/  GPG key: 0D73F361



Re: [dwm] more consistent codestyle patch

2008-05-14 Thread Kai Grossjohann

Marc Andre Tanner wrote:

[...] That is, use tabs for indention and spaces for further alignment:
---XGrabButton(dpy, AnyButton, AnyModifier, c-win, False,
---BUTTONMASK, GrabModeAsync, GrabModeSync, None, None);

This way the user can set the tabwidth to whatever he likes and the code
will still look decent.


*drool*

Is there a tool that does this?

Kai




Re: [dwm] dijkstra quote

2008-05-14 Thread Antoni Grzymala
Archie Elberling dixit (2008-05-15, 10:48):

Your [webmail server's?] clock is wrong. Your e-mail was sent from the
future (see the attribution time).

 H. Interesting - although it doesn't look like dietlinux has really
 been maintained over the past few years. dietlibc has though, so perhaps
 its not impossible (anyone here bored with merely having a suckless
 windowing manager?). uclibc / uclinux looks a more maintained approach, but
 I'm not sure how much better than glibc it is ( apart from the building
 smaller binaries bit). Perhaps I'll boot up a vm and see what I can put
 together.

-- 
[a]


signature.asc
Description: Digital signature


Re: [dwm] more consistent codestyle patch

2008-05-14 Thread Premysl Hruby
On (14/05/08 16:24), Kai Grossjohann wrote:
 To: dynamic window manager dwm@suckless.org
 From: Kai Grossjohann [EMAIL PROTECTED]
 Subject: Re: [dwm] more consistent codestyle patch
 User-Agent: Thunderbird 2.0.0.14 (X11/20080505)
 Reply-To: dynamic window manager dwm@suckless.org
 List-Id: dynamic window manager dwm.suckless.org
 
 Marc Andre Tanner wrote:
 [...] That is, use tabs for indention and spaces for further alignment:
 ---XGrabButton(dpy, AnyButton, AnyModifier, c-win, False,
 ---BUTTONMASK, GrabModeAsync, GrabModeSync, None, None);

 This way the user can set the tabwidth to whatever he likes and the code
 will still look decent.

 *drool*

 Is there a tool that does this?

 Kai



indent(1) and there are other programs that this do.

-- 
Premysl Anydot Hruby, http://www.redrum.cz/



Re: [dwm] more consistent codestyle patch

2008-05-14 Thread Matthias-Christian Ott
Premysl Hruby [EMAIL PROTECTED] wrote:

 On (14/05/08 16:24), Kai Grossjohann wrote:
  To: dynamic window manager dwm@suckless.org
  From: Kai Grossjohann [EMAIL PROTECTED]
  Subject: Re: [dwm] more consistent codestyle patch
  User-Agent: Thunderbird 2.0.0.14 (X11/20080505)
  Reply-To: dynamic window manager dwm@suckless.org
  List-Id: dynamic window manager dwm.suckless.org
  
  Marc Andre Tanner wrote:
  [...] That is, use tabs for indention and spaces for further alignment:
  ---XGrabButton(dpy, AnyButton, AnyModifier, c-win, False,
  ---BUTTONMASK, GrabModeAsync, GrabModeSync, None, None);
 
  This way the user can set the tabwidth to whatever he likes and the code
  will still look decent.
 
  *drool*
 
  Is there a tool that does this?
 
  Kai
 
 

 indent(1) and there are other programs that this do.

I can confirm (I tried it) that indent doesn't supports some options
which would be necessary to imitate dwm style and therefore enable
automatic style testing.
So indent might be a useful tool if you use GNU style or KNF, but
otherwise it's simply useless.

Regards
Matthias-Christian



Re: [dwm] more consistent codestyle patch

2008-05-14 Thread Diego Biurrun
On Tue, May 13, 2008 at 06:08:59PM +0200, Szabolcs Nagy wrote:
 On 5/13/08, Diego Biurrun [EMAIL PROTECTED] wrote:
 XGrabButton(dpy, AnyButton, AnyModifier, c-win, False,
   - BUTTONMASK, GrabModeAsync, GrabModeSync, None, 
   None);
   + BUTTONMASK, GrabModeAsync, GrabModeSync, None, None);
 
  Well, before it was indented to align with the XGrabButton call.  This
 
 used spaces to achieve this which is wrong

You have an interesting concept of wrong.  It was certainly intentional.

  was consistently done in at least a few places and makes the code more
  readable.
 
 no (it was consistently tab only indenting in most places)

It was consistently aligned with the help of tabs and spaces.  You have
undone that in your patch.

Diego



Re: [dwm] more consistent codestyle patch

2008-05-14 Thread Szabolcs Nagy
On 5/14/08, Diego Biurrun [EMAIL PROTECTED] wrote:
 used spaces to achieve this which is wrong

 You have an interesting concept of wrong.  It was certainly intentional.

 no (it was consistently tab only indenting in most places)

 It was consistently aligned with the help of tabs and spaces.  You have
 undone that in your patch.

no and yes

ok it was a misunderstanding

i asked arg if it's right to make style cleanup and also asked him if
i should **use spaces everywhere in case of indented wraps because
imho that's the right way to do it (in most places the code uses tabs
for this)**

he said that he prefered tabs everywhere so i cleaned up the code with
this in mind (== spaces are wrong there)

now i see he misunderstood my intentions, but at least now everyone
agrees on the style ;)