[E-devel] Renaming elm_object_label_set/get

2011-07-04 Thread Tom Hacohen
Dear Mike and everyone else,

As you may know, mike_m recently added elm_object_label_set/get API and 
elm_object_text_set/get macros as a generic way to set/get text for 
elementary widgets. Not all the widgets are supported yet, but some are.

I like this change a lot as it makes the API smaller, nicer, more 
consistent and easier to remember.

Currently, elm_object_label_get accepts two parameters, the object, and 
the part in that object. So for example one would call:
elm_object_label_get(some_label, default) for getting the default 
string of the label.

I'm sending this mail because I disagree with Mike's choice of naming. 
He chose elm_object_label_set/get because in most cases we are setting 
labels, but since we also support setting entries, this name is just not 
good enough.

I suggest renaming elm_object_label_set/get to 
elm_object_text_part_set/get or something similar which is, in my pov, 
better suiting than the former since we are using it to set/get more 
than just labels.

What do you guys think? Should I rename them to 
elm_object_text_part_set/get?

Thanks,
Tom.

P.S, again, thanks a lot to mike for doing this awesome change.

--
All of the data generated in your IT infrastructure is seriously valuable.
Why? It contains a definitive record of application performance, security 
threats, fraudulent activity, and more. Splunk takes this data and makes 
sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-d2d-c2
___
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel


Re: [E-devel] Renaming elm_object_label_set/get

2011-07-04 Thread Tom Hacohen
On 04/07/11 10:48, Daniel Juyung Seo wrote:
 elm_object_text_part_set/get?

 +1.
 I really agree with this idea. This is what I had in my mind.
 We already talked this issue in the mailing list.
 http://www.mail-archive.com/enlightenment-devel@lists.sourceforge.net/msg32884.html

You misread my email :)

We already have this API by a different name. I'm suggesting a rename to 
elm_object_text_part_set/get.

--
Tom.

--
All of the data generated in your IT infrastructure is seriously valuable.
Why? It contains a definitive record of application performance, security 
threats, fraudulent activity, and more. Splunk takes this data and makes 
sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-d2d-c2
___
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel


Re: [E-devel] Renaming elm_object_label_set/get

2011-07-04 Thread Daniel Juyung Seo
 We already have this API by a different name. I'm suggesting a rename to 
 elm_object_text_part_set/get.

Yeah that's what I'm saying :)
We discussed it but it was committed as a different name.
So it's time to get it right.

Daniel Juyung Seo (SeoZ)


On Mon, Jul 4, 2011 at 4:55 PM, Tom Hacohen
tom.haco...@partner.samsung.com wrote:
 On 04/07/11 10:48, Daniel Juyung Seo wrote:

 elm_object_text_part_set/get?

 +1.
 I really agree with this idea. This is what I had in my mind.
 We already talked this issue in the mailing list.

 http://www.mail-archive.com/enlightenment-devel@lists.sourceforge.net/msg32884.html

 You misread my email :)

 We already have this API by a different name. I'm suggesting a rename to
 elm_object_text_part_set/get.

 --
 Tom.


--
All of the data generated in your IT infrastructure is seriously valuable.
Why? It contains a definitive record of application performance, security 
threats, fraudulent activity, and more. Splunk takes this data and makes 
sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-d2d-c2
___
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel


Re: [E-devel] Renaming elm_object_label_set/get

2011-07-04 Thread Mike McCormack
On 07/04/2011 04:41 PM, Tom Hacohen wrote:

 What do you guys think? Should I rename them to elm_object_text_part_set/get?

Hey Tom,

How about this:

elm_object_label_set - elm_object_text_part_set
elm_object_label_get - elm_object_text_part_get

but keeping the elm_object_text_set/get macros as they are. i.e.

EAPI void elm_object_text_part_set(Evas_Object *obj, const char *item, const 
char *label);
#define elm_object_text_set(obj, label) elm_object_text_part_set((obj), NULL, 
(label))

I like elm_object_text_set() for the default part as it's short and simple.
Using label_set for the name was to keep it separate from text_set, but
I agree text_part_set is good.

thanks,

Mike

--
All of the data generated in your IT infrastructure is seriously valuable.
Why? It contains a definitive record of application performance, security 
threats, fraudulent activity, and more. Splunk takes this data and makes 
sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-d2d-c2
___
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel


Re: [E-devel] Renaming elm_object_label_set/get

2011-07-04 Thread Tom Hacohen
On 04/07/11 11:12, Mike McCormack wrote:
 How about this:

 elm_object_label_set -  elm_object_text_part_set
 elm_object_label_get -  elm_object_text_part_get

 but keeping the elm_object_text_set/get macros as they are. i.e.

 EAPI void elm_object_text_part_set(Evas_Object *obj, const char *item, const 
 char *label);
 #define elm_object_text_set(obj, label) elm_object_text_part_set((obj), NULL, 
 (label))

 I like elm_object_text_set() for the default part as it's short and simple.
 Using label_set for the name was to keep it separate from text_set, but
 I agree text_part_set is good.


Yeah, that's exactly what I meant. :)

I'm glad you agree, will change it soon.

--
Tom.

--
All of the data generated in your IT infrastructure is seriously valuable.
Why? It contains a definitive record of application performance, security 
threats, fraudulent activity, and more. Splunk takes this data and makes 
sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-d2d-c2
___
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel


Re: [E-devel] Renaming elm_object_label_set/get

2011-07-04 Thread WooHyun Jung
Hello ~ Tom. 

 

I really really really agree with this change J

It should be ~ I think.

 

+1 to your opinion 

 

Thanks.

WooHyun. 


--
All of the data generated in your IT infrastructure is seriously valuable.
Why? It contains a definitive record of application performance, security 
threats, fraudulent activity, and more. Splunk takes this data and makes 
sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-d2d-c2
___
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel


Re: [E-devel] Renaming elm_object_label_set/get

2011-07-04 Thread Tom Hacohen
Ok, it's in. Rev: 60975.

--
Tom.

--
All of the data generated in your IT infrastructure is seriously valuable.
Why? It contains a definitive record of application performance, security 
threats, fraudulent activity, and more. Splunk takes this data and makes 
sense of it. IT sense. And common sense.
http://p.sf.net/sfu/splunk-d2d-c2
___
enlightenment-devel mailing list
enlightenment-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/enlightenment-devel