Rename it to IS_Scope so that calling scope (node) under gdb is
unambiguous, so ease debugging sessions.
Tested on x86_64-pc-linux-gnu, committed on trunk
gcc/ada/
* ali.ads, ali.adb, bindo-writers.adb, lib-writ.adb (Scope):
Renamed to IS_Scope.
diff --git a/gcc/ada/ali.adb b/gcc/ada/ali.adb
--- a/gcc/ada/ali.adb
+++ b/gcc/ada/ali.adb
@@ -3814,15 +3814,15 @@ package body ALI is
return No_ALI_Id;
end Scan_ALI;
- -----------
- -- Scope --
- -----------
+ --------------
+ -- IS_Scope --
+ --------------
- function Scope (IS_Id : Invocation_Signature_Id) return Name_Id is
+ function IS_Scope (IS_Id : Invocation_Signature_Id) return Name_Id is
begin
pragma Assert (Present (IS_Id));
return Invocation_Signatures.Table (IS_Id).Scope;
- end Scope;
+ end IS_Scope;
---------
-- SEq --
diff --git a/gcc/ada/ali.ads b/gcc/ada/ali.ads
--- a/gcc/ada/ali.ads
+++ b/gcc/ada/ali.ads
@@ -1350,8 +1350,8 @@ package ALI is
pragma Inline (Name);
-- Obtain the name of invocation signature IS_Id
- function Scope (IS_Id : Invocation_Signature_Id) return Name_Id;
- pragma Inline (Scope);
+ function IS_Scope (IS_Id : Invocation_Signature_Id) return Name_Id;
+ pragma Inline (IS_Scope);
-- Obtain the scope of invocation signature IS_Id
procedure Set_Invocation_Graph_Encoding
diff --git a/gcc/ada/bindo-writers.adb b/gcc/ada/bindo-writers.adb
--- a/gcc/ada/bindo-writers.adb
+++ b/gcc/ada/bindo-writers.adb
@@ -222,7 +222,7 @@ package body Bindo.Writers is
Write_Eol;
Write_Str (" Scope = ");
- Write_Name (Scope (IS_Id));
+ Write_Name (IS_Scope (IS_Id));
Write_Eol;
end Write_Invocation_Signature;
diff --git a/gcc/ada/lib-writ.adb b/gcc/ada/lib-writ.adb
--- a/gcc/ada/lib-writ.adb
+++ b/gcc/ada/lib-writ.adb
@@ -1724,7 +1724,7 @@ package body Lib.Writ is
-- scope
- Write_Info_Name (Scope (IS_Id));
+ Write_Info_Name (IS_Scope (IS_Id));
Write_Info_Char (' ');
-- line