mjo         14/10/24 16:34:31

  Modified:             metadata.xml ChangeLog
  Added:                drush-6.4.0.ebuild
  Log:
  Version bump to fix bug #526222, take over as maintainer.
  
  (Portage version: 2.2.8-r2/cvs/Linux x86_64, signed Manifest commit with key 
0x6F48D3DA05C2DADB!)

Revision  Changes    Path
1.4                  app-admin/drush/metadata.xml

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/drush/metadata.xml?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/drush/metadata.xml?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/drush/metadata.xml?r1=1.3&r2=1.4

Index: metadata.xml
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-admin/drush/metadata.xml,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- metadata.xml        23 Dec 2013 15:55:47 -0000      1.3
+++ metadata.xml        24 Oct 2014 16:34:31 -0000      1.4
@@ -1,16 +1,15 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd";>
 <pkgmetadata>
-       <maintainer>
-               <email>maintainer-nee...@gentoo.org</email>
-       </maintainer>
-       <longdescription lang="en">
-       Drush is a command line shell and scripting interface for Drupal, a
-       veritable Swiss Army knife designed to make life easier for those of us 
who
-       spend some of our working hours hacking away at the command prompt.
-
-       See http://drush.ws, the homepage for the drush project. It contains 
many
-       important resources for drush users.
-       </longdescription>
+  <maintainer>
+    <email>m...@gentoo.org</email>
+    <name>Michael Orlitzky</name>
+  </maintainer>
+  <longdescription lang="en">
+    Drush is a command line shell and scripting interface for Drupal,
+    a veritable Swiss Army knife designed to make life easier for
+    those of us who spend some of our working hours hacking away at
+    the command prompt.
+  </longdescription>
 </pkgmetadata>
 



1.10                 app-admin/drush/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/drush/ChangeLog?rev=1.10&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/drush/ChangeLog?rev=1.10&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/drush/ChangeLog?r1=1.9&r2=1.10

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-admin/drush/ChangeLog,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- ChangeLog   20 Mar 2014 17:19:31 -0000      1.9
+++ ChangeLog   24 Oct 2014 16:34:31 -0000      1.10
@@ -1,6 +1,12 @@
 # ChangeLog for app-admin/drush
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/ChangeLog,v 1.9 2014/03/20 
17:19:31 mjo Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/ChangeLog,v 1.10 2014/10/24 
16:34:31 mjo Exp $
+
+*drush-6.4.0 (24 Oct 2014)
+
+  24 Oct 2014; Michael Orlitzky <m...@gentoo.org> +drush-6.4.0.ebuild,
+  +files/update-bash-completion-script-for-2.1.patch, metadata.xml:
+  Version bump to fix bug #526222, take over as maintainer.
 
 *drush-6.2.0 (20 Mar 2014)
 



1.1                  app-admin/drush/drush-6.4.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/drush/drush-6.4.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-admin/drush/drush-6.4.0.ebuild?rev=1.1&content-type=text/plain

Index: drush-6.4.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/app-admin/drush/drush-6.4.0.ebuild,v 1.1 
2014/10/24 16:34:31 mjo Exp $

EAPI=5

inherit bash-completion-r1 eutils

DESCRIPTION="Command line shell and scripting interface for Drupal"
HOMEPAGE="https://github.com/drush-ops/${PN}";
SRC_URI="https://github.com/drush-ops/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND=""
RDEPEND="dev-lang/php[cli,ctype,json,simplexml]
        dev-php/PEAR-Console_Table"

src_prepare() {
        # Fix the bash completion script, check the patch for Gentoo/upstream
        # bug numbers.
        epatch "${FILESDIR}/update-bash-completion-script-for-2.1.patch"

        # dodoc compresses all of the documentation, so we fix the filenames
        # in a few places.

        # First, the README location in bootstrap.inc.
        sed -i -e \
                "s!/share/doc/drush!/share/doc/${PF}!" \
                -e "s!README\.md!\0.bz2!g" \
                includes/bootstrap.inc || die

        # Next, the list of documentation in docs.drush.inc. Note that
        # html files don't get compressed.
        sed -i \
                -e "s!\.bashrc'!.bashrc.bz2'!" \
                -e "s!\.inc'!.inc.bz2'!" \
                -e "s!\.ini'!.ini.bz2'!" \
                -e "s!\.md'!.md.bz2'!" \
                -e "s!\.php'!.php.bz2'!" \
                -e "s!\.script'!.script.bz2'!" \
                -e "s!\.txt'!.txt.bz2'!" \
                commands/core/docs.drush.inc || die
}

src_install() {
        # Always install the examples; they're referenced within the source
        # code and too difficult to exorcise.
        dodoc -r README.md docs examples

        insinto /usr/share/drush
        doins -r classes commands includes lib misc
        doins drush_logo-black.png drush.info drush.php

        exeinto /usr/share/drush
        doexe drush
        dosym /usr/share/drush/drush /usr/bin/drush

        keepdir /etc/drush
        newbashcomp drush.complete.sh drush
}




Reply via email to