vapier      14/08/05 08:54:59

  Modified:             qemu-9999.ebuild qemu-2.1.0.ebuild ChangeLog
  Log:
  Unify configure lists so that we disable all the softmmu flags when building 
the user targets to avoid automagic deps leaking in.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
D2E96200)

Revision  Changes    Path
1.85                 app-emulation/qemu/qemu-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild?rev=1.85&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild?rev=1.85&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild?r1=1.84&r2=1.85

Index: qemu-9999.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v
retrieving revision 1.84
retrieving revision 1.85
diff -u -r1.84 -r1.85
--- qemu-9999.ebuild    5 Aug 2014 08:38:15 -0000       1.84
+++ qemu-9999.ebuild    5 Aug 2014 08:54:59 -0000       1.85
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.84 
2014/08/05 08:38:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.85 
2014/08/05 08:54:59 vapier Exp $
 
 EAPI=5
 
@@ -295,6 +295,58 @@
                $(use_enable tci tcg-interpreter)
        )
 
+       # Disable options not used by user targets as the default configure
+       # options will autoprobe and try to link in a bunch of unused junk.
+       conf_softmmu() {
+               if [[ ${buildtype} == "user" ]] ; then
+                       echo "--disable-${2:-$1}"
+               else
+                       use_enable "$@"
+               fi
+       }
+       conf_opts+=(
+               $(conf_softmmu accessibility brlapi)
+               $(conf_softmmu aio linux-aio)
+               $(conf_softmmu bluetooth bluez)
+               $(conf_softmmu caps cap-ng)
+               $(conf_softmmu curl)
+               $(conf_softmmu fdt)
+               $(conf_softmmu glusterfs)
+               $(conf_softmmu gtk)
+               $(conf_softmmu infiniband rdma)
+               $(conf_softmmu iscsi libiscsi)
+               $(conf_softmmu jpeg vnc-jpeg)
+               $(conf_softmmu kernel_linux kvm)
+               $(conf_softmmu lzo)
+               $(conf_softmmu ncurses curses)
+               $(conf_softmmu nfs libnfs)
+               $(conf_softmmu numa)
+               $(conf_softmmu opengl glx)
+               $(conf_softmmu png vnc-png)
+               $(conf_softmmu rbd)
+               $(conf_softmmu sasl vnc-sasl)
+               $(conf_softmmu sdl)
+               $(conf_softmmu seccomp)
+               $(conf_softmmu smartcard smartcard-nss)
+               $(conf_softmmu snappy)
+               $(conf_softmmu spice)
+               $(conf_softmmu ssh libssh2)
+               $(conf_softmmu tls quorum)
+               $(conf_softmmu tls vnc-tls)
+               $(conf_softmmu tls vnc-ws)
+               $(conf_softmmu usb libusb)
+               $(conf_softmmu usbredir usb-redir)
+               $(conf_softmmu uuid)
+               $(conf_softmmu vde)
+               $(conf_softmmu vhost-net)
+               $(conf_softmmu virtfs)
+               $(conf_softmmu vnc)
+               $(conf_softmmu xattr attr)
+               $(conf_softmmu xen)
+               $(conf_softmmu xen xen-pci-passthrough)
+               $(conf_softmmu xfs xfsctl)
+       )
+
        case ${buildtype} in
        user)
                conf_opts+=(
@@ -302,66 +354,15 @@
                        --disable-system
                        --target-list="${user_targets}"
                        --disable-blobs
-                       --disable-bluez
-                       --disable-curses
-                       --disable-kvm
-                       --disable-libiscsi
-                       --disable-glusterfs
-                       --disable-seccomp
-                       --disable-sdl
-                       --disable-smartcard-nss
                        --disable-tools
-                       --disable-vde
-                       --disable-libssh2
-                       --disable-libusb
                )
                ;;
        softmmu)
                conf_opts+=(
                        --disable-linux-user
                        --enable-system
-                       --with-system-pixman
                        --target-list="${softmmu_targets}"
-                       $(use_enable bluetooth bluez)
-                       $(use_enable gtk)
-                       $(use_enable sdl)
-                       $(use_enable aio linux-aio)
-                       $(use_enable accessibility brlapi)
-                       $(use_enable caps cap-ng)
-                       $(use_enable curl)
-                       $(use_enable fdt)
-                       $(use_enable glusterfs)
-                       $(use_enable infiniband rdma)
-                       $(use_enable iscsi libiscsi)
-                       $(use_enable jpeg vnc-jpeg)
-                       $(use_enable kernel_linux kvm)
-                       $(use_enable lzo)
-                       $(use_enable ncurses curses)
-                       $(use_enable nfs libnfs)
-                       $(use_enable numa)
-                       $(use_enable opengl glx)
-                       $(use_enable png vnc-png)
-                       $(use_enable rbd)
-                       $(use_enable sasl vnc-sasl)
-                       $(use_enable seccomp)
-                       $(use_enable smartcard smartcard-nss)
-                       $(use_enable snappy)
-                       $(use_enable spice)
-                       $(use_enable ssh libssh2)
-                       $(use_enable tls quorum)
-                       $(use_enable tls vnc-tls)
-                       $(use_enable tls vnc-ws)
-                       $(use_enable usb libusb)
-                       $(use_enable usbredir usb-redir)
-                       $(use_enable uuid)
-                       $(use_enable vde)
-                       $(use_enable vhost-net)
-                       $(use_enable virtfs)
-                       $(use_enable vnc)
-                       $(use_enable xattr attr)
-                       $(use_enable xen)
-                       $(use_enable xen xen-pci-passthrough)
-                       $(use_enable xfs xfsctl)
+                       --with-system-pixman
                        --audio-drv-list="${audio_opts}"
                )
                use gtk && conf_opts+=( --with-gtkabi=3.0 )



1.7                  app-emulation/qemu/qemu-2.1.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild?rev=1.7&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild?rev=1.7&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild?r1=1.6&r2=1.7

Index: qemu-2.1.0.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild,v
retrieving revision 1.6
retrieving revision 1.7
diff -u -r1.6 -r1.7
--- qemu-2.1.0.ebuild   5 Aug 2014 08:38:15 -0000       1.6
+++ qemu-2.1.0.ebuild   5 Aug 2014 08:54:59 -0000       1.7
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild,v 1.6 
2014/08/05 08:38:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-2.1.0.ebuild,v 1.7 
2014/08/05 08:54:59 vapier Exp $
 
 EAPI=5
 
@@ -295,6 +295,58 @@
                $(use_enable tci tcg-interpreter)
        )
 
+       # Disable options not used by user targets as the default configure
+       # options will autoprobe and try to link in a bunch of unused junk.
+       conf_softmmu() {
+               if [[ ${buildtype} == "user" ]] ; then
+                       echo "--disable-${2:-$1}"
+               else
+                       use_enable "$@"
+               fi
+       }
+       conf_opts+=(
+               $(conf_softmmu accessibility brlapi)
+               $(conf_softmmu aio linux-aio)
+               $(conf_softmmu bluetooth bluez)
+               $(conf_softmmu caps cap-ng)
+               $(conf_softmmu curl)
+               $(conf_softmmu fdt)
+               $(conf_softmmu glusterfs)
+               $(conf_softmmu gtk)
+               $(conf_softmmu infiniband rdma)
+               $(conf_softmmu iscsi libiscsi)
+               $(conf_softmmu jpeg vnc-jpeg)
+               $(conf_softmmu kernel_linux kvm)
+               $(conf_softmmu lzo)
+               $(conf_softmmu ncurses curses)
+               $(conf_softmmu nfs libnfs)
+               $(conf_softmmu numa)
+               $(conf_softmmu opengl glx)
+               $(conf_softmmu png vnc-png)
+               $(conf_softmmu rbd)
+               $(conf_softmmu sasl vnc-sasl)
+               $(conf_softmmu sdl)
+               $(conf_softmmu seccomp)
+               $(conf_softmmu smartcard smartcard-nss)
+               $(conf_softmmu snappy)
+               $(conf_softmmu spice)
+               $(conf_softmmu ssh libssh2)
+               $(conf_softmmu tls quorum)
+               $(conf_softmmu tls vnc-tls)
+               $(conf_softmmu tls vnc-ws)
+               $(conf_softmmu usb libusb)
+               $(conf_softmmu usbredir usb-redir)
+               $(conf_softmmu uuid)
+               $(conf_softmmu vde)
+               $(conf_softmmu vhost-net)
+               $(conf_softmmu virtfs)
+               $(conf_softmmu vnc)
+               $(conf_softmmu xattr attr)
+               $(conf_softmmu xen)
+               $(conf_softmmu xen xen-pci-passthrough)
+               $(conf_softmmu xfs xfsctl)
+       )
+
        case ${buildtype} in
        user)
                conf_opts+=(
@@ -302,66 +354,15 @@
                        --disable-system
                        --target-list="${user_targets}"
                        --disable-blobs
-                       --disable-bluez
-                       --disable-curses
-                       --disable-kvm
-                       --disable-libiscsi
-                       --disable-glusterfs
-                       --disable-seccomp
-                       --disable-sdl
-                       --disable-smartcard-nss
                        --disable-tools
-                       --disable-vde
-                       --disable-libssh2
-                       --disable-libusb
                )
                ;;
        softmmu)
                conf_opts+=(
                        --disable-linux-user
                        --enable-system
-                       --with-system-pixman
                        --target-list="${softmmu_targets}"
-                       $(use_enable bluetooth bluez)
-                       $(use_enable gtk)
-                       $(use_enable sdl)
-                       $(use_enable aio linux-aio)
-                       $(use_enable accessibility brlapi)
-                       $(use_enable caps cap-ng)
-                       $(use_enable curl)
-                       $(use_enable fdt)
-                       $(use_enable glusterfs)
-                       $(use_enable infiniband rdma)
-                       $(use_enable iscsi libiscsi)
-                       $(use_enable jpeg vnc-jpeg)
-                       $(use_enable kernel_linux kvm)
-                       $(use_enable lzo)
-                       $(use_enable ncurses curses)
-                       $(use_enable nfs libnfs)
-                       $(use_enable numa)
-                       $(use_enable opengl glx)
-                       $(use_enable png vnc-png)
-                       $(use_enable rbd)
-                       $(use_enable sasl vnc-sasl)
-                       $(use_enable seccomp)
-                       $(use_enable smartcard smartcard-nss)
-                       $(use_enable snappy)
-                       $(use_enable spice)
-                       $(use_enable ssh libssh2)
-                       $(use_enable tls quorum)
-                       $(use_enable tls vnc-tls)
-                       $(use_enable tls vnc-ws)
-                       $(use_enable usb libusb)
-                       $(use_enable usbredir usb-redir)
-                       $(use_enable uuid)
-                       $(use_enable vde)
-                       $(use_enable vhost-net)
-                       $(use_enable virtfs)
-                       $(use_enable vnc)
-                       $(use_enable xattr attr)
-                       $(use_enable xen)
-                       $(use_enable xen xen-pci-passthrough)
-                       $(use_enable xfs xfsctl)
+                       --with-system-pixman
                        --audio-drv-list="${audio_opts}"
                )
                use gtk && conf_opts+=( --with-gtkabi=3.0 )



1.280                app-emulation/qemu/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/qemu/ChangeLog?rev=1.280&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/qemu/ChangeLog?rev=1.280&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/app-emulation/qemu/ChangeLog?r1=1.279&r2=1.280

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v
retrieving revision 1.279
retrieving revision 1.280
diff -u -r1.279 -r1.280
--- ChangeLog   5 Aug 2014 08:38:15 -0000       1.279
+++ ChangeLog   5 Aug 2014 08:54:59 -0000       1.280
@@ -1,6 +1,11 @@
 # ChangeLog for app-emulation/qemu
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.279 
2014/08/05 08:38:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.280 
2014/08/05 08:54:59 vapier Exp $
+
+  05 Aug 2014; Mike Frysinger <vap...@gentoo.org> qemu-2.1.0.ebuild,
+  qemu-9999.ebuild:
+  Unify configure lists so that we disable all the softmmu flags when building
+  the user targets to avoid automagic deps leaking in.
 
   05 Aug 2014; Mike Frysinger <vap...@gentoo.org> qemu-2.0.0-r1.ebuild,
   qemu-2.1.0.ebuild, qemu-9999.ebuild:




Reply via email to