[gentoo-commits] gentoo-x86 commit in dev-db/oracle-instantclient-basic: ChangeLog oracle-instantclient-basic-11.2.0.4.ebuild

2014-04-04 Thread Michael Haubenwallner (haubi)
haubi   14/04/04 08:19:10

  Modified: ChangeLog
  Added:oracle-instantclient-basic-11.2.0.4.ebuild
  Log:
  +oracle-instantclient-basic-11.2.0.4: Revbump. Fix bugs #505522, #505536. 
Convert to USE abi_x86_*, #506228.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
A630CCB8)

Revision  ChangesPath
1.57 dev-db/oracle-instantclient-basic/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog?rev=1.57&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog?rev=1.57&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog?r1=1.56&r2=1.57

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog,v
retrieving revision 1.56
retrieving revision 1.57
diff -u -r1.56 -r1.57
--- ChangeLog   11 Nov 2013 09:35:34 -  1.56
+++ ChangeLog   4 Apr 2014 08:19:10 -   1.57
@@ -1,6 +1,12 @@
 # ChangeLog for dev-db/oracle-instantclient-basic
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: 
/var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog,v 1.56 
2013/11/11 09:35:34 haubi Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: 
/var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog,v 1.57 
2014/04/04 08:19:10 haubi Exp $
+
+*oracle-instantclient-basic-11.2.0.4 (04 Apr 2014)
+
+  04 Apr 2014; Michael Haubenwallner 
+  +oracle-instantclient-basic-11.2.0.4.ebuild:
+  Revbump. Fix bugs #505522, #505536. Convert to USE abi_x86_*, #506228.
 
   11 Nov 2013; Michael Haubenwallner 
   oracle-instantclient-basic-11.2.0.3.ebuild:



1.1  
dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild?rev=1.1&content-type=text/plain

Index: oracle-instantclient-basic-11.2.0.4.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild,v
 1.1 2014/04/04 08:19:10 haubi Exp $

EAPI="4"

inherit eutils multilib-minimal

MY_PLAT_x86="Linux x86"
MY_BITS_x86=32
MY_A_x86="${PN/oracle-/}-linux-${PV}.0.zip"
MY_ASDK_x86="${MY_A_x86/basic/sdk}"

MY_PLAT_amd64="Linux x86-64"
MY_BITS_amd64=64
MY_A_amd64="${PN/oracle-}-linux.x64-${PV}.0.zip"
MY_ASDK_amd64="${MY_A_amd64/basic/sdk}"

DESCRIPTION="Oracle 11g Instant Client with SDK"
HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html";
SRC_URI="
abi_x86_32? ( ${MY_A_x86} !abi_x86_64? ( ${MY_ASDK_x86} ) )
abi_x86_64? ( ${MY_A_amd64} ${MY_ASDK_amd64} )
"

LICENSE="OTN"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RESTRICT="fetch splitdebug"
IUSE=""

DEPEND="app-arch/unzip"
RDEPEND=">=dev-libs/libaio-0.3.109-r5[${MULTILIB_USEDEP}]"

S="${WORKDIR}"

QA_PREBUILT="usr/lib*/oracle/${PV}/client/lib*/lib*"

set_my_abivars() {
S="${WORKDIR}/${ABI}/instantclient_11_2"

local abi=${ABI}
[[ ${abi} == 'default' ]] && abi=${ARCH}
MY_PLAT=MY_PLAT_${abi}; MY_PLAT=${!MY_PLAT} # platform name
MY_BITS=MY_BITS_${abi}; MY_BITS=${!MY_BITS} # platform bitwidth
MY_A=MY_A_${abi}  ; MY_A=${!MY_A}   # runtime distfile
MY_ASDK=MY_ASDK_${abi}; MY_ASDK=${!MY_ASDK} # sdk distfile

[[ -n ${MY_PLAT} ]]
}

oic_distfile_status() {
if [[ -r ${DISTDIR}/${1} ]]; then
echo "already here"
else
echo "still absent"
fi
}

pkg_nofetch() {
eerror "Please go to"
eerror "  ${HOMEPAGE%/*}/index-097480.html"
eerror "  and download"
local ABI
for ABI in $(multilib_get_enabled_abis)
do
set_my_abivars || continue
eerror "Instant Client for ${MY_PLAT}"
eerror "Basic: ($(oic_distfile_status ${MY_A})) ${MY_A}"
multilib_is_native_abi &&
eerror "SDK:   ($(oic_distfile_status ${MY_ASDK})) 
${MY_ASDK}"
done
eerror "After downloading these files (for *all* shown architectures), 
put them in:"
eerror "${DISTDIR}/"
}

src_unpack() {
local ABI
for ABI in $(multilib_get_enabled_abis)
do
set_my_abivars || continue
mkdir "${WORKDIR}"/${ABI} || die
cd "${WORKD

[gentoo-commits] gentoo-x86 commit in dev-db/oracle-instantclient-basic: ChangeLog oracle-instantclient-basic-11.2.0.4.ebuild

2014-04-10 Thread Michael Haubenwallner (haubi)
haubi   14/04/10 14:55:13

  Modified: ChangeLog
oracle-instantclient-basic-11.2.0.4.ebuild
  Log:
  oracle-instantclient-basic-11.2.0.4: Fix for pure x86_32 setup, pointed out 
by Cedric Godin in #505522.
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
A630CCB8)

Revision  ChangesPath
1.59 dev-db/oracle-instantclient-basic/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog?rev=1.59&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog?rev=1.59&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog?r1=1.58&r2=1.59

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog,v
retrieving revision 1.58
retrieving revision 1.59
diff -u -r1.58 -r1.59
--- ChangeLog   4 Apr 2014 08:39:54 -   1.58
+++ ChangeLog   10 Apr 2014 14:55:13 -  1.59
@@ -1,6 +1,10 @@
 # ChangeLog for dev-db/oracle-instantclient-basic
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: 
/var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog,v 1.58 
2014/04/04 08:39:54 haubi Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/ChangeLog,v 1.59 
2014/04/10 14:55:13 haubi Exp $
+
+  10 Apr 2014; Michael Haubenwallner 
+  oracle-instantclient-basic-11.2.0.4.ebuild:
+  Fix for pure x86_32 setup, pointed out by Cedric Godin in #505522.
 
 *oracle-instantclient-basic-11.2.0.4 (04 Apr 2014)
 



1.2  
dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild?r1=1.1&r2=1.2

Index: oracle-instantclient-basic-11.2.0.4.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- oracle-instantclient-basic-11.2.0.4.ebuild  4 Apr 2014 08:19:10 -   
1.1
+++ oracle-instantclient-basic-11.2.0.4.ebuild  10 Apr 2014 14:55:13 -  
1.2
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild,v
 1.1 2014/04/04 08:19:10 haubi Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-basic/oracle-instantclient-basic-11.2.0.4.ebuild,v
 1.2 2014/04/10 14:55:13 haubi Exp $
 
 EAPI="4"
 
@@ -88,7 +88,10 @@
 }
 
 src_prepare() {
-   # need to patch for the final ABI only
+   local ABI
+   for ABI in $(multilib_get_enabled_abis)
+   do : # need to patch for the final ABI only
+   done
set_my_abivars || die "${ABI} ABI not supported!"
cd "${S}" || die
epatch "${FILESDIR}"/11.2.0.3-makefile.patch