mjo         15/07/10 14:44:19

  Modified:             ChangeLog
  Added:                coffee-script-1.9.3-r1.ebuild
  Removed:              coffee-script-1.9.3.ebuild
  Log:
  Revbump to install cake, bug #554308 thanks to Peter Cai.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0x6F48D3DA05C2DADB!)

Revision  Changes    Path
1.2                  dev-lang/coffee-script/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/coffee-script/ChangeLog?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/coffee-script/ChangeLog?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/coffee-script/ChangeLog?r1=1.1&r2=1.2

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-lang/coffee-script/ChangeLog,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- ChangeLog   3 Jul 2015 22:11:22 -0000       1.1
+++ ChangeLog   10 Jul 2015 14:44:19 -0000      1.2
@@ -1,6 +1,12 @@
 # ChangeLog for dev-lang/coffee-script
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/coffee-script/ChangeLog,v 1.1 
2015/07/03 22:11:22 mjo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/coffee-script/ChangeLog,v 1.2 
2015/07/10 14:44:19 mjo Exp $
+
+*coffee-script-1.9.3-r1 (10 Jul 2015)
+
+  10 Jul 2015; Michael Orlitzky <m...@gentoo.org> 
+coffee-script-1.9.3-r1.ebuild,
+  -coffee-script-1.9.3.ebuild:
+  Revbump to install cake, bug #554308 thanks to Peter Cai.
 
 *coffee-script-1.9.3 (03 Jul 2015)
 



1.1                  dev-lang/coffee-script/coffee-script-1.9.3-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/coffee-script/coffee-script-1.9.3-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-lang/coffee-script/coffee-script-1.9.3-r1.ebuild?rev=1.1&content-type=text/plain

Index: coffee-script-1.9.3-r1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-lang/coffee-script/coffee-script-1.9.3-r1.ebuild,v 
1.1 2015/07/10 14:44:19 mjo Exp $

EAPI=5

inherit multilib

MY_PN="coffeescript"

DESCRIPTION="A little language that compiles into javascript"
HOMEPAGE="http://coffeescript.org/";

# The tests are missing from the npm registry package, so use Github
# instead.
SRC_URI="https://github.com/jashkenas/${MY_PN}/archive/${PV}.tar.gz
        -> ${P}.tar.gz"
S="${WORKDIR}/${MY_PN}-${PV}"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"

# This package has a test suite (that works), but it requires a number
# of packages not in the tree. See thread "NPM / NodeJS project" on the
# gentoo-dev archives for more info.
IUSE="doc examples"

RDEPEND="net-libs/nodejs"

src_install(){
        local npm_module_dir="/usr/$(get_libdir)/node/${PN}"
        insinto "${npm_module_dir}"
        doins *.js package.json
        doins -r lib
        dodoc CONTRIBUTING.md README.md

        use doc && dodoc -r documentation
        use examples && dodoc -r examples

        # The coffee and cake "binaries" use a relative path to find the lib
        # directory, so we have to symlink them rather than use dobin().
        exeinto "${npm_module_dir}/bin"
        doexe bin/cake
        doexe bin/coffee
        dosym "${npm_module_dir}/bin/cake" "/usr/bin/cake"
        dosym "${npm_module_dir}/bin/coffee" "/usr/bin/coffee"
}




Reply via email to