hasufell    14/11/17 22:32:35

  Modified:             ChangeLog
  Added:                libntru-0.3.ebuild
  Log:
  version bump
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  Changes    Path
1.2                  dev-libs/libntru/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libntru/ChangeLog?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libntru/ChangeLog?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libntru/ChangeLog?r1=1.1&r2=1.2

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/libntru/ChangeLog,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- ChangeLog   16 Apr 2014 22:48:09 -0000      1.1
+++ ChangeLog   17 Nov 2014 22:32:35 -0000      1.2
@@ -1,6 +1,14 @@
 # ChangeLog for dev-libs/libntru
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libntru/ChangeLog,v 1.1 2014/04/16 
22:48:09 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libntru/ChangeLog,v 1.2 2014/11/17 
22:32:35 hasufell Exp $
+
+*libntru-0.3 (17 Nov 2014)
+
+  17 Nov 2014; Julian Ospald <hasuf...@gentoo.org> +libntru-0.3.ebuild,
+  +files/libntru-0.3-Allow-building-and-installing-static-lib.patch,
+  +files/libntru-0.3-Make-the-lib-target-depend-on-the-libntru.so-target.patch,
+  +files/libntru-0.3-Update-VERSION-in-Makefiles.patch:
+  version bump
 
 *libntru-0.2 (16 Apr 2014)
 



1.1                  dev-libs/libntru/libntru-0.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libntru/libntru-0.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/libntru/libntru-0.3.ebuild?rev=1.1&content-type=text/plain

Index: libntru-0.3.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/libntru/libntru-0.3.ebuild,v 1.1 
2014/11/17 22:32:35 hasufell Exp $

EAPI=5

inherit eutils toolchain-funcs multilib multilib-minimal

DESCRIPTION="C Implementation of NTRUEncrypt"
HOMEPAGE="https://github.com/tbuktu/libntru";
SRC_URI="https://github.com/tbuktu/libntru/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples static-libs"

src_prepare() {
        epatch 
"${FILESDIR}"/${P}-Make-the-lib-target-depend-on-the-libntru.so-target.patch \
                
"${FILESDIR}"/${P}-Allow-building-and-installing-static-lib.patch \
                "${FILESDIR}"/${P}-Update-VERSION-in-Makefiles.patch

        multilib_copy_sources

        _copy_test_dir() {
                cp -pr "${BUILD_DIR}" "${BUILD_DIR}-test" || die
        }
        multilib_foreach_abi _copy_test_dir
}

multilib_src_compile() {
        CFLAGS="${CFLAGS}" emake CC="$(tc-getCC)" $(usex static-libs 
"libntru.a" "")
}

src_test() {
        _test() {
                CFLAGS="${CFLAGS}" emake CC="$(tc-getCC)" test -j1 -C 
"${BUILD_DIR}-test"
        }

        multilib_foreach_abi _test
}

multilib_src_install() {
        emake \
                DESTDIR="${ED}" \
                INST_LIBDIR="/usr/$(get_libdir)" \
                INST_DOCDIR="/usr/share/doc/${PF}" \
                install $(usex static-libs install-static-lib "")
}

multilib_src_install_all() {
        einstalldocs
        if use examples ; then
                docinto examples
                dodoc src/hybrid.c
        fi
}




Reply via email to