tomka       15/07/10 14:16:04

  Modified:             ChangeLog
  Added:                ntl-9.3.0.ebuild
  Log:
  bump to 9.3, thanks Francois Bissey
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
565C32BC)

Revision  Changes    Path
1.28                 dev-libs/ntl/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/ntl/ChangeLog?rev=1.28&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/ntl/ChangeLog?rev=1.28&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/ntl/ChangeLog?r1=1.27&r2=1.28

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-libs/ntl/ChangeLog,v
retrieving revision 1.27
retrieving revision 1.28
diff -u -r1.27 -r1.28
--- ChangeLog   2 Apr 2015 12:29:55 -0000       1.27
+++ ChangeLog   10 Jul 2015 14:16:04 -0000      1.28
@@ -1,6 +1,13 @@
 # ChangeLog for dev-libs/ntl
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ChangeLog,v 1.27 2015/04/02 
12:29:55 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ChangeLog,v 1.28 2015/07/10 
14:16:04 tomka Exp $
+
+*ntl-9.3.0 (10 Jul 2015)
+
+  10 Jul 2015; Thomas Kahle <to...@gentoo.org>
+  +files/ntl-9.2.0-sanitize-makefile.patch, +files/ntl-9.2.0-singular.patch,
+  +ntl-9.3.0.ebuild:
+  bump to 9.3, thanks Francois Bissey
 
 *ntl-9.0.2 (02 Apr 2015)
 



1.1                  dev-libs/ntl/ntl-9.3.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/ntl/ntl-9.3.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-libs/ntl/ntl-9.3.0.ebuild?rev=1.1&content-type=text/plain

Index: ntl-9.3.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ntl-9.3.0.ebuild,v 1.1 
2015/07/10 14:16:04 tomka Exp $

EAPI=5
inherit toolchain-funcs eutils multilib flag-o-matic

DESCRIPTION="High-performance and portable Number Theory C++ library"
HOMEPAGE="http://shoup.net/ntl/";
SRC_URI="http://www.shoup.net/ntl/${P}.tar.gz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos 
~x64-macos"
IUSE="doc static-libs test"

RDEPEND="dev-libs/gmp:=
        >=dev-libs/gf2x-0.9"
DEPEND="${RDEPEND}
        dev-lang/perl"

S="${WORKDIR}/${P}/src"

src_prepare() {
        # fix parallel make
        sed -i -e "s/make/make ${MAKEOPTS}/g" WizardAux || die
        cd ..
        # sanitize the makefile and allow the building of shared library
        epatch "${FILESDIR}"/${PN}-9.2.0-sanitize-makefile.patch
        # enable compatibility with singular
        epatch "${FILESDIR}"/${PN}-9.2.0-singular.patch
        replace-flags -O[3-9] -O2
}

src_configure() {
        perl DoConfig \
                PREFIX="${EPREFIX}"/usr \
                CXXFLAGS="${CXXFLAGS}" \
                LDFLAGS="${LDFLAGS}" \
                CXX="$(tc-getCXX)" \
                AR="$(tc-getAR)" \
                RANLIB="$(tc-getRANLIB)" \
                NTL_GMP_LIP=on NTL_GF2X_LIB=on NTL_LEGACY_SP_MULMOD=on \
                || die "DoConfig failed"
}

src_compile() {
        # split the targets to allow parallel make to run properly
        emake setup1 setup2
        emake setup3
        sh Wizard on || die "Tuning wizard failed"
        if use static-libs; then
                emake ntl.a
        fi
        local trg=so
        [[ ${CHOST} == *-darwin* ]] && trg=dylib
        emake shared${trg}
}

src_install() {
        if use static-libs; then
                newlib.a ntl.a libntl.a
        fi
        dolib.so lib*$(get_libname)

        cd ..
        insinto /usr/include
        doins -r include/NTL

        dodoc README
        if use doc ; then
                dodoc doc/*.txt
                dohtml doc/*
        fi
}

src_test(){
        # the current ebuild need static library to run tests
        emake ntl.a

        default
}




Reply via email to