idella4     15/07/22 03:59:20

  Modified:             ChangeLog
  Added:                elasticsearch-py-1.6.0.ebuild
  Log:
  bump
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.10                 dev-python/elasticsearch-py/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/elasticsearch-py/ChangeLog?rev=1.10&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/elasticsearch-py/ChangeLog?rev=1.10&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/elasticsearch-py/ChangeLog?r1=1.9&r2=1.10

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/elasticsearch-py/ChangeLog,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- ChangeLog   7 Jun 2015 16:44:02 -0000       1.9
+++ ChangeLog   22 Jul 2015 03:59:20 -0000      1.10
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/elasticsearch-py
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/elasticsearch-py/ChangeLog,v 1.9 
2015/06/07 16:44:02 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/elasticsearch-py/ChangeLog,v 
1.10 2015/07/22 03:59:20 idella4 Exp $
+
+*elasticsearch-py-1.6.0 (22 Jul 2015)
+
+  22 Jul 2015; Ian Delaney <idel...@gentoo.org> +elasticsearch-py-1.6.0.ebuild:
+  bump
 
 *elasticsearch-py-1.5.0 (07 Jun 2015)
 



1.1                  dev-python/elasticsearch-py/elasticsearch-py-1.6.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/elasticsearch-py/elasticsearch-py-1.6.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/elasticsearch-py/elasticsearch-py-1.6.0.ebuild?rev=1.1&content-type=text/plain

Index: elasticsearch-py-1.6.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-python/elasticsearch-py/elasticsearch-py-1.6.0.ebuild,v
 1.1 2015/07/22 03:59:20 idella4 Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 python3_{3,4} pypy )

inherit distutils-r1

DESCRIPTION="official Python low-level client for Elasticsearch"
HOMEPAGE="http://elasticsearch-py.rtfd.org/";
SRC_URI="https://github.com/elasticsearch/${PN}/archive/${PV}.tar.gz -> 
${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~mips ~x86"
IUSE="examples doc test"

RDEPEND=">=dev-python/urllib3-1.8[${PYTHON_USEDEP}]
        <dev-python/urllib3-2.0[${PYTHON_USEDEP}]"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? ( ${RDEPEND}
                >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
                <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
                dev-python/nose[${PYTHON_USEDEP}]
                dev-python/coverage[${PYTHON_USEDEP}]
                dev-python/mock[${PYTHON_USEDEP}]
                dev-python/pyyaml[${PYTHON_USEDEP}] )"
# nosexcover is listed for tests but is not essential

python_prepare_all() {
        # Remove tests attempting to connect ot the network
        rm -rf test_elasticsearch/test_server/ || die
        distutils-r1_python_prepare_all
}

python_compile_all() {
        use doc && emake -C docs html
}

python_test_all() {
        # For unknown reason the testsuite fails to iterate the set of impls of 
PYTHON_COMPAT
        # but they all pass on testing when run individually
        "${PYTHON}" test_elasticsearch/run_tests.py

}

python_install_all() {
        use doc && HTML_DOCS=( docs/_build/html/. )
        use examples && local EXAMPLES=( example/. )
        distutils-r1_python_install_all
}




Reply via email to