idella4     14/12/30 07:57:50

  Modified:             ChangeLog
  Added:                functest-0.8.8-r1.ebuild
  Removed:              functest-0.8.8.ebuild
  Log:
  revbump; conversion -> distutils-r1, rm old
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.4                  dev-python/functest/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/functest/ChangeLog?rev=1.4&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/functest/ChangeLog?rev=1.4&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/functest/ChangeLog?r1=1.3&r2=1.4

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/functest/ChangeLog,v
retrieving revision 1.3
retrieving revision 1.4
diff -u -r1.3 -r1.4
--- ChangeLog   22 Jul 2010 16:17:58 -0000      1.3
+++ ChangeLog   30 Dec 2014 07:57:50 -0000      1.4
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/functest
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/functest/ChangeLog,v 1.3 
2010/07/22 16:17:58 arfrever Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/functest/ChangeLog,v 1.4 
2014/12/30 07:57:50 idella4 Exp $
+
+*functest-0.8.8-r1 (30 Dec 2014)
+
+  30 Dec 2014; Ian Delaney <idel...@gentoo.org> +functest-0.8.8-r1.ebuild,
+  -functest-0.8.8.ebuild:
+  revbump; conversion -> distutils-r1, rm old
 
   22 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfre...@gentoo.org>
   functest-0.8.8.ebuild:
@@ -14,4 +20,3 @@
   25 Jul 2009; Jesus Rivero <neurog...@gentoo.org> +functest-0.8.8.ebuild,
   +metadata.xml:
   Initial commit. Thanks to Almad (b...@almad.net). Closes bug #238899.
-



1.1                  dev-python/functest/functest-0.8.8-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/functest/functest-0.8.8-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/functest/functest-0.8.8-r1.ebuild?rev=1.1&content-type=text/plain

Index: functest-0.8.8-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-python/functest/functest-0.8.8-r1.ebuild,v 1.1 
2014/12/30 07:57:50 idella4 Exp $

EAPI=5
PYTHON_COMPAT=( python2_7 )

inherit distutils-r1

DESCRIPTION="Functest is a test tool/framework for testing in Python"
HOMEPAGE="http://code.google.com/p/functest/ 
http://pypi.python.org/pypi/functest";
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""

python_prepare_all() {
        # purge test folder to avoid file collisions
        sed -e "s:find_packages():find_packages(exclude=['tests','tests.*']):" 
-i setup.py || die
        distutils-r1_python_prepare_all
}

python_test() {
        PATH="scripts:${PATH}" nosetests || die "Tests fail with ${EPYTHON}"
}




Reply via email to