idella4     14/04/10 07:52:53

  Modified:             ChangeLog
  Added:                fusil-1.5.ebuild
  Removed:              fusil-1.3.2.ebuild fusil-1.4.ebuild
  Log:
  bump; add py3 pypy support and migration -> distutils-r1, rm old
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.9                  dev-python/fusil/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/fusil/ChangeLog?rev=1.9&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/fusil/ChangeLog?rev=1.9&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/fusil/ChangeLog?r1=1.8&r2=1.9

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -r1.8 -r1.9
--- ChangeLog   7 Jun 2012 20:29:52 -0000       1.8
+++ ChangeLog   10 Apr 2014 07:52:53 -0000      1.9
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/fusil
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.8 2012/06/07 
20:29:52 zmedico Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/ChangeLog,v 1.9 2014/04/10 
07:52:53 idella4 Exp $
+
+*fusil-1.5 (10 Apr 2014)
+
+  10 Apr 2014; Ian Delaney <idel...@gentoo.org> +fusil-1.5.ebuild,
+  -fusil-1.3.2.ebuild, -fusil-1.4.ebuild:
+  bump; add py3 pypy support and migration -> distutils-r1, rm old
 
   07 Jun 2012; Zac Medico <zmed...@gentoo.org> fusil-1.3.2.ebuild,
   fusil-1.4.ebuild:
@@ -45,4 +51,3 @@
   28 Feb 2009; Patrick Lauer <patr...@gentoo.org> +metadata.xml,
   +fusil-1.2.1.ebuild:
   Initial import. Fixes #247893. Ebuild contributed by Tuna <t...@lyua.org>
-



1.1                  dev-python/fusil/fusil-1.5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/fusil/fusil-1.5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/fusil/fusil-1.5.ebuild?rev=1.1&content-type=text/plain

Index: fusil-1.5.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-python/fusil/fusil-1.5.ebuild,v 1.1 
2014/04/10 07:52:53 idella4 Exp $

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy2_0 pypy )

inherit distutils-r1 user

DESCRIPTION="Fusil the fuzzer is a Python library used to write fuzzing 
programs."
HOMEPAGE="http://bitbucket.org/haypo/fusil/wiki/Home 
http://pypi.python.org/pypi/fusil";
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"

DEPEND=">=dev-python/python-ptrace-0.6[${PYTHON_USEDEP}]
        doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"

RDEPEND="${DEPEND}"

python_compile_all() {
        use doc && emake -C doc RST2HTML="rst2html.py" || die "Generation of 
documentation failed"
}

python_install_all(){
        use doc && local HTML_DOCS=( doc/. )
        use examples && local EXAMPLES=( examples/. )
        distutils-r1_python_install_all
}

pkg_postinst() {
        enewgroup fusil
        enewuser fusil -1 -1 -1 "fusil"
}




Reply via email to