[gentoo-commits] gentoo-x86 commit in dev-python/pytest: pytest-2.4.2.ebuild pytest-2.5.2.ebuild ChangeLog

2014-07-19 Thread Mike Gilbert (floppym)
floppym 14/07/19 18:59:11

  Modified: pytest-2.4.2.ebuild pytest-2.5.2.ebuild ChangeLog
  Log:
  Use python_gen_cond_dep.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0BBEEA1FEA4843A4)

Revision  ChangesPath
1.11 dev-python/pytest/pytest-2.4.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild?rev=1.11view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild?rev=1.11content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild?r1=1.10r2=1.11

Index: pytest-2.4.2.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v
retrieving revision 1.10
retrieving revision 1.11
diff -u -r1.10 -r1.11
--- pytest-2.4.2.ebuild 6 Jul 2014 12:49:18 -   1.10
+++ pytest-2.4.2.ebuild 19 Jul 2014 18:59:11 -  1.11
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 
1.10 2014/07/06 12:49:18 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 
1.11 2014/07/19 18:59:11 floppym Exp $
 
 EAPI=5
 
@@ -24,7 +24,7 @@
 DEPEND=${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
-   dev-python/pexpect[$(python_gen_usedep python{2_6,2_7,3_2,3_3})]
+   $(python_gen_cond_dep 'dev-python/pexpect[${PYTHON_USEDEP}]' 
'python*')
dev-python/pyyaml[${PYTHON_USEDEP}]
)
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )



1.6  dev-python/pytest/pytest-2.5.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild?rev=1.6view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild?rev=1.6content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild?r1=1.5r2=1.6

Index: pytest-2.5.2.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -r1.5 -r1.6
--- pytest-2.5.2.ebuild 6 Jul 2014 12:49:18 -   1.5
+++ pytest-2.5.2.ebuild 19 Jul 2014 18:59:11 -  1.6
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.5 
2014/07/06 12:49:18 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.6 
2014/07/19 18:59:11 floppym Exp $
 
 EAPI=5
 
@@ -24,7 +24,7 @@
 DEPEND=${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
-   dev-python/pexpect[$(python_gen_usedep 
python{2_6,2_7,3_2,3_3,3_4})]
+   $(python_gen_cond_dep 'dev-python/pexpect[${PYTHON_USEDEP}]' 
'python*')
dev-python/pyyaml[${PYTHON_USEDEP}]
)
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )



1.91 dev-python/pytest/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/ChangeLog?rev=1.91view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/ChangeLog?rev=1.91content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/ChangeLog?r1=1.90r2=1.91

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v
retrieving revision 1.90
retrieving revision 1.91
diff -u -r1.90 -r1.91
--- ChangeLog   6 Jul 2014 12:49:18 -   1.90
+++ ChangeLog   19 Jul 2014 18:59:11 -  1.91
@@ -1,6 +1,10 @@
 # ChangeLog for dev-python/pytest
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.90 
2014/07/06 12:49:18 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.91 
2014/07/19 18:59:11 floppym Exp $
+
+  19 Jul 2014; Mike Gilbert flop...@gentoo.org pytest-2.4.2.ebuild,
+  pytest-2.5.2.ebuild:
+  Use python_gen_cond_dep.
 
   06 Jul 2014; Michał Górny mgo...@gentoo.org pytest-2.4.2.ebuild,
   pytest-2.5.2.ebuild:






[gentoo-commits] gentoo-x86 commit in dev-python/pytest: pytest-2.4.2.ebuild pytest-2.5.2.ebuild ChangeLog

2014-07-06 Thread Michal Gorny (mgorny)
mgorny  14/07/06 12:49:19

  Modified: pytest-2.4.2.ebuild pytest-2.5.2.ebuild ChangeLog
  Log:
  Clean up obsolete dependencies on virtual/python-argparse and 
virtual/python-unittest2 (those packages were only required for =python-2.6).
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
EFB4464E!)

Revision  ChangesPath
1.10 dev-python/pytest/pytest-2.4.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild?rev=1.10view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild?rev=1.10content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild?r1=1.9r2=1.10

Index: pytest-2.4.2.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- pytest-2.4.2.ebuild 31 Mar 2014 20:31:59 -  1.9
+++ pytest-2.4.2.ebuild 6 Jul 2014 12:49:18 -   1.10
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 1.9 
2014/03/31 20:31:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.4.2.ebuild,v 
1.10 2014/07/06 12:49:18 mgorny Exp $
 
 EAPI=5
 
@@ -23,7 +23,6 @@
 #pexpect dep based on 
https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
 DEPEND=${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
-   virtual/python-argparse[${PYTHON_USEDEP}]
test? (
dev-python/pexpect[$(python_gen_usedep python{2_6,2_7,3_2,3_3})]
dev-python/pyyaml[${PYTHON_USEDEP}]



1.5  dev-python/pytest/pytest-2.5.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild?rev=1.5view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild?rev=1.5content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild?r1=1.4r2=1.5

Index: pytest-2.5.2.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v
retrieving revision 1.4
retrieving revision 1.5
diff -u -r1.4 -r1.5
--- pytest-2.5.2.ebuild 2 Apr 2014 20:25:31 -   1.4
+++ pytest-2.5.2.ebuild 6 Jul 2014 12:49:18 -   1.5
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.4 
2014/04/02 20:25:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.5.2.ebuild,v 1.5 
2014/07/06 12:49:18 mgorny Exp $
 
 EAPI=5
 
@@ -23,7 +23,6 @@
 #pexpect dep based on 
https://bitbucket.org/hpk42/pytest/issue/386/tests-fail-with-pexpect-30
 DEPEND=${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
-   virtual/python-argparse[${PYTHON_USEDEP}]
test? (
dev-python/pexpect[$(python_gen_usedep 
python{2_6,2_7,3_2,3_3,3_4})]
dev-python/pyyaml[${PYTHON_USEDEP}]



1.90 dev-python/pytest/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/ChangeLog?rev=1.90view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/ChangeLog?rev=1.90content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/pytest/ChangeLog?r1=1.89r2=1.90

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v
retrieving revision 1.89
retrieving revision 1.90
diff -u -r1.89 -r1.90
--- ChangeLog   2 Apr 2014 20:25:31 -   1.89
+++ ChangeLog   6 Jul 2014 12:49:18 -   1.90
@@ -1,6 +1,11 @@
 # ChangeLog for dev-python/pytest
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.89 
2014/04/02 20:25:31 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.90 
2014/07/06 12:49:18 mgorny Exp $
+
+  06 Jul 2014; Michał Górny mgo...@gentoo.org pytest-2.4.2.ebuild,
+  pytest-2.5.2.ebuild:
+  Clean up obsolete dependencies on virtual/python-argparse and virtual/python-
+  unittest2 (those packages were only required for =python-2.6).
 
   02 Apr 2014; Tim Harder radher...@gentoo.org pytest-2.5.2.ebuild:
   Add python3_4 support.