idella4     14/04/10 06:19:20

  Modified:             ChangeLog
  Added:                python-ptrace-0.7.ebuild
  Removed:              python-ptrace-0.6.4.ebuild
                        python-ptrace-0.6.3.ebuild
                        python-ptrace-0.6.5.ebuild
                        python-ptrace-0.6.2.ebuild
  Log:
  bump; radical updating that goes with adding py3 pypy support and conversion 
-> distutils-r1
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.13                 dev-python/python-ptrace/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/python-ptrace/ChangeLog?rev=1.13&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/python-ptrace/ChangeLog?rev=1.13&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/python-ptrace/ChangeLog?r1=1.12&r2=1.13

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v
retrieving revision 1.12
retrieving revision 1.13
diff -u -r1.12 -r1.13
--- ChangeLog   7 Jan 2014 06:58:19 -0000       1.12
+++ ChangeLog   10 Apr 2014 06:19:20 -0000      1.13
@@ -1,6 +1,14 @@
 # ChangeLog for dev-python/python-ptrace
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.12 
2014/01/07 06:58:19 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.13 
2014/04/10 06:19:20 idella4 Exp $
+
+*python-ptrace-0.7 (10 Apr 2014)
+
+  10 Apr 2014; Ian Delaney <idel...@gentoo.org> +python-ptrace-0.7.ebuild,
+  -python-ptrace-0.6.2.ebuild, -python-ptrace-0.6.3.ebuild,
+  -python-ptrace-0.6.4.ebuild, -python-ptrace-0.6.5.ebuild:
+  bump; radical updating that goes with adding py3 pypy support and conversion
+  -> distutils-r1
 
 *python-ptrace-0.6.6 (07 Jan 2014)
 



1.1                  dev-python/python-ptrace/python-ptrace-0.7.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.7.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.7.ebuild?rev=1.1&content-type=text/plain

Index: python-ptrace-0.7.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.7.ebuild,v 1.1 
2014/04/10 06:19:20 idella4 Exp $

EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy2_0 pypy )

inherit distutils-r1

DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin 
system call to trace processes)."
HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ 
http://pypi.python.org/pypi/python-ptrace";
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"

DEPEND=""
RDEPEND="dev-libs/distorm64"
# Req'd for tests
DISTUTILS_IN_SOURCE_BUILD=1

python_test() {
        echo "${EPYTHON}"
        if python_is_python3; then
                2to3 -w ptrace
        fi
        "${PYTHON}" test_doc.py || die "tests failed under ${EPYTHON}"
}

python_install_all() {
        use examples && local EXAMPLES=( examples/. )

        distutils-r1_python_install_all
}




Reply via email to