graaff      15/06/07 06:36:56

  Modified:             ChangeLog eventmachine-1.0.3-r1.ebuild
  Added:                eventmachine-1.0.3-r2.ebuild
  Log:
  Create stable candidate.
  
  (Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.27                 dev-ruby/eventmachine/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/eventmachine/ChangeLog?rev=1.27&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/eventmachine/ChangeLog?rev=1.27&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/eventmachine/ChangeLog?r1=1.26&r2=1.27

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/eventmachine/ChangeLog,v
retrieving revision 1.26
retrieving revision 1.27
diff -u -r1.26 -r1.27
--- ChangeLog   5 Aug 2014 16:01:02 -0000       1.26
+++ ChangeLog   7 Jun 2015 06:36:55 -0000       1.27
@@ -1,6 +1,12 @@
 # ChangeLog for dev-ruby/eventmachine
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/eventmachine/ChangeLog,v 1.26 
2014/08/05 16:01:02 mrueg Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/eventmachine/ChangeLog,v 1.27 
2015/06/07 06:36:55 graaff Exp $
+
+*eventmachine-1.0.3-r2 (07 Jun 2015)
+
+  07 Jun 2015; Hans de Graaff <gra...@gentoo.org> eventmachine-1.0.3-r1.ebuild,
+  +eventmachine-1.0.3-r2.ebuild:
+  Create stable candidate.
 
   05 Aug 2014; Manuel Rüger <mr...@gentoo.org> eventmachine-0.12.10-r2.ebuild,
   eventmachine-1.0.3-r1.ebuild:



1.6                  dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild?rev=1.6&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild?rev=1.6&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild?r1=1.5&r2=1.6

Index: eventmachine-1.0.3-r1.ebuild
===================================================================
RCS file: 
/var/cvsroot/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -r1.5 -r1.6
--- eventmachine-1.0.3-r1.ebuild        5 Aug 2014 16:01:02 -0000       1.5
+++ eventmachine-1.0.3-r1.ebuild        7 Jun 2015 06:36:55 -0000       1.6
@@ -1,11 +1,11 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild,v 
1.5 2014/08/05 16:01:02 mrueg Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3-r1.ebuild,v 
1.6 2015/06/07 06:36:55 graaff Exp $
 
 EAPI=5
 # jruby → has shims for Java handling but tests fail badly, remaining
 # stuck; avoid that for now.
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
 
 RUBY_FAKEGEM_TASK_DOC="yard"
 RUBY_FAKEGEM_DOCDIR="rdoc"



1.1                  dev-ruby/eventmachine/eventmachine-1.0.3-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3-r2.ebuild?rev=1.1&content-type=text/plain

Index: eventmachine-1.0.3-r2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/dev-ruby/eventmachine/eventmachine-1.0.3-r2.ebuild,v 
1.1 2015/06/07 06:36:55 graaff Exp $

EAPI=5
# ruby22 - code does not compile
USE_RUBY="ruby19 ruby20 ruby21"

RUBY_FAKEGEM_TASK_DOC="yard"
RUBY_FAKEGEM_DOCDIR="rdoc"
RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"

inherit ruby-fakegem

DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby 
programs"
HOMEPAGE="http://rubyeventmachine.com";

LICENSE="|| ( GPL-2 Ruby )"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos 
~x86-macos ~x64-solaris ~x86-solaris"
IUSE=""

DEPEND="${DEPEND}
        dev-libs/openssl"
RDEPEND="${RDEPEND}
        dev-libs/openssl"

ruby_add_bdepend "doc? ( dev-ruby/yard )"

all_ruby_prepare() {
        # Remove package tasks to avoid dependency on rake-compiler.
        rm rakelib/package.rake || die

        # fix test issue - upstream b96b736b39261f7d74f013633cc7cd619afa20c4
        sed -i -e 's/DEBUG/BROADCAST/g' tests/test_set_sock_opt.rb || die

        # Remove the resolver tests since they require network access and
        # the localhost test fails with an IPv6 localhost.
        rm tests/test_resolver.rb || die
}

each_ruby_configure() {
        for extdir in ext ext/fastfilereader; do
                pushd $extdir
                ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
                popd
        done
}

each_ruby_compile() {
        for extdir in ext ext/fastfilereader; do
                pushd $extdir
                # both extensions use C++, so use the CXXFLAGS not the CFLAGS
                emake V=1 CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || 
die "emake failed for ${extdir}"
                popd
                cp $extdir/*.so lib/ || die "Unable to copy extensions for 
${extdir}"
        done
}

each_ruby_test() {
        ${RUBY} -Ilib -S testrb tests/test_*.rb || die
}

all_ruby_install() {
        all_fakegem_install

        insinto /usr/share/doc/${PF}/
        doins -r examples || die "Failed to install examples"
}




Reply via email to