graaff      15/07/10 06:45:26

  Modified:             ChangeLog
  Added:                redcloth-4.2.9-r4.ebuild redcloth-4.2.9-r3.ebuild
  Removed:              redcloth-4.2.9-r2.ebuild
  Log:
  Add debian patch for bug 536008.
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0x8883FA56A308A8D7!)

Revision  Changes    Path
1.101                dev-ruby/redcloth/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/ChangeLog?rev=1.101&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/ChangeLog?rev=1.101&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/ChangeLog?r1=1.100&r2=1.101

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v
retrieving revision 1.100
retrieving revision 1.101
diff -u -r1.100 -r1.101
--- ChangeLog   7 Jun 2015 19:21:57 -0000       1.100
+++ ChangeLog   10 Jul 2015 06:45:26 -0000      1.101
@@ -1,6 +1,14 @@
 # ChangeLog for dev-ruby/redcloth
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.100 
2015/06/07 19:21:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.101 
2015/07/10 06:45:26 graaff Exp $
+
+*redcloth-4.2.9-r4 (10 Jul 2015)
+*redcloth-4.2.9-r3 (10 Jul 2015)
+
+  10 Jul 2015; Hans de Graaff <gra...@gentoo.org> -redcloth-4.2.9-r2.ebuild,
+  +redcloth-4.2.9-r3.ebuild, +redcloth-4.2.9-r4.ebuild,
+  +files/redcloth-4.2.9-cve-2012-6684.patch:
+  Add debian patch for bug 536008.
 
   07 Jun 2015; Justin Lecher <j...@gentoo.org> metadata.xml:
   Add github to remote-id in metadata.xml



1.1                  dev-ruby/redcloth/redcloth-4.2.9-r4.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r4.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r4.ebuild?rev=1.1&content-type=text/plain

Index: redcloth-4.2.9-r4.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r4.ebuild,v 
1.1 2015/07/10 06:45:26 graaff Exp $

EAPI=5

USE_RUBY="ruby19 ruby20 ruby21 ruby22"

RUBY_FAKEGEM_NAME="RedCloth"

RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_TASK_DOC=""

RUBY_FAKEGEM_DOCDIR="doc"

RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG"

RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"

inherit ruby-fakegem versionator

DESCRIPTION="A module for using Textile in Ruby"
HOMEPAGE="http://redcloth.org/";

GITHUB_USER=jgarber
SRC_URI="https://github.com/${GITHUB_USER}/redcloth/tarball/v${PV} -> 
${RUBY_FAKEGEM_NAME}-git-${PV}.tgz"
RUBY_S="${GITHUB_USER}-${PN}-*"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux 
~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris 
~x64-solaris ~x86-solaris"
IUSE=""

DEPEND+=" dev-util/ragel"

ruby_add_bdepend "
        >=dev-ruby/rake-0.8.7
        >=dev-ruby/rake-compiler-0.7.1
        test? ( >=dev-ruby/diff-lcs-1.1.2 )"

pkg_setup() {
        ruby-ng_pkg_setup

        # Export the VERBOSE variable to avoid remapping of stdout and
        # stderr, and that breaks because of bad interactions between
        # echoe, Ruby and Gentoo.
        export VERBOSE=1
}

RUBY_PATCHES=( ${P}-cve-2012-6684.patch )

all_ruby_prepare() {
        sed -i -e '/[Bb]undler/d' Rakefile ${PN}.gemspec || die
        rm tasks/{release,gems,rspec}.rake || die
}

each_ruby_compile() {
        # We cannot run this manually easily, because Ragel re-generation
        # is a mess
        ${RUBY} -S rake compile || die "rake compile failed"
}



1.1                  dev-ruby/redcloth/redcloth-4.2.9-r3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r3.ebuild?rev=1.1&content-type=text/plain

Index: redcloth-4.2.9-r3.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.9-r3.ebuild,v 
1.1 2015/07/10 06:45:26 graaff Exp $

EAPI=5

USE_RUBY="ruby19 ruby20"

RUBY_FAKEGEM_NAME="RedCloth"

RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_TASK_DOC=""

RUBY_FAKEGEM_DOCDIR="doc"

RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGELOG"

RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"

inherit ruby-fakegem versionator

DESCRIPTION="A module for using Textile in Ruby"
HOMEPAGE="http://redcloth.org/";

GITHUB_USER=jgarber
SRC_URI="https://github.com/${GITHUB_USER}/redcloth/tarball/v${PV} -> 
${RUBY_FAKEGEM_NAME}-git-${PV}.tgz"
RUBY_S="${GITHUB_USER}-${PN}-*"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux 
~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris 
~x64-solaris ~x86-solaris"
IUSE=""

DEPEND+=" dev-util/ragel"

ruby_add_bdepend "
        >=dev-ruby/rake-0.8.7
        >=dev-ruby/rake-compiler-0.7.1
        test? ( >=dev-ruby/diff-lcs-1.1.2 )"

pkg_setup() {
        ruby-ng_pkg_setup

        # Export the VERBOSE variable to avoid remapping of stdout and
        # stderr, and that breaks because of bad interactions between
        # echoe, Ruby and Gentoo.
        export VERBOSE=1
}

RUBY_PATCHES=( ${P}-cve-2012-6684.patch )

all_ruby_prepare() {
        sed -i -e '/[Bb]undler/d' Rakefile ${PN}.gemspec || die
        rm tasks/{release,gems,rspec}.rake || die
}

each_ruby_compile() {
        # We cannot run this manually easily, because Ragel re-generation
        # is a mess
        ${RUBY} -S rake compile || die "rake compile failed"
}




Reply via email to