[gentoo-commits] gentoo-x86 commit in games-action/shootingstar: shootingstar-1.2.0.ebuild ChangeLog

2014-04-09 Thread Michael Sterrett (mr_bones_)
mr_bones_14/04/10 06:30:58

  Modified: shootingstar-1.2.0.ebuild ChangeLog
  Log:
  fix up HOMEPAGE,SRC_URI (bug #499702); EAPI=5; improve icon handling
  
  (Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)

Revision  ChangesPath
1.8  games-action/shootingstar/shootingstar-1.2.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild?rev=1.8&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild?rev=1.8&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild?r1=1.7&r2=1.8

Index: shootingstar-1.2.0.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- shootingstar-1.2.0.ebuild   19 Oct 2009 05:01:04 -  1.7
+++ shootingstar-1.2.0.ebuild   10 Apr 2014 06:30:58 -  1.8
@@ -1,17 +1,17 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 
1.7 2009/10/19 05:01:04 mr_bones_ Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 
1.8 2014/04/10 06:30:58 mr_bones_ Exp $
 
-EAPI=2
-inherit eutils games
+EAPI=5
+inherit autotools eutils gnome2-utils games
 
 DESCRIPTION="A topdown shooter"
-HOMEPAGE="http://www.2ndpoint.fi/ss";
-SRC_URI="http://www.2ndpoint.fi/ss/${P}.tar.gz";
+HOMEPAGE="http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Arcade/Shooting-Star-19754.shtml";
+SRC_URI="mirror://gentoo/${P}.tar.gz"
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="x86"
+KEYWORDS="~amd64 x86"
 IUSE=""
 
 DEPEND="virtual/opengl
@@ -19,16 +19,32 @@
media-libs/libsdl[video]
media-libs/sdl-mixer
media-libs/sdl-image"
+RDEPEND="${DEPEND}"
 
-PATCHES=(
-   "${FILESDIR}"/${PV}-gcc34.patch
-   "${FILESDIR}"/${P}-gcc44.patch
-)
+src_prepare() {
+   epatch \
+   "${FILESDIR}"/${PV}-gcc34.patch \
+   "${FILESDIR}"/${P}-gcc44.patch
+   eautoreconf
+}
 
 src_install () {
-   emake DESTDIR="${D}" install || die "emake install failed"
-   newicon data/textures/body1.png ${PN}.png
+   default
+   newicon -s 128 data/textures/body1.png ${PN}.png
make_desktop_entry ${PN} "Shooting Star"
-   dodoc AUTHORS ChangeLog NEWS README TODO
prepgamesdirs
 }
+
+pkg_preinst() {
+   games_pkg_preinst
+   gnome2_icon_savelist
+}
+
+pkg_postinst() {
+   games_pkg_postinst
+   gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+   gnome2_icon_cache_update
+}



1.8  games-action/shootingstar/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/ChangeLog?rev=1.8&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/ChangeLog?rev=1.8&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/ChangeLog?r1=1.7&r2=1.8

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v
retrieving revision 1.7
retrieving revision 1.8
diff -u -r1.7 -r1.8
--- ChangeLog   19 Oct 2009 05:01:04 -  1.7
+++ ChangeLog   10 Apr 2014 06:30:58 -  1.8
@@ -1,6 +1,10 @@
 # ChangeLog for games-action/shootingstar
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.7 
2009/10/19 05:01:04 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.8 
2014/04/10 06:30:58 mr_bones_ Exp $
+
+  10 Apr 2014; Michael Sterrett 
+  shootingstar-1.2.0.ebuild:
+  fix up HOMEPAGE,SRC_URI (bug #499702); EAPI=5; improve icon handling
 
   19 Oct 2009; Michael Sterrett 
   shootingstar-1.2.0.ebuild:
@@ -26,4 +30,3 @@
   23 Feb 2004; Michael Sterrett  metadata.xml,
   shootingstar-1.2.0.ebuild:
   initial commit; ebuild submitted by Thomas Preissler via bug #42569 
(modified)
-






[gentoo-commits] gentoo-x86 commit in games-action/shootingstar: shootingstar-1.2.0.ebuild ChangeLog

2015-02-06 Thread Michael Sterrett (mr_bones_)
mr_bones_15/02/06 10:02:22

  Modified: shootingstar-1.2.0.ebuild ChangeLog
  Log:
  tidy
  
  (Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)

Revision  ChangesPath
1.9  games-action/shootingstar/shootingstar-1.2.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild?rev=1.9&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild?rev=1.9&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild?r1=1.8&r2=1.9

Index: shootingstar-1.2.0.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -r1.8 -r1.9
--- shootingstar-1.2.0.ebuild   10 Apr 2014 06:30:58 -  1.8
+++ shootingstar-1.2.0.ebuild   6 Feb 2015 10:02:22 -   1.9
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 
1.8 2014/04/10 06:30:58 mr_bones_ Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 
1.9 2015/02/06 10:02:22 mr_bones_ Exp $
 
 EAPI=5
 inherit autotools eutils gnome2-utils games
@@ -19,7 +19,7 @@
media-libs/libsdl[video]
media-libs/sdl-mixer
media-libs/sdl-image"
-RDEPEND="${DEPEND}"
+RDEPEND=${DEPEND}
 
 src_prepare() {
epatch \



1.9  games-action/shootingstar/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/ChangeLog?rev=1.9&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/ChangeLog?rev=1.9&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/ChangeLog?r1=1.8&r2=1.9

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v
retrieving revision 1.8
retrieving revision 1.9
diff -u -r1.8 -r1.9
--- ChangeLog   10 Apr 2014 06:30:58 -  1.8
+++ ChangeLog   6 Feb 2015 10:02:22 -   1.9
@@ -1,6 +1,10 @@
 # ChangeLog for games-action/shootingstar
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.8 
2014/04/10 06:30:58 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.9 
2015/02/06 10:02:22 mr_bones_ Exp $
+
+  06 Feb 2015; Michael Sterrett 
+  shootingstar-1.2.0.ebuild:
+  tidy
 
   10 Apr 2014; Michael Sterrett 
   shootingstar-1.2.0.ebuild:






[gentoo-commits] gentoo-x86 commit in games-action/shootingstar: shootingstar-1.2.0.ebuild ChangeLog

2015-02-06 Thread Agostino Sarubbo (ago)
ago 15/02/06 13:41:29

  Modified: shootingstar-1.2.0.ebuild ChangeLog
  Log:
  Stable for amd64, wrt bug #539046
  
  (Portage version: 2.2.14/cvs/Linux x86_64, RepoMan options: 
--include-arches="amd64", signed Manifest commit with key 7194459F)

Revision  ChangesPath
1.10 games-action/shootingstar/shootingstar-1.2.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild?rev=1.10&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild?rev=1.10&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild?r1=1.9&r2=1.10

Index: shootingstar-1.2.0.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- shootingstar-1.2.0.ebuild   6 Feb 2015 10:02:22 -   1.9
+++ shootingstar-1.2.0.ebuild   6 Feb 2015 13:41:29 -   1.10
@@ -1,6 +1,6 @@
 # Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 
1.9 2015/02/06 10:02:22 mr_bones_ Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 
1.10 2015/02/06 13:41:29 ago Exp $
 
 EAPI=5
 inherit autotools eutils gnome2-utils games
@@ -11,7 +11,7 @@
 
 LICENSE="GPL-2"
 SLOT="0"
-KEYWORDS="~amd64 x86"
+KEYWORDS="amd64 x86"
 IUSE=""
 
 DEPEND="virtual/opengl



1.10 games-action/shootingstar/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/ChangeLog?rev=1.10&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/ChangeLog?rev=1.10&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-action/shootingstar/ChangeLog?r1=1.9&r2=1.10

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v
retrieving revision 1.9
retrieving revision 1.10
diff -u -r1.9 -r1.10
--- ChangeLog   6 Feb 2015 10:02:22 -   1.9
+++ ChangeLog   6 Feb 2015 13:41:29 -   1.10
@@ -1,6 +1,9 @@
 # ChangeLog for games-action/shootingstar
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.9 
2015/02/06 10:02:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/ChangeLog,v 1.10 
2015/02/06 13:41:29 ago Exp $
+
+  06 Feb 2015; Agostino Sarubbo  shootingstar-1.2.0.ebuild:
+  Stable for amd64, wrt bug #539046
 
   06 Feb 2015; Michael Sterrett 
   shootingstar-1.2.0.ebuild: