[gentoo-commits] gentoo-x86 commit in games-fps/unreal-tournament-goty: unreal-tournament-goty-436.ebuild unreal-tournament-goty-451.ebuild ChangeLog

2014-10-15 Thread Pacho Ramos (pacho)
pacho   14/10/15 11:42:52

  Modified: unreal-tournament-goty-436.ebuild
unreal-tournament-goty-451.ebuild ChangeLog
  Log:
  Support multilib providers for deps. Bump to EAPI=5.
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
A188FBD4)

Revision  ChangesPath
1.17 
games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?r1=1.16&r2=1.17

Index: unreal-tournament-goty-436.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
retrieving revision 1.16
retrieving revision 1.17
diff -u -r1.16 -r1.17
--- unreal-tournament-goty-436.ebuild   1 May 2014 13:58:53 -   1.16
+++ unreal-tournament-goty-436.ebuild   15 Oct 2014 11:42:52 -  1.17
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.16 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.17 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -16,12 +18,23 @@
 RESTRICT="mirror bindist"
 
 DEPEND="!games-fps/unreal-tournament
-   app-arch/unzip"
-RDEPEND="opengl? ( virtual/opengl )
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp"
+   app-arch/unzip
+"
+RDEPEND="
+   || (
+   (
+   opengl? ( virtual/opengl[abi_x86_32(-)] )
+   x11-libs/libXext[abi_x86_32(-)]
+   x11-libs/libX11[abi_x86_32(-)]
+   x11-libs/libXau[abi_x86_32(-)]
+   x11-libs/libXdmcp[abi_x86_32(-)]
+   )
+   amd64? (
+   opengl? ( 
app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )
+   app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+   )
+   )
+"
 
 S=${WORKDIR}
 
@@ -49,7 +62,7 @@
# the most important things, ucc & ut :)
exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
-   dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
+   sed -i -e "s:\`FindPath \$0\`:${dir}:" "${ED}/${dir}"/ucc || die
 
# export some symlinks so ppl can run
dodir "${GAMES_BINDIR}"



1.20 
games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?r1=1.19&r2=1.20

Index: unreal-tournament-goty-451.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
retrieving revision 1.19
retrieving revision 1.20
diff -u -r1.19 -r1.20
--- unreal-tournament-goty-451.ebuild   1 May 2014 13:58:53 -   1.19
+++ unreal-tournament-goty-451.ebuild   15 Oct 2014 11:42:52 -  1.20
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.19 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.20 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -15,19 +17,24 @@
 IUSE="3dfx S3TC nls opengl"
 RESTRICT="mirror bindist"
 
-RDEPEND="!amd64? (
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp
-   =media-libs/libsdl-1.2*
-   opengl? ( virtual/opengl ) )
-   amd64? ( app-emulation/emul-linux-x86-sdl
-   app-emulation/emul-linux-x86-baselibs
-   app-emulation/emul-linux-x86-xlibs )"
-DEPEND="${RDEPEND}
-   !games-fps/unreal-tournament
-   app-arch/unzip"
+RDEPEND="
+   || (
+   (
+   opengl? (

[gentoo-commits] gentoo-x86 commit in games-fps/unreal-tournament-goty: unreal-tournament-goty-436.ebuild unreal-tournament-goty-451.ebuild ChangeLog

2014-10-15 Thread Pacho Ramos (pacho)
pacho   14/10/15 11:42:52

  Modified: unreal-tournament-goty-436.ebuild
unreal-tournament-goty-451.ebuild ChangeLog
  Log:
  Support multilib providers for deps. Bump to EAPI=5.
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
A188FBD4)

Revision  ChangesPath
1.17 
games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?r1=1.16&r2=1.17

Index: unreal-tournament-goty-436.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
retrieving revision 1.16
retrieving revision 1.17
diff -u -r1.16 -r1.17
--- unreal-tournament-goty-436.ebuild   1 May 2014 13:58:53 -   1.16
+++ unreal-tournament-goty-436.ebuild   15 Oct 2014 11:42:52 -  1.17
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.16 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.17 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -16,12 +18,23 @@
 RESTRICT="mirror bindist"
 
 DEPEND="!games-fps/unreal-tournament
-   app-arch/unzip"
-RDEPEND="opengl? ( virtual/opengl )
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp"
+   app-arch/unzip
+"
+RDEPEND="
+   || (
+   (
+   opengl? ( virtual/opengl[abi_x86_32(-)] )
+   x11-libs/libXext[abi_x86_32(-)]
+   x11-libs/libX11[abi_x86_32(-)]
+   x11-libs/libXau[abi_x86_32(-)]
+   x11-libs/libXdmcp[abi_x86_32(-)]
+   )
+   amd64? (
+   opengl? ( 
app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )
+   app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+   )
+   )
+"
 
 S=${WORKDIR}
 
@@ -49,7 +62,7 @@
# the most important things, ucc & ut :)
exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
-   dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
+   sed -i -e "s:\`FindPath \$0\`:${dir}:" "${ED}/${dir}"/ucc || die
 
# export some symlinks so ppl can run
dodir "${GAMES_BINDIR}"



1.20 
games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?r1=1.19&r2=1.20

Index: unreal-tournament-goty-451.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
retrieving revision 1.19
retrieving revision 1.20
diff -u -r1.19 -r1.20
--- unreal-tournament-goty-451.ebuild   1 May 2014 13:58:53 -   1.19
+++ unreal-tournament-goty-451.ebuild   15 Oct 2014 11:42:52 -  1.20
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.19 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.20 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -15,19 +17,24 @@
 IUSE="3dfx S3TC nls opengl"
 RESTRICT="mirror bindist"
 
-RDEPEND="!amd64? (
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp
-   =media-libs/libsdl-1.2*
-   opengl? ( virtual/opengl ) )
-   amd64? ( app-emulation/emul-linux-x86-sdl
-   app-emulation/emul-linux-x86-baselibs
-   app-emulation/emul-linux-x86-xlibs )"
-DEPEND="${RDEPEND}
-   !games-fps/unreal-tournament
-   app-arch/unzip"
+RDEPEND="
+   || (
+   (
+   opengl? (

[gentoo-commits] gentoo-x86 commit in games-fps/unreal-tournament-goty: unreal-tournament-goty-436.ebuild unreal-tournament-goty-451.ebuild ChangeLog

2014-10-15 Thread Pacho Ramos (pacho)
pacho   14/10/15 11:42:52

  Modified: unreal-tournament-goty-436.ebuild
unreal-tournament-goty-451.ebuild ChangeLog
  Log:
  Support multilib providers for deps. Bump to EAPI=5.
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
A188FBD4)

Revision  ChangesPath
1.17 
games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?r1=1.16&r2=1.17

Index: unreal-tournament-goty-436.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
retrieving revision 1.16
retrieving revision 1.17
diff -u -r1.16 -r1.17
--- unreal-tournament-goty-436.ebuild   1 May 2014 13:58:53 -   1.16
+++ unreal-tournament-goty-436.ebuild   15 Oct 2014 11:42:52 -  1.17
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.16 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.17 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -16,12 +18,23 @@
 RESTRICT="mirror bindist"
 
 DEPEND="!games-fps/unreal-tournament
-   app-arch/unzip"
-RDEPEND="opengl? ( virtual/opengl )
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp"
+   app-arch/unzip
+"
+RDEPEND="
+   || (
+   (
+   opengl? ( virtual/opengl[abi_x86_32(-)] )
+   x11-libs/libXext[abi_x86_32(-)]
+   x11-libs/libX11[abi_x86_32(-)]
+   x11-libs/libXau[abi_x86_32(-)]
+   x11-libs/libXdmcp[abi_x86_32(-)]
+   )
+   amd64? (
+   opengl? ( 
app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )
+   app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+   )
+   )
+"
 
 S=${WORKDIR}
 
@@ -49,7 +62,7 @@
# the most important things, ucc & ut :)
exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
-   dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
+   sed -i -e "s:\`FindPath \$0\`:${dir}:" "${ED}/${dir}"/ucc || die
 
# export some symlinks so ppl can run
dodir "${GAMES_BINDIR}"



1.20 
games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?r1=1.19&r2=1.20

Index: unreal-tournament-goty-451.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
retrieving revision 1.19
retrieving revision 1.20
diff -u -r1.19 -r1.20
--- unreal-tournament-goty-451.ebuild   1 May 2014 13:58:53 -   1.19
+++ unreal-tournament-goty-451.ebuild   15 Oct 2014 11:42:52 -  1.20
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.19 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.20 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -15,19 +17,24 @@
 IUSE="3dfx S3TC nls opengl"
 RESTRICT="mirror bindist"
 
-RDEPEND="!amd64? (
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp
-   =media-libs/libsdl-1.2*
-   opengl? ( virtual/opengl ) )
-   amd64? ( app-emulation/emul-linux-x86-sdl
-   app-emulation/emul-linux-x86-baselibs
-   app-emulation/emul-linux-x86-xlibs )"
-DEPEND="${RDEPEND}
-   !games-fps/unreal-tournament
-   app-arch/unzip"
+RDEPEND="
+   || (
+   (
+   opengl? (

[gentoo-commits] gentoo-x86 commit in games-fps/unreal-tournament-goty: unreal-tournament-goty-436.ebuild unreal-tournament-goty-451.ebuild ChangeLog

2014-10-15 Thread Pacho Ramos (pacho)
pacho   14/10/15 11:42:52

  Modified: unreal-tournament-goty-436.ebuild
unreal-tournament-goty-451.ebuild ChangeLog
  Log:
  Support multilib providers for deps. Bump to EAPI=5.
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
A188FBD4)

Revision  ChangesPath
1.17 
games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?r1=1.16&r2=1.17

Index: unreal-tournament-goty-436.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
retrieving revision 1.16
retrieving revision 1.17
diff -u -r1.16 -r1.17
--- unreal-tournament-goty-436.ebuild   1 May 2014 13:58:53 -   1.16
+++ unreal-tournament-goty-436.ebuild   15 Oct 2014 11:42:52 -  1.17
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.16 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.17 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -16,12 +18,23 @@
 RESTRICT="mirror bindist"
 
 DEPEND="!games-fps/unreal-tournament
-   app-arch/unzip"
-RDEPEND="opengl? ( virtual/opengl )
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp"
+   app-arch/unzip
+"
+RDEPEND="
+   || (
+   (
+   opengl? ( virtual/opengl[abi_x86_32(-)] )
+   x11-libs/libXext[abi_x86_32(-)]
+   x11-libs/libX11[abi_x86_32(-)]
+   x11-libs/libXau[abi_x86_32(-)]
+   x11-libs/libXdmcp[abi_x86_32(-)]
+   )
+   amd64? (
+   opengl? ( 
app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )
+   app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+   )
+   )
+"
 
 S=${WORKDIR}
 
@@ -49,7 +62,7 @@
# the most important things, ucc & ut :)
exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
-   dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
+   sed -i -e "s:\`FindPath \$0\`:${dir}:" "${ED}/${dir}"/ucc || die
 
# export some symlinks so ppl can run
dodir "${GAMES_BINDIR}"



1.20 
games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?r1=1.19&r2=1.20

Index: unreal-tournament-goty-451.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
retrieving revision 1.19
retrieving revision 1.20
diff -u -r1.19 -r1.20
--- unreal-tournament-goty-451.ebuild   1 May 2014 13:58:53 -   1.19
+++ unreal-tournament-goty-451.ebuild   15 Oct 2014 11:42:52 -  1.20
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.19 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.20 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -15,19 +17,24 @@
 IUSE="3dfx S3TC nls opengl"
 RESTRICT="mirror bindist"
 
-RDEPEND="!amd64? (
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp
-   =media-libs/libsdl-1.2*
-   opengl? ( virtual/opengl ) )
-   amd64? ( app-emulation/emul-linux-x86-sdl
-   app-emulation/emul-linux-x86-baselibs
-   app-emulation/emul-linux-x86-xlibs )"
-DEPEND="${RDEPEND}
-   !games-fps/unreal-tournament
-   app-arch/unzip"
+RDEPEND="
+   || (
+   (
+   opengl? (

[gentoo-commits] gentoo-x86 commit in games-fps/unreal-tournament-goty: unreal-tournament-goty-436.ebuild unreal-tournament-goty-451.ebuild ChangeLog

2014-10-15 Thread Pacho Ramos (pacho)
pacho   14/10/15 11:42:52

  Modified: unreal-tournament-goty-436.ebuild
unreal-tournament-goty-451.ebuild ChangeLog
  Log:
  Support multilib providers for deps. Bump to EAPI=5.
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
A188FBD4)

Revision  ChangesPath
1.17 
games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?r1=1.16&r2=1.17

Index: unreal-tournament-goty-436.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
retrieving revision 1.16
retrieving revision 1.17
diff -u -r1.16 -r1.17
--- unreal-tournament-goty-436.ebuild   1 May 2014 13:58:53 -   1.16
+++ unreal-tournament-goty-436.ebuild   15 Oct 2014 11:42:52 -  1.17
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.16 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.17 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -16,12 +18,23 @@
 RESTRICT="mirror bindist"
 
 DEPEND="!games-fps/unreal-tournament
-   app-arch/unzip"
-RDEPEND="opengl? ( virtual/opengl )
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp"
+   app-arch/unzip
+"
+RDEPEND="
+   || (
+   (
+   opengl? ( virtual/opengl[abi_x86_32(-)] )
+   x11-libs/libXext[abi_x86_32(-)]
+   x11-libs/libX11[abi_x86_32(-)]
+   x11-libs/libXau[abi_x86_32(-)]
+   x11-libs/libXdmcp[abi_x86_32(-)]
+   )
+   amd64? (
+   opengl? ( 
app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )
+   app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+   )
+   )
+"
 
 S=${WORKDIR}
 
@@ -49,7 +62,7 @@
# the most important things, ucc & ut :)
exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
-   dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
+   sed -i -e "s:\`FindPath \$0\`:${dir}:" "${ED}/${dir}"/ucc || die
 
# export some symlinks so ppl can run
dodir "${GAMES_BINDIR}"



1.20 
games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?r1=1.19&r2=1.20

Index: unreal-tournament-goty-451.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
retrieving revision 1.19
retrieving revision 1.20
diff -u -r1.19 -r1.20
--- unreal-tournament-goty-451.ebuild   1 May 2014 13:58:53 -   1.19
+++ unreal-tournament-goty-451.ebuild   15 Oct 2014 11:42:52 -  1.20
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.19 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.20 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -15,19 +17,24 @@
 IUSE="3dfx S3TC nls opengl"
 RESTRICT="mirror bindist"
 
-RDEPEND="!amd64? (
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp
-   =media-libs/libsdl-1.2*
-   opengl? ( virtual/opengl ) )
-   amd64? ( app-emulation/emul-linux-x86-sdl
-   app-emulation/emul-linux-x86-baselibs
-   app-emulation/emul-linux-x86-xlibs )"
-DEPEND="${RDEPEND}
-   !games-fps/unreal-tournament
-   app-arch/unzip"
+RDEPEND="
+   || (
+   (
+   opengl? (

[gentoo-commits] gentoo-x86 commit in games-fps/unreal-tournament-goty: unreal-tournament-goty-436.ebuild unreal-tournament-goty-451.ebuild ChangeLog

2014-10-15 Thread Pacho Ramos (pacho)
pacho   14/10/15 11:42:52

  Modified: unreal-tournament-goty-436.ebuild
unreal-tournament-goty-451.ebuild ChangeLog
  Log:
  Support multilib providers for deps. Bump to EAPI=5.
  
  (Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 
A188FBD4)

Revision  ChangesPath
1.17 
games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?rev=1.17&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild?r1=1.16&r2=1.17

Index: unreal-tournament-goty-436.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
retrieving revision 1.16
retrieving revision 1.17
diff -u -r1.16 -r1.17
--- unreal-tournament-goty-436.ebuild   1 May 2014 13:58:53 -   1.16
+++ unreal-tournament-goty-436.ebuild   15 Oct 2014 11:42:52 -  1.17
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.16 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v
 1.17 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -16,12 +18,23 @@
 RESTRICT="mirror bindist"
 
 DEPEND="!games-fps/unreal-tournament
-   app-arch/unzip"
-RDEPEND="opengl? ( virtual/opengl )
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp"
+   app-arch/unzip
+"
+RDEPEND="
+   || (
+   (
+   opengl? ( virtual/opengl[abi_x86_32(-)] )
+   x11-libs/libXext[abi_x86_32(-)]
+   x11-libs/libX11[abi_x86_32(-)]
+   x11-libs/libXau[abi_x86_32(-)]
+   x11-libs/libXdmcp[abi_x86_32(-)]
+   )
+   amd64? (
+   opengl? ( 
app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )
+   app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+   )
+   )
+"
 
 S=${WORKDIR}
 
@@ -49,7 +62,7 @@
# the most important things, ucc & ut :)
exeinto "${dir}"
doexe bin/x86/{ucc,ut} || die "install ucc/ut"
-   dosed "s:\`FindPath \$0\`:${dir}:" "${dir}"/ucc
+   sed -i -e "s:\`FindPath \$0\`:${dir}:" "${ED}/${dir}"/ucc || die
 
# export some symlinks so ppl can run
dodir "${GAMES_BINDIR}"



1.20 
games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?rev=1.20&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild?r1=1.19&r2=1.20

Index: unreal-tournament-goty-451.ebuild
===
RCS file: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
retrieving revision 1.19
retrieving revision 1.20
diff -u -r1.19 -r1.20
--- unreal-tournament-goty-451.ebuild   1 May 2014 13:58:53 -   1.19
+++ unreal-tournament-goty-451.ebuild   15 Oct 2014 11:42:52 -  1.20
@@ -1,6 +1,8 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.19 2014/05/01 13:58:53 ulm Exp $
+# $Header: 
/var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v
 1.20 2014/10/15 11:42:52 pacho Exp $
+
+EAPI=5
 
 inherit eutils unpacker cdrom games
 
@@ -15,19 +17,24 @@
 IUSE="3dfx S3TC nls opengl"
 RESTRICT="mirror bindist"
 
-RDEPEND="!amd64? (
-   x11-libs/libXext
-   x11-libs/libX11
-   x11-libs/libXau
-   x11-libs/libXdmcp
-   =media-libs/libsdl-1.2*
-   opengl? ( virtual/opengl ) )
-   amd64? ( app-emulation/emul-linux-x86-sdl
-   app-emulation/emul-linux-x86-baselibs
-   app-emulation/emul-linux-x86-xlibs )"
-DEPEND="${RDEPEND}
-   !games-fps/unreal-tournament
-   app-arch/unzip"
+RDEPEND="
+   || (
+   (
+   opengl? (