[gentoo-commits] gentoo-x86 commit in games-strategy/0ad: 0ad-0.0.16_alpha-r2.ebuild ChangeLog 0ad-0.0.16_alpha-r1.ebuild

2014-06-17 Thread Julian Ospald (hasufell)
hasufell14/06/17 20:44:56

  Modified: ChangeLog
  Added:0ad-0.0.16_alpha-r2.ebuild
  Removed:  0ad-0.0.16_alpha-r1.ebuild
  Log:
  add patch that fixes UD, fix HOMEPAGE
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  ChangesPath
1.3  games-strategy/0ad/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   22 May 2014 12:06:23 -  1.2
+++ ChangeLog   17 Jun 2014 20:44:55 -  1.3
@@ -1,6 +1,12 @@
 # ChangeLog for games-strategy/0ad
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.2 
2014/05/22 12:06:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.3 
2014/06/17 20:44:55 hasufell Exp $
+
+*0ad-0.0.16_alpha-r2 (17 Jun 2014)
+
+  17 Jun 2014; Julian Ospald  -0ad-0.0.16_alpha-r1.ebuild,
+  +0ad-0.0.16_alpha-r2.ebuild, +files/0ad-0.0.16_alpha-gcc-4.9.patch:
+  add patch that fixes UD, fix HOMEPAGE
 
 *0ad-0.0.16_alpha-r1 (22 May 2014)
 



1.1  games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&content-type=text/plain

Index: 0ad-0.0.16_alpha-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild,v 1.1 
2014/06/17 20:44:55 hasufell Exp $

EAPI=5

WX_GTK_VER="2.8"

inherit eutils wxwidgets toolchain-funcs gnome2-utils games

MY_P=0ad-${PV/_/-}
DESCRIPTION="A free, real-time strategy game"
HOMEPAGE="http://play0ad.com/";
SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz";

LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="editor +lobby pch sound test"
RESTRICT="test"

RDEPEND="
dev-lang/spidermonkey:24
dev-libs/boost
dev-libs/icu
dev-libs/libxml2
~games-strategy/0ad-data-${PV}
media-gfx/nvidia-texture-tools
media-libs/libpng:0
media-libs/libsdl[X,opengl,video]
net-libs/enet:1.3
net-libs/miniupnpc
net-misc/curl
sys-libs/zlib
virtual/jpeg
virtual/opengl
x11-libs/libX11
x11-libs/libXcursor
editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
lobby? ( net-libs/gloox )
sound? ( media-libs/libogg
media-libs/libvorbis
media-libs/openal )"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-lang/perl )"

S=${WORKDIR}/${MY_P}

src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-gcc-4.9.patch
}

src_configure() {
local myconf=(
--with-system-nvtt
--with-system-enet
--with-system-miniupnpc
--with-system-mozjs24
--minimal-flags
$(usex pch "" "--without-pch")
$(usex test "" "--without-tests")
$(usex sound "" "--without-audio")
$(usex editor "--atlas" "")
$(usex lobby "" "--without-lobby")
--collada
--bindir="${GAMES_BINDIR}"
--libdir="$(games_get_libdir)"/${PN}
--datadir="${GAMES_DATADIR}"/${PN}
)

# stock premake4 does not work, use the shipped one
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# regenerate scripts.c so our patch applies
cd "${S}"/build/premake/premake4 || die
"${S}"/build/premake/premake4/bin/release/premake4 embed || die

# rebuild premake again... this is the most stupid build system
emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# run premake to create build scripts
cd "${S}"/build/premake || die
"${S}"/build/premake/premake4/bin/release/premake4 \
--file="premake4.lua" \
--outpath="../workspaces/gcc/" \
--platform=$(usex amd64 "x64" "x32") \

[gentoo-commits] gentoo-x86 commit in games-strategy/0ad: 0ad-0.0.16_alpha-r2.ebuild ChangeLog 0ad-0.0.16_alpha-r1.ebuild

2014-06-17 Thread Julian Ospald (hasufell)
hasufell14/06/17 20:44:56

  Modified: ChangeLog
  Added:0ad-0.0.16_alpha-r2.ebuild
  Removed:  0ad-0.0.16_alpha-r1.ebuild
  Log:
  add patch that fixes UD, fix HOMEPAGE
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  ChangesPath
1.3  games-strategy/0ad/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   22 May 2014 12:06:23 -  1.2
+++ ChangeLog   17 Jun 2014 20:44:55 -  1.3
@@ -1,6 +1,12 @@
 # ChangeLog for games-strategy/0ad
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.2 
2014/05/22 12:06:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.3 
2014/06/17 20:44:55 hasufell Exp $
+
+*0ad-0.0.16_alpha-r2 (17 Jun 2014)
+
+  17 Jun 2014; Julian Ospald  -0ad-0.0.16_alpha-r1.ebuild,
+  +0ad-0.0.16_alpha-r2.ebuild, +files/0ad-0.0.16_alpha-gcc-4.9.patch:
+  add patch that fixes UD, fix HOMEPAGE
 
 *0ad-0.0.16_alpha-r1 (22 May 2014)
 



1.1  games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&content-type=text/plain

Index: 0ad-0.0.16_alpha-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild,v 1.1 
2014/06/17 20:44:55 hasufell Exp $

EAPI=5

WX_GTK_VER="2.8"

inherit eutils wxwidgets toolchain-funcs gnome2-utils games

MY_P=0ad-${PV/_/-}
DESCRIPTION="A free, real-time strategy game"
HOMEPAGE="http://play0ad.com/";
SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz";

LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="editor +lobby pch sound test"
RESTRICT="test"

RDEPEND="
dev-lang/spidermonkey:24
dev-libs/boost
dev-libs/icu
dev-libs/libxml2
~games-strategy/0ad-data-${PV}
media-gfx/nvidia-texture-tools
media-libs/libpng:0
media-libs/libsdl[X,opengl,video]
net-libs/enet:1.3
net-libs/miniupnpc
net-misc/curl
sys-libs/zlib
virtual/jpeg
virtual/opengl
x11-libs/libX11
x11-libs/libXcursor
editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
lobby? ( net-libs/gloox )
sound? ( media-libs/libogg
media-libs/libvorbis
media-libs/openal )"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-lang/perl )"

S=${WORKDIR}/${MY_P}

src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-gcc-4.9.patch
}

src_configure() {
local myconf=(
--with-system-nvtt
--with-system-enet
--with-system-miniupnpc
--with-system-mozjs24
--minimal-flags
$(usex pch "" "--without-pch")
$(usex test "" "--without-tests")
$(usex sound "" "--without-audio")
$(usex editor "--atlas" "")
$(usex lobby "" "--without-lobby")
--collada
--bindir="${GAMES_BINDIR}"
--libdir="$(games_get_libdir)"/${PN}
--datadir="${GAMES_DATADIR}"/${PN}
)

# stock premake4 does not work, use the shipped one
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# regenerate scripts.c so our patch applies
cd "${S}"/build/premake/premake4 || die
"${S}"/build/premake/premake4/bin/release/premake4 embed || die

# rebuild premake again... this is the most stupid build system
emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# run premake to create build scripts
cd "${S}"/build/premake || die
"${S}"/build/premake/premake4/bin/release/premake4 \
--file="premake4.lua" \
--outpath="../workspaces/gcc/" \
--platform=$(usex amd64 "x64" "x32") \

[gentoo-commits] gentoo-x86 commit in games-strategy/0ad: 0ad-0.0.16_alpha-r2.ebuild ChangeLog 0ad-0.0.16_alpha-r1.ebuild

2014-06-17 Thread Julian Ospald (hasufell)
hasufell14/06/17 20:44:56

  Modified: ChangeLog
  Added:0ad-0.0.16_alpha-r2.ebuild
  Removed:  0ad-0.0.16_alpha-r1.ebuild
  Log:
  add patch that fixes UD, fix HOMEPAGE
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  ChangesPath
1.3  games-strategy/0ad/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   22 May 2014 12:06:23 -  1.2
+++ ChangeLog   17 Jun 2014 20:44:55 -  1.3
@@ -1,6 +1,12 @@
 # ChangeLog for games-strategy/0ad
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.2 
2014/05/22 12:06:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.3 
2014/06/17 20:44:55 hasufell Exp $
+
+*0ad-0.0.16_alpha-r2 (17 Jun 2014)
+
+  17 Jun 2014; Julian Ospald  -0ad-0.0.16_alpha-r1.ebuild,
+  +0ad-0.0.16_alpha-r2.ebuild, +files/0ad-0.0.16_alpha-gcc-4.9.patch:
+  add patch that fixes UD, fix HOMEPAGE
 
 *0ad-0.0.16_alpha-r1 (22 May 2014)
 



1.1  games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&content-type=text/plain

Index: 0ad-0.0.16_alpha-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild,v 1.1 
2014/06/17 20:44:55 hasufell Exp $

EAPI=5

WX_GTK_VER="2.8"

inherit eutils wxwidgets toolchain-funcs gnome2-utils games

MY_P=0ad-${PV/_/-}
DESCRIPTION="A free, real-time strategy game"
HOMEPAGE="http://play0ad.com/";
SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz";

LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="editor +lobby pch sound test"
RESTRICT="test"

RDEPEND="
dev-lang/spidermonkey:24
dev-libs/boost
dev-libs/icu
dev-libs/libxml2
~games-strategy/0ad-data-${PV}
media-gfx/nvidia-texture-tools
media-libs/libpng:0
media-libs/libsdl[X,opengl,video]
net-libs/enet:1.3
net-libs/miniupnpc
net-misc/curl
sys-libs/zlib
virtual/jpeg
virtual/opengl
x11-libs/libX11
x11-libs/libXcursor
editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
lobby? ( net-libs/gloox )
sound? ( media-libs/libogg
media-libs/libvorbis
media-libs/openal )"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-lang/perl )"

S=${WORKDIR}/${MY_P}

src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-gcc-4.9.patch
}

src_configure() {
local myconf=(
--with-system-nvtt
--with-system-enet
--with-system-miniupnpc
--with-system-mozjs24
--minimal-flags
$(usex pch "" "--without-pch")
$(usex test "" "--without-tests")
$(usex sound "" "--without-audio")
$(usex editor "--atlas" "")
$(usex lobby "" "--without-lobby")
--collada
--bindir="${GAMES_BINDIR}"
--libdir="$(games_get_libdir)"/${PN}
--datadir="${GAMES_DATADIR}"/${PN}
)

# stock premake4 does not work, use the shipped one
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# regenerate scripts.c so our patch applies
cd "${S}"/build/premake/premake4 || die
"${S}"/build/premake/premake4/bin/release/premake4 embed || die

# rebuild premake again... this is the most stupid build system
emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# run premake to create build scripts
cd "${S}"/build/premake || die
"${S}"/build/premake/premake4/bin/release/premake4 \
--file="premake4.lua" \
--outpath="../workspaces/gcc/" \
--platform=$(usex amd64 "x64" "x32") \

[gentoo-commits] gentoo-x86 commit in games-strategy/0ad: 0ad-0.0.16_alpha-r2.ebuild ChangeLog 0ad-0.0.16_alpha-r1.ebuild

2014-06-17 Thread Julian Ospald (hasufell)
hasufell14/06/17 20:44:56

  Modified: ChangeLog
  Added:0ad-0.0.16_alpha-r2.ebuild
  Removed:  0ad-0.0.16_alpha-r1.ebuild
  Log:
  add patch that fixes UD, fix HOMEPAGE
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  ChangesPath
1.3  games-strategy/0ad/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   22 May 2014 12:06:23 -  1.2
+++ ChangeLog   17 Jun 2014 20:44:55 -  1.3
@@ -1,6 +1,12 @@
 # ChangeLog for games-strategy/0ad
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.2 
2014/05/22 12:06:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.3 
2014/06/17 20:44:55 hasufell Exp $
+
+*0ad-0.0.16_alpha-r2 (17 Jun 2014)
+
+  17 Jun 2014; Julian Ospald  -0ad-0.0.16_alpha-r1.ebuild,
+  +0ad-0.0.16_alpha-r2.ebuild, +files/0ad-0.0.16_alpha-gcc-4.9.patch:
+  add patch that fixes UD, fix HOMEPAGE
 
 *0ad-0.0.16_alpha-r1 (22 May 2014)
 



1.1  games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&content-type=text/plain

Index: 0ad-0.0.16_alpha-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild,v 1.1 
2014/06/17 20:44:55 hasufell Exp $

EAPI=5

WX_GTK_VER="2.8"

inherit eutils wxwidgets toolchain-funcs gnome2-utils games

MY_P=0ad-${PV/_/-}
DESCRIPTION="A free, real-time strategy game"
HOMEPAGE="http://play0ad.com/";
SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz";

LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="editor +lobby pch sound test"
RESTRICT="test"

RDEPEND="
dev-lang/spidermonkey:24
dev-libs/boost
dev-libs/icu
dev-libs/libxml2
~games-strategy/0ad-data-${PV}
media-gfx/nvidia-texture-tools
media-libs/libpng:0
media-libs/libsdl[X,opengl,video]
net-libs/enet:1.3
net-libs/miniupnpc
net-misc/curl
sys-libs/zlib
virtual/jpeg
virtual/opengl
x11-libs/libX11
x11-libs/libXcursor
editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
lobby? ( net-libs/gloox )
sound? ( media-libs/libogg
media-libs/libvorbis
media-libs/openal )"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-lang/perl )"

S=${WORKDIR}/${MY_P}

src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-gcc-4.9.patch
}

src_configure() {
local myconf=(
--with-system-nvtt
--with-system-enet
--with-system-miniupnpc
--with-system-mozjs24
--minimal-flags
$(usex pch "" "--without-pch")
$(usex test "" "--without-tests")
$(usex sound "" "--without-audio")
$(usex editor "--atlas" "")
$(usex lobby "" "--without-lobby")
--collada
--bindir="${GAMES_BINDIR}"
--libdir="$(games_get_libdir)"/${PN}
--datadir="${GAMES_DATADIR}"/${PN}
)

# stock premake4 does not work, use the shipped one
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# regenerate scripts.c so our patch applies
cd "${S}"/build/premake/premake4 || die
"${S}"/build/premake/premake4/bin/release/premake4 embed || die

# rebuild premake again... this is the most stupid build system
emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# run premake to create build scripts
cd "${S}"/build/premake || die
"${S}"/build/premake/premake4/bin/release/premake4 \
--file="premake4.lua" \
--outpath="../workspaces/gcc/" \
--platform=$(usex amd64 "x64" "x32") \

[gentoo-commits] gentoo-x86 commit in games-strategy/0ad: 0ad-0.0.16_alpha-r2.ebuild ChangeLog 0ad-0.0.16_alpha-r1.ebuild

2014-06-17 Thread Julian Ospald (hasufell)
hasufell14/06/17 20:44:56

  Modified: ChangeLog
  Added:0ad-0.0.16_alpha-r2.ebuild
  Removed:  0ad-0.0.16_alpha-r1.ebuild
  Log:
  add patch that fixes UD, fix HOMEPAGE
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  ChangesPath
1.3  games-strategy/0ad/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   22 May 2014 12:06:23 -  1.2
+++ ChangeLog   17 Jun 2014 20:44:55 -  1.3
@@ -1,6 +1,12 @@
 # ChangeLog for games-strategy/0ad
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.2 
2014/05/22 12:06:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.3 
2014/06/17 20:44:55 hasufell Exp $
+
+*0ad-0.0.16_alpha-r2 (17 Jun 2014)
+
+  17 Jun 2014; Julian Ospald  -0ad-0.0.16_alpha-r1.ebuild,
+  +0ad-0.0.16_alpha-r2.ebuild, +files/0ad-0.0.16_alpha-gcc-4.9.patch:
+  add patch that fixes UD, fix HOMEPAGE
 
 *0ad-0.0.16_alpha-r1 (22 May 2014)
 



1.1  games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&content-type=text/plain

Index: 0ad-0.0.16_alpha-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild,v 1.1 
2014/06/17 20:44:55 hasufell Exp $

EAPI=5

WX_GTK_VER="2.8"

inherit eutils wxwidgets toolchain-funcs gnome2-utils games

MY_P=0ad-${PV/_/-}
DESCRIPTION="A free, real-time strategy game"
HOMEPAGE="http://play0ad.com/";
SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz";

LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="editor +lobby pch sound test"
RESTRICT="test"

RDEPEND="
dev-lang/spidermonkey:24
dev-libs/boost
dev-libs/icu
dev-libs/libxml2
~games-strategy/0ad-data-${PV}
media-gfx/nvidia-texture-tools
media-libs/libpng:0
media-libs/libsdl[X,opengl,video]
net-libs/enet:1.3
net-libs/miniupnpc
net-misc/curl
sys-libs/zlib
virtual/jpeg
virtual/opengl
x11-libs/libX11
x11-libs/libXcursor
editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
lobby? ( net-libs/gloox )
sound? ( media-libs/libogg
media-libs/libvorbis
media-libs/openal )"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-lang/perl )"

S=${WORKDIR}/${MY_P}

src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-gcc-4.9.patch
}

src_configure() {
local myconf=(
--with-system-nvtt
--with-system-enet
--with-system-miniupnpc
--with-system-mozjs24
--minimal-flags
$(usex pch "" "--without-pch")
$(usex test "" "--without-tests")
$(usex sound "" "--without-audio")
$(usex editor "--atlas" "")
$(usex lobby "" "--without-lobby")
--collada
--bindir="${GAMES_BINDIR}"
--libdir="$(games_get_libdir)"/${PN}
--datadir="${GAMES_DATADIR}"/${PN}
)

# stock premake4 does not work, use the shipped one
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# regenerate scripts.c so our patch applies
cd "${S}"/build/premake/premake4 || die
"${S}"/build/premake/premake4/bin/release/premake4 embed || die

# rebuild premake again... this is the most stupid build system
emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# run premake to create build scripts
cd "${S}"/build/premake || die
"${S}"/build/premake/premake4/bin/release/premake4 \
--file="premake4.lua" \
--outpath="../workspaces/gcc/" \
--platform=$(usex amd64 "x64" "x32") \

[gentoo-commits] gentoo-x86 commit in games-strategy/0ad: 0ad-0.0.16_alpha-r2.ebuild ChangeLog 0ad-0.0.16_alpha-r1.ebuild

2014-06-17 Thread Julian Ospald (hasufell)
hasufell14/06/17 20:44:56

  Modified: ChangeLog
  Added:0ad-0.0.16_alpha-r2.ebuild
  Removed:  0ad-0.0.16_alpha-r1.ebuild
  Log:
  add patch that fixes UD, fix HOMEPAGE
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
BDEED020)

Revision  ChangesPath
1.3  games-strategy/0ad/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?rev=1.3&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/ChangeLog?r1=1.2&r2=1.3

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v
retrieving revision 1.2
retrieving revision 1.3
diff -u -r1.2 -r1.3
--- ChangeLog   22 May 2014 12:06:23 -  1.2
+++ ChangeLog   17 Jun 2014 20:44:55 -  1.3
@@ -1,6 +1,12 @@
 # ChangeLog for games-strategy/0ad
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.2 
2014/05/22 12:06:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/0ad/ChangeLog,v 1.3 
2014/06/17 20:44:55 hasufell Exp $
+
+*0ad-0.0.16_alpha-r2 (17 Jun 2014)
+
+  17 Jun 2014; Julian Ospald  -0ad-0.0.16_alpha-r1.ebuild,
+  +0ad-0.0.16_alpha-r2.ebuild, +files/0ad-0.0.16_alpha-gcc-4.9.patch:
+  add patch that fixes UD, fix HOMEPAGE
 
 *0ad-0.0.16_alpha-r1 (22 May 2014)
 



1.1  games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild?rev=1.1&content-type=text/plain

Index: 0ad-0.0.16_alpha-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/games-strategy/0ad/0ad-0.0.16_alpha-r2.ebuild,v 1.1 
2014/06/17 20:44:55 hasufell Exp $

EAPI=5

WX_GTK_VER="2.8"

inherit eutils wxwidgets toolchain-funcs gnome2-utils games

MY_P=0ad-${PV/_/-}
DESCRIPTION="A free, real-time strategy game"
HOMEPAGE="http://play0ad.com/";
SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz";

LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="editor +lobby pch sound test"
RESTRICT="test"

RDEPEND="
dev-lang/spidermonkey:24
dev-libs/boost
dev-libs/icu
dev-libs/libxml2
~games-strategy/0ad-data-${PV}
media-gfx/nvidia-texture-tools
media-libs/libpng:0
media-libs/libsdl[X,opengl,video]
net-libs/enet:1.3
net-libs/miniupnpc
net-misc/curl
sys-libs/zlib
virtual/jpeg
virtual/opengl
x11-libs/libX11
x11-libs/libXcursor
editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
lobby? ( net-libs/gloox )
sound? ( media-libs/libogg
media-libs/libvorbis
media-libs/openal )"
DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-lang/perl )"

S=${WORKDIR}/${MY_P}

src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch \
"${FILESDIR}"/${P}-gcc-4.9.patch
}

src_configure() {
local myconf=(
--with-system-nvtt
--with-system-enet
--with-system-miniupnpc
--with-system-mozjs24
--minimal-flags
$(usex pch "" "--without-pch")
$(usex test "" "--without-tests")
$(usex sound "" "--without-audio")
$(usex editor "--atlas" "")
$(usex lobby "" "--without-lobby")
--collada
--bindir="${GAMES_BINDIR}"
--libdir="$(games_get_libdir)"/${PN}
--datadir="${GAMES_DATADIR}"/${PN}
)

# stock premake4 does not work, use the shipped one
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# regenerate scripts.c so our patch applies
cd "${S}"/build/premake/premake4 || die
"${S}"/build/premake/premake4/bin/release/premake4 embed || die

# rebuild premake again... this is the most stupid build system
emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# run premake to create build scripts
cd "${S}"/build/premake || die
"${S}"/build/premake/premake4/bin/release/premake4 \
--file="premake4.lua" \
--outpath="../workspaces/gcc/" \
--platform=$(usex amd64 "x64" "x32") \