mgorny      14/11/30 13:36:09

  Modified:             ChangeLog
  Added:                libiptcdata-1.0.4-r1.ebuild
  Log:
  Convert to python-single-r1.
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
EFB4464E!)

Revision  Changes    Path
1.28                 media-libs/libiptcdata/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/libiptcdata/ChangeLog?rev=1.28&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/libiptcdata/ChangeLog?rev=1.28&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/libiptcdata/ChangeLog?r1=1.27&r2=1.28

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/media-libs/libiptcdata/ChangeLog,v
retrieving revision 1.27
retrieving revision 1.28
diff -u -r1.27 -r1.28
--- ChangeLog   24 Jun 2014 03:46:01 -0000      1.27
+++ ChangeLog   30 Nov 2014 13:36:09 -0000      1.28
@@ -1,6 +1,11 @@
 # ChangeLog for media-libs/libiptcdata
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libiptcdata/ChangeLog,v 1.27 
2014/06/24 03:46:01 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libiptcdata/ChangeLog,v 1.28 
2014/11/30 13:36:09 mgorny Exp $
+
+*libiptcdata-1.0.4-r1 (30 Nov 2014)
+
+  30 Nov 2014; Michał Górny <mgo...@gentoo.org> +libiptcdata-1.0.4-r1.ebuild:
+  Convert to python-single-r1.
 
   24 Jun 2014; Patrick Lauer <patr...@gentoo.org> libiptcdata-1.0.4.ebuild:
   Remove obsolete lafilefixer message



1.1                  media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild?rev=1.1&content-type=text/plain

Index: libiptcdata-1.0.4-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/media-libs/libiptcdata/libiptcdata-1.0.4-r1.ebuild,v 
1.1 2014/11/30 13:36:09 mgorny Exp $

EAPI=5

PYTHON_COMPAT=( python2_7 )

inherit eutils python-single-r1

DESCRIPTION="library for manipulating the International Press Telecommunications
Council (IPTC) metadata"
HOMEPAGE="http://libiptcdata.sourceforge.net";
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"

LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc examples nls python"

RDEPEND="python? ( ${PYTHON_DEPS} )
        nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
        nls? ( >=sys-devel/gettext-0.13.1 )
        doc? ( >=dev-util/gtk-doc-1 )"

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

pkg_setup() {
        use python && python-single-r1_pkg_setup
}

src_configure () {
        econf \
                $(use_enable nls) \
                $(use_enable python) \
                $(use_enable doc gtk-doc)
}

src_install () {
        emake DESTDIR="${D}" install || die "emake install failed."
        dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed."

        if use examples; then
                insinto /usr/share/doc/${PF}/python
                doins python/README || die "doins failed"
                doins -r python/examples || die "doins 2 failed"
        fi

        find "${D}" -name '*.la' -delete || die "failed to remove *.la files"
}




Reply via email to