[gentoo-commits] gentoo-x86 commit in media-plugins/gimp-gmic: ChangeLog gimp-gmic-1.6.0.3.ebuild

2015-01-07 Thread Tim Harder (radhermit)
radhermit15/01/08 04:53:37

  Modified: ChangeLog
  Added:gimp-gmic-1.6.0.3.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
4AB3E85B4F064CA3)

Revision  ChangesPath
1.50 media-plugins/gimp-gmic/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?r1=1.49&r2=1.50

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v
retrieving revision 1.49
retrieving revision 1.50
diff -u -r1.49 -r1.50
--- ChangeLog   8 Jan 2015 04:44:15 -   1.49
+++ ChangeLog   8 Jan 2015 04:53:37 -   1.50
@@ -1,6 +1,11 @@
 # ChangeLog for media-plugins/gimp-gmic
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.49 
2015/01/08 04:44:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.50 
2015/01/08 04:53:37 radhermit Exp $
+
+*gimp-gmic-1.6.0.3 (08 Jan 2015)
+
+  08 Jan 2015; Tim Harder  +gimp-gmic-1.6.0.3.ebuild:
+  Version bump.
 
   08 Jan 2015; Tim Harder  -gimp-gmic-1.5.8.6.ebuild,
   -gimp-gmic-1.5.9.1.ebuild, -gimp-gmic-1.5.9.2-r1.ebuild,



1.1  media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&content-type=text/plain

Index: gimp-gmic-1.6.0.3.ebuild
===
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild,v 1.1 
2015/01/08 04:53:37 radhermit Exp $

EAPI=5

inherit eutils toolchain-funcs flag-o-matic

DESCRIPTION="G'MIC GIMP plugin"
HOMEPAGE="http://gmic.sourceforge.net/gimp.shtml";
SRC_URI="mirror://sourceforge/gmic/gmic_${PV}.tar.gz"

LICENSE="CeCILL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="openmp"

RDEPEND="
>=media-gfx/gimp-2.4.0
media-libs/libpng:0=
sci-libs/fftw:3.0[threads]
sys-libs/zlib
"
DEPEND="${RDEPEND}"

S=${WORKDIR}/gmic-${PV}/src

pkg_pretend() {
if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible 
compiler"
fi

if ! test-flag-CXX -std=c++11 ; then
die "You need at least GCC 4.7.x or Clang >= 3.3 for 
C++11-specific compiler flags"
fi
}

src_prepare() {
cp "${FILESDIR}"/gmic-1.6.0.2-makefile.patch "${WORKDIR}" || die
edos2unix "${WORKDIR}"/gmic-1.6.0.2-makefile.patch
epatch "${WORKDIR}"/gmic-1.6.0.2-makefile.patch

if ! use openmp ; then
sed -i -r "s/^(OPENMP_(CFLAGS|LIBS) =).*/\1/" Makefile || die
fi
}

src_compile() {
emake CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" OPT_CFLAGS= DEBUG_CFLAGS= 
gimp
}

src_install() {
emake DESTDIR="${D}" install-gimp
dodoc ../README
}

pkg_postinst() {
elog "The G'MIC plugin is accessible from the menu:"
elog "Filters -> G'MIC"
}






[gentoo-commits] gentoo-x86 commit in media-plugins/gimp-gmic: ChangeLog gimp-gmic-1.6.0.3.ebuild

2015-01-07 Thread Tim Harder (radhermit)
radhermit15/01/08 04:53:37

  Modified: ChangeLog
  Added:gimp-gmic-1.6.0.3.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
4AB3E85B4F064CA3)

Revision  ChangesPath
1.50 media-plugins/gimp-gmic/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?r1=1.49&r2=1.50

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v
retrieving revision 1.49
retrieving revision 1.50
diff -u -r1.49 -r1.50
--- ChangeLog   8 Jan 2015 04:44:15 -   1.49
+++ ChangeLog   8 Jan 2015 04:53:37 -   1.50
@@ -1,6 +1,11 @@
 # ChangeLog for media-plugins/gimp-gmic
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.49 
2015/01/08 04:44:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.50 
2015/01/08 04:53:37 radhermit Exp $
+
+*gimp-gmic-1.6.0.3 (08 Jan 2015)
+
+  08 Jan 2015; Tim Harder  +gimp-gmic-1.6.0.3.ebuild:
+  Version bump.
 
   08 Jan 2015; Tim Harder  -gimp-gmic-1.5.8.6.ebuild,
   -gimp-gmic-1.5.9.1.ebuild, -gimp-gmic-1.5.9.2-r1.ebuild,



1.1  media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&content-type=text/plain

Index: gimp-gmic-1.6.0.3.ebuild
===
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild,v 1.1 
2015/01/08 04:53:37 radhermit Exp $

EAPI=5

inherit eutils toolchain-funcs flag-o-matic

DESCRIPTION="G'MIC GIMP plugin"
HOMEPAGE="http://gmic.sourceforge.net/gimp.shtml";
SRC_URI="mirror://sourceforge/gmic/gmic_${PV}.tar.gz"

LICENSE="CeCILL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="openmp"

RDEPEND="
>=media-gfx/gimp-2.4.0
media-libs/libpng:0=
sci-libs/fftw:3.0[threads]
sys-libs/zlib
"
DEPEND="${RDEPEND}"

S=${WORKDIR}/gmic-${PV}/src

pkg_pretend() {
if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible 
compiler"
fi

if ! test-flag-CXX -std=c++11 ; then
die "You need at least GCC 4.7.x or Clang >= 3.3 for 
C++11-specific compiler flags"
fi
}

src_prepare() {
cp "${FILESDIR}"/gmic-1.6.0.2-makefile.patch "${WORKDIR}" || die
edos2unix "${WORKDIR}"/gmic-1.6.0.2-makefile.patch
epatch "${WORKDIR}"/gmic-1.6.0.2-makefile.patch

if ! use openmp ; then
sed -i -r "s/^(OPENMP_(CFLAGS|LIBS) =).*/\1/" Makefile || die
fi
}

src_compile() {
emake CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" OPT_CFLAGS= DEBUG_CFLAGS= 
gimp
}

src_install() {
emake DESTDIR="${D}" install-gimp
dodoc ../README
}

pkg_postinst() {
elog "The G'MIC plugin is accessible from the menu:"
elog "Filters -> G'MIC"
}






[gentoo-commits] gentoo-x86 commit in media-plugins/gimp-gmic: ChangeLog gimp-gmic-1.6.0.3.ebuild

2015-01-07 Thread Tim Harder (radhermit)
radhermit15/01/08 04:53:37

  Modified: ChangeLog
  Added:gimp-gmic-1.6.0.3.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
4AB3E85B4F064CA3)

Revision  ChangesPath
1.50 media-plugins/gimp-gmic/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?r1=1.49&r2=1.50

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v
retrieving revision 1.49
retrieving revision 1.50
diff -u -r1.49 -r1.50
--- ChangeLog   8 Jan 2015 04:44:15 -   1.49
+++ ChangeLog   8 Jan 2015 04:53:37 -   1.50
@@ -1,6 +1,11 @@
 # ChangeLog for media-plugins/gimp-gmic
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.49 
2015/01/08 04:44:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.50 
2015/01/08 04:53:37 radhermit Exp $
+
+*gimp-gmic-1.6.0.3 (08 Jan 2015)
+
+  08 Jan 2015; Tim Harder  +gimp-gmic-1.6.0.3.ebuild:
+  Version bump.
 
   08 Jan 2015; Tim Harder  -gimp-gmic-1.5.8.6.ebuild,
   -gimp-gmic-1.5.9.1.ebuild, -gimp-gmic-1.5.9.2-r1.ebuild,



1.1  media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&content-type=text/plain

Index: gimp-gmic-1.6.0.3.ebuild
===
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild,v 1.1 
2015/01/08 04:53:37 radhermit Exp $

EAPI=5

inherit eutils toolchain-funcs flag-o-matic

DESCRIPTION="G'MIC GIMP plugin"
HOMEPAGE="http://gmic.sourceforge.net/gimp.shtml";
SRC_URI="mirror://sourceforge/gmic/gmic_${PV}.tar.gz"

LICENSE="CeCILL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="openmp"

RDEPEND="
>=media-gfx/gimp-2.4.0
media-libs/libpng:0=
sci-libs/fftw:3.0[threads]
sys-libs/zlib
"
DEPEND="${RDEPEND}"

S=${WORKDIR}/gmic-${PV}/src

pkg_pretend() {
if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible 
compiler"
fi

if ! test-flag-CXX -std=c++11 ; then
die "You need at least GCC 4.7.x or Clang >= 3.3 for 
C++11-specific compiler flags"
fi
}

src_prepare() {
cp "${FILESDIR}"/gmic-1.6.0.2-makefile.patch "${WORKDIR}" || die
edos2unix "${WORKDIR}"/gmic-1.6.0.2-makefile.patch
epatch "${WORKDIR}"/gmic-1.6.0.2-makefile.patch

if ! use openmp ; then
sed -i -r "s/^(OPENMP_(CFLAGS|LIBS) =).*/\1/" Makefile || die
fi
}

src_compile() {
emake CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" OPT_CFLAGS= DEBUG_CFLAGS= 
gimp
}

src_install() {
emake DESTDIR="${D}" install-gimp
dodoc ../README
}

pkg_postinst() {
elog "The G'MIC plugin is accessible from the menu:"
elog "Filters -> G'MIC"
}






[gentoo-commits] gentoo-x86 commit in media-plugins/gimp-gmic: ChangeLog gimp-gmic-1.6.0.3.ebuild

2015-01-07 Thread Tim Harder (radhermit)
radhermit15/01/08 04:53:37

  Modified: ChangeLog
  Added:gimp-gmic-1.6.0.3.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
4AB3E85B4F064CA3)

Revision  ChangesPath
1.50 media-plugins/gimp-gmic/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?r1=1.49&r2=1.50

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v
retrieving revision 1.49
retrieving revision 1.50
diff -u -r1.49 -r1.50
--- ChangeLog   8 Jan 2015 04:44:15 -   1.49
+++ ChangeLog   8 Jan 2015 04:53:37 -   1.50
@@ -1,6 +1,11 @@
 # ChangeLog for media-plugins/gimp-gmic
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.49 
2015/01/08 04:44:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.50 
2015/01/08 04:53:37 radhermit Exp $
+
+*gimp-gmic-1.6.0.3 (08 Jan 2015)
+
+  08 Jan 2015; Tim Harder  +gimp-gmic-1.6.0.3.ebuild:
+  Version bump.
 
   08 Jan 2015; Tim Harder  -gimp-gmic-1.5.8.6.ebuild,
   -gimp-gmic-1.5.9.1.ebuild, -gimp-gmic-1.5.9.2-r1.ebuild,



1.1  media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&content-type=text/plain

Index: gimp-gmic-1.6.0.3.ebuild
===
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild,v 1.1 
2015/01/08 04:53:37 radhermit Exp $

EAPI=5

inherit eutils toolchain-funcs flag-o-matic

DESCRIPTION="G'MIC GIMP plugin"
HOMEPAGE="http://gmic.sourceforge.net/gimp.shtml";
SRC_URI="mirror://sourceforge/gmic/gmic_${PV}.tar.gz"

LICENSE="CeCILL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="openmp"

RDEPEND="
>=media-gfx/gimp-2.4.0
media-libs/libpng:0=
sci-libs/fftw:3.0[threads]
sys-libs/zlib
"
DEPEND="${RDEPEND}"

S=${WORKDIR}/gmic-${PV}/src

pkg_pretend() {
if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible 
compiler"
fi

if ! test-flag-CXX -std=c++11 ; then
die "You need at least GCC 4.7.x or Clang >= 3.3 for 
C++11-specific compiler flags"
fi
}

src_prepare() {
cp "${FILESDIR}"/gmic-1.6.0.2-makefile.patch "${WORKDIR}" || die
edos2unix "${WORKDIR}"/gmic-1.6.0.2-makefile.patch
epatch "${WORKDIR}"/gmic-1.6.0.2-makefile.patch

if ! use openmp ; then
sed -i -r "s/^(OPENMP_(CFLAGS|LIBS) =).*/\1/" Makefile || die
fi
}

src_compile() {
emake CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" OPT_CFLAGS= DEBUG_CFLAGS= 
gimp
}

src_install() {
emake DESTDIR="${D}" install-gimp
dodoc ../README
}

pkg_postinst() {
elog "The G'MIC plugin is accessible from the menu:"
elog "Filters -> G'MIC"
}






[gentoo-commits] gentoo-x86 commit in media-plugins/gimp-gmic: ChangeLog gimp-gmic-1.6.0.3.ebuild

2015-01-07 Thread Tim Harder (radhermit)
radhermit15/01/08 04:53:37

  Modified: ChangeLog
  Added:gimp-gmic-1.6.0.3.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
4AB3E85B4F064CA3)

Revision  ChangesPath
1.50 media-plugins/gimp-gmic/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?r1=1.49&r2=1.50

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v
retrieving revision 1.49
retrieving revision 1.50
diff -u -r1.49 -r1.50
--- ChangeLog   8 Jan 2015 04:44:15 -   1.49
+++ ChangeLog   8 Jan 2015 04:53:37 -   1.50
@@ -1,6 +1,11 @@
 # ChangeLog for media-plugins/gimp-gmic
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.49 
2015/01/08 04:44:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.50 
2015/01/08 04:53:37 radhermit Exp $
+
+*gimp-gmic-1.6.0.3 (08 Jan 2015)
+
+  08 Jan 2015; Tim Harder  +gimp-gmic-1.6.0.3.ebuild:
+  Version bump.
 
   08 Jan 2015; Tim Harder  -gimp-gmic-1.5.8.6.ebuild,
   -gimp-gmic-1.5.9.1.ebuild, -gimp-gmic-1.5.9.2-r1.ebuild,



1.1  media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&content-type=text/plain

Index: gimp-gmic-1.6.0.3.ebuild
===
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild,v 1.1 
2015/01/08 04:53:37 radhermit Exp $

EAPI=5

inherit eutils toolchain-funcs flag-o-matic

DESCRIPTION="G'MIC GIMP plugin"
HOMEPAGE="http://gmic.sourceforge.net/gimp.shtml";
SRC_URI="mirror://sourceforge/gmic/gmic_${PV}.tar.gz"

LICENSE="CeCILL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="openmp"

RDEPEND="
>=media-gfx/gimp-2.4.0
media-libs/libpng:0=
sci-libs/fftw:3.0[threads]
sys-libs/zlib
"
DEPEND="${RDEPEND}"

S=${WORKDIR}/gmic-${PV}/src

pkg_pretend() {
if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible 
compiler"
fi

if ! test-flag-CXX -std=c++11 ; then
die "You need at least GCC 4.7.x or Clang >= 3.3 for 
C++11-specific compiler flags"
fi
}

src_prepare() {
cp "${FILESDIR}"/gmic-1.6.0.2-makefile.patch "${WORKDIR}" || die
edos2unix "${WORKDIR}"/gmic-1.6.0.2-makefile.patch
epatch "${WORKDIR}"/gmic-1.6.0.2-makefile.patch

if ! use openmp ; then
sed -i -r "s/^(OPENMP_(CFLAGS|LIBS) =).*/\1/" Makefile || die
fi
}

src_compile() {
emake CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" OPT_CFLAGS= DEBUG_CFLAGS= 
gimp
}

src_install() {
emake DESTDIR="${D}" install-gimp
dodoc ../README
}

pkg_postinst() {
elog "The G'MIC plugin is accessible from the menu:"
elog "Filters -> G'MIC"
}






[gentoo-commits] gentoo-x86 commit in media-plugins/gimp-gmic: ChangeLog gimp-gmic-1.6.0.3.ebuild

2015-01-07 Thread Tim Harder (radhermit)
radhermit15/01/08 04:53:37

  Modified: ChangeLog
  Added:gimp-gmic-1.6.0.3.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
4AB3E85B4F064CA3)

Revision  ChangesPath
1.50 media-plugins/gimp-gmic/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?rev=1.50&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/ChangeLog?r1=1.49&r2=1.50

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v
retrieving revision 1.49
retrieving revision 1.50
diff -u -r1.49 -r1.50
--- ChangeLog   8 Jan 2015 04:44:15 -   1.49
+++ ChangeLog   8 Jan 2015 04:53:37 -   1.50
@@ -1,6 +1,11 @@
 # ChangeLog for media-plugins/gimp-gmic
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.49 
2015/01/08 04:44:15 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/ChangeLog,v 1.50 
2015/01/08 04:53:37 radhermit Exp $
+
+*gimp-gmic-1.6.0.3 (08 Jan 2015)
+
+  08 Jan 2015; Tim Harder  +gimp-gmic-1.6.0.3.ebuild:
+  Version bump.
 
   08 Jan 2015; Tim Harder  -gimp-gmic-1.5.8.6.ebuild,
   -gimp-gmic-1.5.9.1.ebuild, -gimp-gmic-1.5.9.2-r1.ebuild,



1.1  media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild?rev=1.1&content-type=text/plain

Index: gimp-gmic-1.6.0.3.ebuild
===
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/media-plugins/gimp-gmic/gimp-gmic-1.6.0.3.ebuild,v 1.1 
2015/01/08 04:53:37 radhermit Exp $

EAPI=5

inherit eutils toolchain-funcs flag-o-matic

DESCRIPTION="G'MIC GIMP plugin"
HOMEPAGE="http://gmic.sourceforge.net/gimp.shtml";
SRC_URI="mirror://sourceforge/gmic/gmic_${PV}.tar.gz"

LICENSE="CeCILL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="openmp"

RDEPEND="
>=media-gfx/gimp-2.4.0
media-libs/libpng:0=
sci-libs/fftw:3.0[threads]
sys-libs/zlib
"
DEPEND="${RDEPEND}"

S=${WORKDIR}/gmic-${PV}/src

pkg_pretend() {
if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible 
compiler"
fi

if ! test-flag-CXX -std=c++11 ; then
die "You need at least GCC 4.7.x or Clang >= 3.3 for 
C++11-specific compiler flags"
fi
}

src_prepare() {
cp "${FILESDIR}"/gmic-1.6.0.2-makefile.patch "${WORKDIR}" || die
edos2unix "${WORKDIR}"/gmic-1.6.0.2-makefile.patch
epatch "${WORKDIR}"/gmic-1.6.0.2-makefile.patch

if ! use openmp ; then
sed -i -r "s/^(OPENMP_(CFLAGS|LIBS) =).*/\1/" Makefile || die
fi
}

src_compile() {
emake CC="$(tc-getCXX)" CFLAGS="${CXXFLAGS}" OPT_CFLAGS= DEBUG_CFLAGS= 
gimp
}

src_install() {
emake DESTDIR="${D}" install-gimp
dodoc ../README
}

pkg_postinst() {
elog "The G'MIC plugin is accessible from the menu:"
elog "Filters -> G'MIC"
}