swegener    15/02/12 18:14:32

  Modified:             ChangeLog
  Added:                pdns-recursor-3.7.1.ebuild
  Log:
  Version bump.
  
  (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 
0x64D4CF24)

Revision  Changes    Path
1.54                 net-dns/pdns-recursor/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/pdns-recursor/ChangeLog?rev=1.54&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/pdns-recursor/ChangeLog?rev=1.54&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/pdns-recursor/ChangeLog?r1=1.53&r2=1.54

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v
retrieving revision 1.53
retrieving revision 1.54
diff -u -r1.53 -r1.54
--- ChangeLog   21 Dec 2014 18:55:35 -0000      1.53
+++ ChangeLog   12 Feb 2015 18:14:32 -0000      1.54
@@ -1,6 +1,11 @@
 # ChangeLog for net-dns/pdns-recursor
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.53 
2014/12/21 18:55:35 zlogene Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.54 
2015/02/12 18:14:32 swegener Exp $
+
+*pdns-recursor-3.7.1 (12 Feb 2015)
+
+  12 Feb 2015; Sven Wegener <swege...@gentoo.org> +pdns-recursor-3.7.1.ebuild:
+  Version bump.
 
   21 Dec 2014; Mikle Kolyada <zlog...@gentoo.org> 
pdns-recursor-3.6.1-r1.ebuild:
   amd64/x86 stable wrt bug #531992



1.1                  net-dns/pdns-recursor/pdns-recursor-3.7.1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.7.1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.7.1.ebuild?rev=1.1&content-type=text/plain

Index: pdns-recursor-3.7.1.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.7.1.ebuild,v 1.1 
2015/02/12 18:14:32 swegener Exp $

EAPI="4"

inherit toolchain-funcs flag-o-matic eutils

DESCRIPTION="The PowerDNS Recursor"
HOMEPAGE="http://www.powerdns.com/";
SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="lua"

DEPEND="lua? ( >=dev-lang/lua-5.1 )"
RDEPEND="${DEPEND}
        !<net-dns/pdns-2.9.20-r1"
DEPEND="${DEPEND}
        >=dev-libs/boost-1.33.1"

pkg_setup() {
        filter-flags -ftree-vectorize
}

src_configure() {
        CC="$(tc-getCC)" \
        CXX="$(tc-getCXX)" \
        OPTFLAGS="" \
        LUA_LIBS_CONFIG="-llua" \
        LUA_CPPFLAGS_CONFIG="" \
        LUA="$(use lua && echo 1)" \
        ./configure
}

src_compile() {
        emake \
                LOCALSTATEDIR=/var/lib/powerdns \
                CC="$(tc-getCC)" \
                CXX="$(tc-getCXX)" \
                OPTFLAGS="" \
                LUA_LIBS_CONFIG="-llua" \
                LUA_CPPFLAGS_CONFIG="" \
                LUA="$(use lua && echo 1)"
}

src_install() {
        dosbin pdns_recursor rec_control
        doman pdns_recursor.1 rec_control.1

        insinto /etc/powerdns
        doins "${FILESDIR}"/recursor.conf

        doinitd "${FILESDIR}"/precursor

        # Pretty ugly, uh?
        dodir /var/lib/powerdns/var/lib
        dosym ../.. /var/lib/powerdns/var/lib/powerdns
}




Reply via email to