[gentoo-commits] gentoo-x86 commit in net-im/prosody: ChangeLog prosody-0.9.5-r2.ebuild prosody-0.9.5-r1.ebuild

2014-10-15 Thread Tobias Klausmann (klausman)
klausman14/10/15 08:07:58

  Modified: ChangeLog
  Added:prosody-0.9.5-r2.ebuild
  Removed:  prosody-0.9.5-r1.ebuild
  Log:
  Fix checkpath call to make file, not directory. Bug 525402
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key CE5D54E8)

Revision  ChangesPath
1.41 net-im/prosody/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?r1=1.40&r2=1.41

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v
retrieving revision 1.40
retrieving revision 1.41
diff -u -r1.40 -r1.41
--- ChangeLog   14 Oct 2014 10:53:36 -  1.40
+++ ChangeLog   15 Oct 2014 08:07:58 -  1.41
@@ -1,6 +1,12 @@
 # ChangeLog for net-im/prosody
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.40 2014/10/14 
10:53:36 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.41 2014/10/15 
08:07:58 klausman Exp $
+
+*prosody-0.9.5-r2 (15 Oct 2014)
+
+  15 Oct 2014; Tobias Klausmann  -prosody-0.9.5-r1.ebuild,
+  +prosody-0.9.5-r2.ebuild, -files/prosody.initd-r1, +files/prosody.initd-r2:
+  Fix checkpath call to make file, not directory. Bug 525402
 
 *prosody-0.9.5-r1 (14 Oct 2014)
 



1.1  net-im/prosody/prosody-0.9.5-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&content-type=text/plain

Index: prosody-0.9.5-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild,v 1.1 
2014/10/15 08:07:58 klausman Exp $

EAPI=5

inherit flag-o-matic multilib systemd versionator

MY_PV=$(replace_version_separator 3 '')
MY_P="${PN}-${MY_PV}"
DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP 
written in Lua"
HOMEPAGE="http://prosody.im/";
SRC_URI="http://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz";

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="ipv6 libevent mysql postgres sqlite ssl zlib jit"

DEPEND="net-im/jabber-base
!jit? ( >=dev-lang/lua-5.1 )
jit? ( dev-lang/luajit )
>=net-dns/libidn-1.1
>=dev-libs/openssl-0.9.8"
RDEPEND="${DEPEND}
>=dev-lua/luaexpat-1.3.0
dev-lua/luafilesystem
ipv6? ( >=dev-lua/luasocket-3 )
!ipv6? ( dev-lua/luasocket )
libevent? ( >=dev-lua/luaevent-0.4.3 )
mysql? ( dev-lua/luadbi[mysql] )
postgres? ( dev-lua/luadbi[postgres] )
sqlite? ( dev-lua/luadbi[sqlite] )
ssl? ( dev-lua/luasec )
zlib? ( dev-lua/lua-zlib )"

S=${WORKDIR}/${MY_P}

JABBER_ETC="/etc/jabber"
JABBER_SPOOL="/var/spool/jabber"

src_prepare() {
epatch "${FILESDIR}/${PN}-0.9.2-cfg.lua.patch"
sed -i -e "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = 
\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = 
\$(PREFIX)/$(get_libdir)/!"\
 Makefile || die
}

src_configure() {
# the configure script is handcrafted (and yells at unknown options)
# hence do not use 'econf'
append-cflags -D_GNU_SOURCE
luajit=""
if use jit; then
luajit="--runwith=luajit"
fi
./configure \
--ostype=linux $luajit \
--prefix="/usr" \
--sysconfdir="${JABBER_ETC}" \
--datadir="${JABBER_SPOOL}" \
--with-lua-include=/usr/include \
--with-lua-lib=/usr/$(get_libdir)/lua \
--cflags="${CFLAGS} -Wall -fPIC" \
--ldflags="${LDFLAGS} -shared" \
--c-compiler="$(tc-getCC)" \
--linker="$(tc-getCC)" \
--require-config || die "configure failed"
}

src_install() {
emake DESTDIR="${D}" install
systemd_dounit "${FILESDIR}/${PN}".service
systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
newinitd "${FILESDIR}/${PN}".initd-r1 $

[gentoo-commits] gentoo-x86 commit in net-im/prosody: ChangeLog prosody-0.9.5-r2.ebuild prosody-0.9.5-r1.ebuild

2014-10-15 Thread Tobias Klausmann (klausman)
klausman14/10/15 08:07:58

  Modified: ChangeLog
  Added:prosody-0.9.5-r2.ebuild
  Removed:  prosody-0.9.5-r1.ebuild
  Log:
  Fix checkpath call to make file, not directory. Bug 525402
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key CE5D54E8)

Revision  ChangesPath
1.41 net-im/prosody/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?r1=1.40&r2=1.41

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v
retrieving revision 1.40
retrieving revision 1.41
diff -u -r1.40 -r1.41
--- ChangeLog   14 Oct 2014 10:53:36 -  1.40
+++ ChangeLog   15 Oct 2014 08:07:58 -  1.41
@@ -1,6 +1,12 @@
 # ChangeLog for net-im/prosody
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.40 2014/10/14 
10:53:36 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.41 2014/10/15 
08:07:58 klausman Exp $
+
+*prosody-0.9.5-r2 (15 Oct 2014)
+
+  15 Oct 2014; Tobias Klausmann  -prosody-0.9.5-r1.ebuild,
+  +prosody-0.9.5-r2.ebuild, -files/prosody.initd-r1, +files/prosody.initd-r2:
+  Fix checkpath call to make file, not directory. Bug 525402
 
 *prosody-0.9.5-r1 (14 Oct 2014)
 



1.1  net-im/prosody/prosody-0.9.5-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&content-type=text/plain

Index: prosody-0.9.5-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild,v 1.1 
2014/10/15 08:07:58 klausman Exp $

EAPI=5

inherit flag-o-matic multilib systemd versionator

MY_PV=$(replace_version_separator 3 '')
MY_P="${PN}-${MY_PV}"
DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP 
written in Lua"
HOMEPAGE="http://prosody.im/";
SRC_URI="http://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz";

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="ipv6 libevent mysql postgres sqlite ssl zlib jit"

DEPEND="net-im/jabber-base
!jit? ( >=dev-lang/lua-5.1 )
jit? ( dev-lang/luajit )
>=net-dns/libidn-1.1
>=dev-libs/openssl-0.9.8"
RDEPEND="${DEPEND}
>=dev-lua/luaexpat-1.3.0
dev-lua/luafilesystem
ipv6? ( >=dev-lua/luasocket-3 )
!ipv6? ( dev-lua/luasocket )
libevent? ( >=dev-lua/luaevent-0.4.3 )
mysql? ( dev-lua/luadbi[mysql] )
postgres? ( dev-lua/luadbi[postgres] )
sqlite? ( dev-lua/luadbi[sqlite] )
ssl? ( dev-lua/luasec )
zlib? ( dev-lua/lua-zlib )"

S=${WORKDIR}/${MY_P}

JABBER_ETC="/etc/jabber"
JABBER_SPOOL="/var/spool/jabber"

src_prepare() {
epatch "${FILESDIR}/${PN}-0.9.2-cfg.lua.patch"
sed -i -e "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = 
\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = 
\$(PREFIX)/$(get_libdir)/!"\
 Makefile || die
}

src_configure() {
# the configure script is handcrafted (and yells at unknown options)
# hence do not use 'econf'
append-cflags -D_GNU_SOURCE
luajit=""
if use jit; then
luajit="--runwith=luajit"
fi
./configure \
--ostype=linux $luajit \
--prefix="/usr" \
--sysconfdir="${JABBER_ETC}" \
--datadir="${JABBER_SPOOL}" \
--with-lua-include=/usr/include \
--with-lua-lib=/usr/$(get_libdir)/lua \
--cflags="${CFLAGS} -Wall -fPIC" \
--ldflags="${LDFLAGS} -shared" \
--c-compiler="$(tc-getCC)" \
--linker="$(tc-getCC)" \
--require-config || die "configure failed"
}

src_install() {
emake DESTDIR="${D}" install
systemd_dounit "${FILESDIR}/${PN}".service
systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
newinitd "${FILESDIR}/${PN}".initd-r1 $

[gentoo-commits] gentoo-x86 commit in net-im/prosody: ChangeLog prosody-0.9.5-r2.ebuild prosody-0.9.5-r1.ebuild

2014-10-15 Thread Tobias Klausmann (klausman)
klausman14/10/15 08:07:58

  Modified: ChangeLog
  Added:prosody-0.9.5-r2.ebuild
  Removed:  prosody-0.9.5-r1.ebuild
  Log:
  Fix checkpath call to make file, not directory. Bug 525402
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key CE5D54E8)

Revision  ChangesPath
1.41 net-im/prosody/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?r1=1.40&r2=1.41

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v
retrieving revision 1.40
retrieving revision 1.41
diff -u -r1.40 -r1.41
--- ChangeLog   14 Oct 2014 10:53:36 -  1.40
+++ ChangeLog   15 Oct 2014 08:07:58 -  1.41
@@ -1,6 +1,12 @@
 # ChangeLog for net-im/prosody
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.40 2014/10/14 
10:53:36 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.41 2014/10/15 
08:07:58 klausman Exp $
+
+*prosody-0.9.5-r2 (15 Oct 2014)
+
+  15 Oct 2014; Tobias Klausmann  -prosody-0.9.5-r1.ebuild,
+  +prosody-0.9.5-r2.ebuild, -files/prosody.initd-r1, +files/prosody.initd-r2:
+  Fix checkpath call to make file, not directory. Bug 525402
 
 *prosody-0.9.5-r1 (14 Oct 2014)
 



1.1  net-im/prosody/prosody-0.9.5-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&content-type=text/plain

Index: prosody-0.9.5-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild,v 1.1 
2014/10/15 08:07:58 klausman Exp $

EAPI=5

inherit flag-o-matic multilib systemd versionator

MY_PV=$(replace_version_separator 3 '')
MY_P="${PN}-${MY_PV}"
DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP 
written in Lua"
HOMEPAGE="http://prosody.im/";
SRC_URI="http://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz";

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="ipv6 libevent mysql postgres sqlite ssl zlib jit"

DEPEND="net-im/jabber-base
!jit? ( >=dev-lang/lua-5.1 )
jit? ( dev-lang/luajit )
>=net-dns/libidn-1.1
>=dev-libs/openssl-0.9.8"
RDEPEND="${DEPEND}
>=dev-lua/luaexpat-1.3.0
dev-lua/luafilesystem
ipv6? ( >=dev-lua/luasocket-3 )
!ipv6? ( dev-lua/luasocket )
libevent? ( >=dev-lua/luaevent-0.4.3 )
mysql? ( dev-lua/luadbi[mysql] )
postgres? ( dev-lua/luadbi[postgres] )
sqlite? ( dev-lua/luadbi[sqlite] )
ssl? ( dev-lua/luasec )
zlib? ( dev-lua/lua-zlib )"

S=${WORKDIR}/${MY_P}

JABBER_ETC="/etc/jabber"
JABBER_SPOOL="/var/spool/jabber"

src_prepare() {
epatch "${FILESDIR}/${PN}-0.9.2-cfg.lua.patch"
sed -i -e "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = 
\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = 
\$(PREFIX)/$(get_libdir)/!"\
 Makefile || die
}

src_configure() {
# the configure script is handcrafted (and yells at unknown options)
# hence do not use 'econf'
append-cflags -D_GNU_SOURCE
luajit=""
if use jit; then
luajit="--runwith=luajit"
fi
./configure \
--ostype=linux $luajit \
--prefix="/usr" \
--sysconfdir="${JABBER_ETC}" \
--datadir="${JABBER_SPOOL}" \
--with-lua-include=/usr/include \
--with-lua-lib=/usr/$(get_libdir)/lua \
--cflags="${CFLAGS} -Wall -fPIC" \
--ldflags="${LDFLAGS} -shared" \
--c-compiler="$(tc-getCC)" \
--linker="$(tc-getCC)" \
--require-config || die "configure failed"
}

src_install() {
emake DESTDIR="${D}" install
systemd_dounit "${FILESDIR}/${PN}".service
systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
newinitd "${FILESDIR}/${PN}".initd-r1 $

[gentoo-commits] gentoo-x86 commit in net-im/prosody: ChangeLog prosody-0.9.5-r2.ebuild prosody-0.9.5-r1.ebuild

2014-10-15 Thread Tobias Klausmann (klausman)
klausman14/10/15 08:07:58

  Modified: ChangeLog
  Added:prosody-0.9.5-r2.ebuild
  Removed:  prosody-0.9.5-r1.ebuild
  Log:
  Fix checkpath call to make file, not directory. Bug 525402
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key CE5D54E8)

Revision  ChangesPath
1.41 net-im/prosody/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?r1=1.40&r2=1.41

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v
retrieving revision 1.40
retrieving revision 1.41
diff -u -r1.40 -r1.41
--- ChangeLog   14 Oct 2014 10:53:36 -  1.40
+++ ChangeLog   15 Oct 2014 08:07:58 -  1.41
@@ -1,6 +1,12 @@
 # ChangeLog for net-im/prosody
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.40 2014/10/14 
10:53:36 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.41 2014/10/15 
08:07:58 klausman Exp $
+
+*prosody-0.9.5-r2 (15 Oct 2014)
+
+  15 Oct 2014; Tobias Klausmann  -prosody-0.9.5-r1.ebuild,
+  +prosody-0.9.5-r2.ebuild, -files/prosody.initd-r1, +files/prosody.initd-r2:
+  Fix checkpath call to make file, not directory. Bug 525402
 
 *prosody-0.9.5-r1 (14 Oct 2014)
 



1.1  net-im/prosody/prosody-0.9.5-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&content-type=text/plain

Index: prosody-0.9.5-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild,v 1.1 
2014/10/15 08:07:58 klausman Exp $

EAPI=5

inherit flag-o-matic multilib systemd versionator

MY_PV=$(replace_version_separator 3 '')
MY_P="${PN}-${MY_PV}"
DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP 
written in Lua"
HOMEPAGE="http://prosody.im/";
SRC_URI="http://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz";

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="ipv6 libevent mysql postgres sqlite ssl zlib jit"

DEPEND="net-im/jabber-base
!jit? ( >=dev-lang/lua-5.1 )
jit? ( dev-lang/luajit )
>=net-dns/libidn-1.1
>=dev-libs/openssl-0.9.8"
RDEPEND="${DEPEND}
>=dev-lua/luaexpat-1.3.0
dev-lua/luafilesystem
ipv6? ( >=dev-lua/luasocket-3 )
!ipv6? ( dev-lua/luasocket )
libevent? ( >=dev-lua/luaevent-0.4.3 )
mysql? ( dev-lua/luadbi[mysql] )
postgres? ( dev-lua/luadbi[postgres] )
sqlite? ( dev-lua/luadbi[sqlite] )
ssl? ( dev-lua/luasec )
zlib? ( dev-lua/lua-zlib )"

S=${WORKDIR}/${MY_P}

JABBER_ETC="/etc/jabber"
JABBER_SPOOL="/var/spool/jabber"

src_prepare() {
epatch "${FILESDIR}/${PN}-0.9.2-cfg.lua.patch"
sed -i -e "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = 
\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = 
\$(PREFIX)/$(get_libdir)/!"\
 Makefile || die
}

src_configure() {
# the configure script is handcrafted (and yells at unknown options)
# hence do not use 'econf'
append-cflags -D_GNU_SOURCE
luajit=""
if use jit; then
luajit="--runwith=luajit"
fi
./configure \
--ostype=linux $luajit \
--prefix="/usr" \
--sysconfdir="${JABBER_ETC}" \
--datadir="${JABBER_SPOOL}" \
--with-lua-include=/usr/include \
--with-lua-lib=/usr/$(get_libdir)/lua \
--cflags="${CFLAGS} -Wall -fPIC" \
--ldflags="${LDFLAGS} -shared" \
--c-compiler="$(tc-getCC)" \
--linker="$(tc-getCC)" \
--require-config || die "configure failed"
}

src_install() {
emake DESTDIR="${D}" install
systemd_dounit "${FILESDIR}/${PN}".service
systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
newinitd "${FILESDIR}/${PN}".initd-r1 $

[gentoo-commits] gentoo-x86 commit in net-im/prosody: ChangeLog prosody-0.9.5-r2.ebuild prosody-0.9.5-r1.ebuild

2014-10-15 Thread Tobias Klausmann (klausman)
klausman14/10/15 08:07:58

  Modified: ChangeLog
  Added:prosody-0.9.5-r2.ebuild
  Removed:  prosody-0.9.5-r1.ebuild
  Log:
  Fix checkpath call to make file, not directory. Bug 525402
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key CE5D54E8)

Revision  ChangesPath
1.41 net-im/prosody/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?r1=1.40&r2=1.41

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v
retrieving revision 1.40
retrieving revision 1.41
diff -u -r1.40 -r1.41
--- ChangeLog   14 Oct 2014 10:53:36 -  1.40
+++ ChangeLog   15 Oct 2014 08:07:58 -  1.41
@@ -1,6 +1,12 @@
 # ChangeLog for net-im/prosody
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.40 2014/10/14 
10:53:36 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.41 2014/10/15 
08:07:58 klausman Exp $
+
+*prosody-0.9.5-r2 (15 Oct 2014)
+
+  15 Oct 2014; Tobias Klausmann  -prosody-0.9.5-r1.ebuild,
+  +prosody-0.9.5-r2.ebuild, -files/prosody.initd-r1, +files/prosody.initd-r2:
+  Fix checkpath call to make file, not directory. Bug 525402
 
 *prosody-0.9.5-r1 (14 Oct 2014)
 



1.1  net-im/prosody/prosody-0.9.5-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&content-type=text/plain

Index: prosody-0.9.5-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild,v 1.1 
2014/10/15 08:07:58 klausman Exp $

EAPI=5

inherit flag-o-matic multilib systemd versionator

MY_PV=$(replace_version_separator 3 '')
MY_P="${PN}-${MY_PV}"
DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP 
written in Lua"
HOMEPAGE="http://prosody.im/";
SRC_URI="http://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz";

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="ipv6 libevent mysql postgres sqlite ssl zlib jit"

DEPEND="net-im/jabber-base
!jit? ( >=dev-lang/lua-5.1 )
jit? ( dev-lang/luajit )
>=net-dns/libidn-1.1
>=dev-libs/openssl-0.9.8"
RDEPEND="${DEPEND}
>=dev-lua/luaexpat-1.3.0
dev-lua/luafilesystem
ipv6? ( >=dev-lua/luasocket-3 )
!ipv6? ( dev-lua/luasocket )
libevent? ( >=dev-lua/luaevent-0.4.3 )
mysql? ( dev-lua/luadbi[mysql] )
postgres? ( dev-lua/luadbi[postgres] )
sqlite? ( dev-lua/luadbi[sqlite] )
ssl? ( dev-lua/luasec )
zlib? ( dev-lua/lua-zlib )"

S=${WORKDIR}/${MY_P}

JABBER_ETC="/etc/jabber"
JABBER_SPOOL="/var/spool/jabber"

src_prepare() {
epatch "${FILESDIR}/${PN}-0.9.2-cfg.lua.patch"
sed -i -e "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = 
\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = 
\$(PREFIX)/$(get_libdir)/!"\
 Makefile || die
}

src_configure() {
# the configure script is handcrafted (and yells at unknown options)
# hence do not use 'econf'
append-cflags -D_GNU_SOURCE
luajit=""
if use jit; then
luajit="--runwith=luajit"
fi
./configure \
--ostype=linux $luajit \
--prefix="/usr" \
--sysconfdir="${JABBER_ETC}" \
--datadir="${JABBER_SPOOL}" \
--with-lua-include=/usr/include \
--with-lua-lib=/usr/$(get_libdir)/lua \
--cflags="${CFLAGS} -Wall -fPIC" \
--ldflags="${LDFLAGS} -shared" \
--c-compiler="$(tc-getCC)" \
--linker="$(tc-getCC)" \
--require-config || die "configure failed"
}

src_install() {
emake DESTDIR="${D}" install
systemd_dounit "${FILESDIR}/${PN}".service
systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
newinitd "${FILESDIR}/${PN}".initd-r1 $

[gentoo-commits] gentoo-x86 commit in net-im/prosody: ChangeLog prosody-0.9.5-r2.ebuild prosody-0.9.5-r1.ebuild

2014-10-15 Thread Tobias Klausmann (klausman)
klausman14/10/15 08:07:58

  Modified: ChangeLog
  Added:prosody-0.9.5-r2.ebuild
  Removed:  prosody-0.9.5-r1.ebuild
  Log:
  Fix checkpath call to make file, not directory. Bug 525402
  
  (Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with 
key CE5D54E8)

Revision  ChangesPath
1.41 net-im/prosody/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?rev=1.41&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/ChangeLog?r1=1.40&r2=1.41

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v
retrieving revision 1.40
retrieving revision 1.41
diff -u -r1.40 -r1.41
--- ChangeLog   14 Oct 2014 10:53:36 -  1.40
+++ ChangeLog   15 Oct 2014 08:07:58 -  1.41
@@ -1,6 +1,12 @@
 # ChangeLog for net-im/prosody
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.40 2014/10/14 
10:53:36 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/ChangeLog,v 1.41 2014/10/15 
08:07:58 klausman Exp $
+
+*prosody-0.9.5-r2 (15 Oct 2014)
+
+  15 Oct 2014; Tobias Klausmann  -prosody-0.9.5-r1.ebuild,
+  +prosody-0.9.5-r2.ebuild, -files/prosody.initd-r1, +files/prosody.initd-r2:
+  Fix checkpath call to make file, not directory. Bug 525402
 
 *prosody-0.9.5-r1 (14 Oct 2014)
 



1.1  net-im/prosody/prosody-0.9.5-r2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild?rev=1.1&content-type=text/plain

Index: prosody-0.9.5-r2.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-im/prosody/prosody-0.9.5-r2.ebuild,v 1.1 
2014/10/15 08:07:58 klausman Exp $

EAPI=5

inherit flag-o-matic multilib systemd versionator

MY_PV=$(replace_version_separator 3 '')
MY_P="${PN}-${MY_PV}"
DESCRIPTION="Prosody is a flexible communications server for Jabber/XMPP 
written in Lua"
HOMEPAGE="http://prosody.im/";
SRC_URI="http://prosody.im/tmp/${MY_PV}/${MY_P}.tar.gz";

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="ipv6 libevent mysql postgres sqlite ssl zlib jit"

DEPEND="net-im/jabber-base
!jit? ( >=dev-lang/lua-5.1 )
jit? ( dev-lang/luajit )
>=net-dns/libidn-1.1
>=dev-libs/openssl-0.9.8"
RDEPEND="${DEPEND}
>=dev-lua/luaexpat-1.3.0
dev-lua/luafilesystem
ipv6? ( >=dev-lua/luasocket-3 )
!ipv6? ( dev-lua/luasocket )
libevent? ( >=dev-lua/luaevent-0.4.3 )
mysql? ( dev-lua/luadbi[mysql] )
postgres? ( dev-lua/luadbi[postgres] )
sqlite? ( dev-lua/luadbi[sqlite] )
ssl? ( dev-lua/luasec )
zlib? ( dev-lua/lua-zlib )"

S=${WORKDIR}/${MY_P}

JABBER_ETC="/etc/jabber"
JABBER_SPOOL="/var/spool/jabber"

src_prepare() {
epatch "${FILESDIR}/${PN}-0.9.2-cfg.lua.patch"
sed -i -e "s!MODULES = \$(DESTDIR)\$(PREFIX)/lib/!MODULES = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!SOURCE = \$(DESTDIR)\$(PREFIX)/lib/!SOURCE = 
\$(DESTDIR)\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDSOURCE = \$(PREFIX)/lib/!INSTALLEDSOURCE = 
\$(PREFIX)/$(get_libdir)/!"\
-e "s!INSTALLEDMODULES = \$(PREFIX)/lib/!INSTALLEDMODULES = 
\$(PREFIX)/$(get_libdir)/!"\
 Makefile || die
}

src_configure() {
# the configure script is handcrafted (and yells at unknown options)
# hence do not use 'econf'
append-cflags -D_GNU_SOURCE
luajit=""
if use jit; then
luajit="--runwith=luajit"
fi
./configure \
--ostype=linux $luajit \
--prefix="/usr" \
--sysconfdir="${JABBER_ETC}" \
--datadir="${JABBER_SPOOL}" \
--with-lua-include=/usr/include \
--with-lua-lib=/usr/$(get_libdir)/lua \
--cflags="${CFLAGS} -Wall -fPIC" \
--ldflags="${LDFLAGS} -shared" \
--c-compiler="$(tc-getCC)" \
--linker="$(tc-getCC)" \
--require-config || die "configure failed"
}

src_install() {
emake DESTDIR="${D}" install
systemd_dounit "${FILESDIR}/${PN}".service
systemd_newtmpfilesd "${FILESDIR}/${PN}".tmpfilesd "${PN}".conf
newinitd "${FILESDIR}/${PN}".initd-r1 $