eras        14/07/08 07:40:03

  Modified:             ChangeLog
  Added:                libetpan-1.5.ebuild
  Log:
  Version bump - bug #510582
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
0x77F1F175586A3B1F)

Revision  Changes    Path
1.103                net-libs/libetpan/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/libetpan/ChangeLog?rev=1.103&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/libetpan/ChangeLog?rev=1.103&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/libetpan/ChangeLog?r1=1.102&r2=1.103

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v
retrieving revision 1.102
retrieving revision 1.103
diff -u -r1.102 -r1.103
--- ChangeLog   30 Apr 2013 06:38:46 -0000      1.102
+++ ChangeLog   8 Jul 2014 07:40:03 -0000       1.103
@@ -1,6 +1,11 @@
 # ChangeLog for net-libs/libetpan
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.102 
2013/04/30 06:38:46 eras Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.103 
2014/07/08 07:40:03 eras Exp $
+
+*libetpan-1.5 (08 Jul 2014)
+
+  08 Jul 2014; Eray Aslan <e...@gentoo.org> +libetpan-1.5.ebuild:
+  Version bump - bug #510582
 
   30 Apr 2013; Eray Aslan <e...@gentoo.org> libetpan-1.1.ebuild:
   Fix building with automake-1.13 - bug #467788



1.1                  net-libs/libetpan/libetpan-1.5.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/libetpan/libetpan-1.5.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-libs/libetpan/libetpan-1.5.ebuild?rev=1.1&content-type=text/plain

Index: libetpan-1.5.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-1.5.ebuild,v 1.1 
2014/07/08 07:40:03 eras Exp $

EAPI=5
inherit autotools eutils

DESCRIPTION="A portable, efficient middleware for different kinds of mail 
access."
HOMEPAGE="http://libetpan.sourceforge.net/";
SRC_URI="https://github.com/dinhviethoa/${PN}/archive/${PV}.tar.gz -> 
${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd 
~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="berkdb debug gnutls ipv6 liblockfile sasl ssl static-libs"

DEPEND="berkdb? ( sys-libs/db )
        gnutls? ( net-libs/gnutls )
        !gnutls? ( ssl? ( dev-libs/openssl ) )
        sasl? ( dev-libs/cyrus-sasl )
        liblockfile? ( net-libs/liblockfile )"
RDEPEND="${DEPEND}"

src_prepare() {
        epatch "${FILESDIR}"/${PN}-1.0-nonnull.patch

        sed -i \
                -e "s/-O2 -g//" \
                -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" \
                configure.ac

        eautoreconf
}

src_configure() {
        local sslconf

        if use ssl; then
                if use gnutls; then
                        sslconf="--with-gnutls --without-openssl"
                else
                        sslconf="--without-gnutls --with-openssl"
                fi
        else
                if use gnutls; then
                        sslconf="--with-gnutls --without-openssl"
                else
                        sslconf="--without-gnutls --without-openssl"
                fi
        fi

        # in Prefix emake uses SHELL=${BASH}, export CONFIG_SHELL to the same so
        # libtool recognises it as valid shell (bug #300211)
        use prefix && export CONFIG_SHELL=${BASH}
        # The configure script contains an error, in that it doesn't check the
        # argument of --enable-{debug,optim}, hence --disable-debug results in
        # --enable-debug=no, which isn't checked and debugging flags are blindly
        # injected.  So, avoid passing --disable-debug when we don't need it.
        econf \
                $(use debug && echo --enable-debug) \
                $(use_enable berkdb db) \
                $(use_with sasl) \
                $(use_enable ipv6) \
                $(use_enable liblockfile lockfile) \
                $(use_enable static-libs static) \
                ${sslconf}
}

src_install() {
        default
        use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
}




Reply via email to