voyageur    14/04/10 15:19:50

  Modified:             ChangeLog
  Added:                x2goclient-4.0.2.0.ebuild
  Removed:              x2goclient-4.0.1.1.ebuild x2goclient-4.0.1.2.ebuild
                        x2goclient-4.0.1.3.ebuild
  Log:
  Version bump, with official support for libssh 0.6.x, and other new features. 
Remove some 4.0.1 versions
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
C74525F2)

Revision  Changes    Path
1.29                 net-misc/x2goclient/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/x2goclient/ChangeLog?rev=1.29&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/x2goclient/ChangeLog?rev=1.29&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/x2goclient/ChangeLog?r1=1.28&r2=1.29

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v
retrieving revision 1.28
retrieving revision 1.29
diff -u -r1.28 -r1.29
--- ChangeLog   7 Apr 2014 15:25:47 -0000       1.28
+++ ChangeLog   10 Apr 2014 15:19:50 -0000      1.29
@@ -1,6 +1,14 @@
 # ChangeLog for net-misc/x2goclient
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.28 
2014/04/07 15:25:47 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/x2goclient/ChangeLog,v 1.29 
2014/04/10 15:19:50 voyageur Exp $
+
+*x2goclient-4.0.2.0 (10 Apr 2014)
+
+  10 Apr 2014; Bernard Cafarelli <voyag...@gentoo.org>
+  -x2goclient-4.0.1.1.ebuild, -x2goclient-4.0.1.2.ebuild,
+  -x2goclient-4.0.1.3.ebuild, +x2goclient-4.0.2.0.ebuild:
+  Version bump, with official support for libssh 0.6.x, and other new features.
+  Remove some 4.0.1 versions
 
 *x2goclient-4.0.1.3-r2 (07 Apr 2014)
 



1.1                  net-misc/x2goclient/x2goclient-4.0.2.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/x2goclient/x2goclient-4.0.2.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/net-misc/x2goclient/x2goclient-4.0.2.0.ebuild?rev=1.1&content-type=text/plain

Index: x2goclient-4.0.2.0.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/net-misc/x2goclient/x2goclient-4.0.2.0.ebuild,v 1.1 
2014/04/10 15:19:50 voyageur Exp $

EAPI=5
inherit eutils nsplugins qt4-r2

DESCRIPTION="The X2Go Qt client"
HOMEPAGE="http://www.x2go.org";
SRC_URI="http://code.x2go.org/releases/source/${PN}/${P}.tar.gz";

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="ldap nsplugin"

DEPEND=">=net-libs/libssh-0.6.0_rc1
        net-print/cups
        dev-qt/qtcore:4[ssl]
        dev-qt/qtgui:4
        dev-qt/qtsvg:4
        ldap? ( net-nds/openldap )"
RDEPEND="${DEPEND}
        net-misc/nx"

CLIENT_BUILD=${WORKDIR}/${P}.client_build
PLUGIN_BUILD=${WORKDIR}/${P}.plugin_build

src_prepare() {
        if ! use ldap; then
                sed -e "s/-lldap//" -i x2goclient.pro || die
                sed -e "s/#define USELDAP//" -i x2goclientconfig.h || die
        fi

        mkdir -p "${CLIENT_BUILD}"
        use nsplugin && mkdir -p "${PLUGIN_BUILD}"
}

src_configure() {
        cd "${CLIENT_BUILD}"
        eqmake4 "${S}"/x2goclient.pro

        if use nsplugin;
        then
                cd "${PLUGIN_BUILD}"
                X2GO_CLIENT_TARGET=plugin eqmake4 "${S}"/x2goclient.pro
        fi
}

src_compile() {
        cd "${CLIENT_BUILD}"
        qt4-r2_src_compile

        if use nsplugin;
        then
                cd "${PLUGIN_BUILD}"
                qt4-r2_src_compile
        fi
}

src_install() {
        dobin "${CLIENT_BUILD}"/${PN}

        insinto /usr/share/pixmaps/x2goclient
        doins -r icons/*

        domenu desktop/${PN}.desktop
        doman man/man?/*

        if use nsplugin;
        then
                # PLUGINS_DIR comes from nsplugins.eclass
                exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
                doexe "${PLUGIN_BUILD}"/libx2goplugin.so
        fi

        emake DESTDIR="${D}" PREFIX=/usr install_pluginprovider
}




Reply via email to