tomka       15/01/29 10:02:44

  Modified:             ChangeLog
  Added:                normaliz-2.12.2.ebuild
  Removed:              normaliz-2.12.1.ebuild normaliz-2.11.ebuild
  Log:
  Bump to 2.12.2, cleanup
  
  (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 
565C32BC)

Revision  Changes    Path
1.23                 sci-mathematics/normaliz/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/normaliz/ChangeLog?rev=1.23&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/normaliz/ChangeLog?rev=1.23&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/normaliz/ChangeLog?r1=1.22&r2=1.23

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v
retrieving revision 1.22
retrieving revision 1.23
diff -u -r1.22 -r1.23
--- ChangeLog   25 Oct 2014 13:23:21 -0000      1.22
+++ ChangeLog   29 Jan 2015 10:02:44 -0000      1.23
@@ -1,6 +1,13 @@
 # ChangeLog for sci-mathematics/normaliz
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.22 
2014/10/25 13:23:21 tomka Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/normaliz/ChangeLog,v 1.23 
2015/01/29 10:02:44 tomka Exp $
+
+*normaliz-2.12.2 (29 Jan 2015)
+
+  29 Jan 2015; Thomas Kahle <to...@gentoo.org> +normaliz-2.12.2.ebuild,
+  -files/normaliz-2.11-respect-flags.patch, -normaliz-2.11.ebuild,
+  -normaliz-2.12.1.ebuild:
+  Bump to 2.12.2, cleanup
 
 *normaliz-2.12.1 (25 Oct 2014)
 



1.1                  sci-mathematics/normaliz/normaliz-2.12.2.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/normaliz/normaliz-2.12.2.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sci-mathematics/normaliz/normaliz-2.12.2.ebuild?rev=1.1&content-type=text/plain

Index: normaliz-2.12.2.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sci-mathematics/normaliz/normaliz-2.12.2.ebuild,v 1.1 
2015/01/29 10:02:44 tomka Exp $

EAPI=5

inherit eutils toolchain-funcs versionator

MYPV=$(get_version_component_range 1-2)
MYP="Normaliz${MYPV}"

DESCRIPTION="Tool for computations in affine monoids and more"
HOMEPAGE="http://www.mathematik.uni-osnabrueck.de/normaliz/";
SRC_URI="http://www.mathematik.uni-osnabrueck.de/${PN}/Normaliz${PV}/Normaliz${PV}.zip";

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc extras openmp"

RDEPEND="dev-libs/gmp[cxx]"
DEPEND="${RDEPEND}
        app-arch/unzip
        dev-libs/boost"
# Only a boost header is needed -> not RDEPEND

S=${WORKDIR}/${MYP}

src_prepare () {
        epatch "${FILESDIR}/${PN}-2.12.1-respect-flags.patch"

        # Respect users AR tool (Bug 474532)
        sed -e "s:ar -cr:$(tc-getAR) -cr:" -i source/libnormaliz/Makefile || die

        if use openmp && tc-has-openmp; then
                export OPENMP=yes
        else
                export OPENMP=no
        fi
}

src_compile(){
        emake CXX="$(tc-getCXX)" OPENMP="${OPENMP}" -C source
}

src_install() {
        dobin source/normaliz
        if use doc ; then
                dodoc doc/"Normaliz.pdf"
                dodoc doc/"NmzIntegrate.pdf"
        fi
        if use extras; then
                elog "You have selected to install extras which consist of 
Macaulay2"
                elog "and Singular packages. These have been installed into "
                elog "/usr/share/${PN}, and cannot be used without additional 
setup. Please refer"
                elog "to the homepages of the respective projects for 
additional information."
                elog "Note however, Gentoo's versions of Singular and Macaulay2 
bring their own"
                elog "copies of these interface packages. Usually you don't 
need normaliz's versions."
                insinto "/usr/share/${PN}"
                doins Singular/normaliz.lib
                doins Macaulay2/Normaliz.m2
        fi
}




Reply via email to