mgorny      14/04/28 17:43:02

  Modified:             dbus-1.6.18-r1.ebuild dbus-1.8.0.ebuild ChangeLog
  Log:
  Replace multilib_build_binaries with multilib_is_native_abi, in order to put 
an end to the confusion introduced by having two functions, the proper one 
suggesting it is just for binaries.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
EFB4464E!)

Revision  Changes    Path
1.14                 sys-apps/dbus/dbus-1.6.18-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/dbus/dbus-1.6.18-r1.ebuild?rev=1.14&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/dbus/dbus-1.6.18-r1.ebuild?rev=1.14&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/dbus/dbus-1.6.18-r1.ebuild?r1=1.13&r2=1.14

Index: dbus-1.6.18-r1.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.6.18-r1.ebuild,v
retrieving revision 1.13
retrieving revision 1.14
diff -u -r1.13 -r1.14
--- dbus-1.6.18-r1.ebuild       14 Mar 2014 22:13:56 -0000      1.13
+++ dbus-1.6.18-r1.ebuild       28 Apr 2014 17:43:02 -0000      1.14
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.6.18-r1.ebuild,v 1.13 
2014/03/14 22:13:56 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.6.18-r1.ebuild,v 1.14 
2014/04/28 17:43:02 mgorny Exp $
 
 EAPI=5
 PYTHON_COMPAT=( python2_7 )
@@ -111,7 +111,7 @@
                "$(systemd_with_unitdir)"
                )
 
-       if multilib_build_binaries; then
+       if multilib_is_native_abi; then
                docconf=(
                        $(use_enable doc xml-docs) \
                        $(use_enable doc doxygen-docs)
@@ -137,7 +137,7 @@
        einfo "Running configure in ${BUILD_DIR}"
        ECONF_SOURCE="${S}" econf "${myconf[@]}" "${docconf[@]}"
 
-       if multilib_build_binaries && use test; then
+       if multilib_is_native_abi && use test; then
                mkdir "${TBD}"
                cd "${TBD}"
                einfo "Running configure in ${TBD}"
@@ -150,7 +150,7 @@
 }
 
 multilib_src_compile() {
-       if multilib_build_binaries; then
+       if multilib_is_native_abi; then
                # after the compile, it uses a selinuxfs interface to
                # check if the SELinux policy has the right support
                use selinux && addwrite /selinux/access
@@ -158,7 +158,7 @@
                einfo "Running make in ${BUILD_DIR}"
                emake
 
-               if multilib_build_binaries && use test; then
+               if multilib_is_native_abi && use test; then
                        cd "${TBD}"
                        einfo "Running make in ${TBD}"
                        emake
@@ -174,7 +174,7 @@
 }
 
 multilib_src_install() {
-       if multilib_build_binaries; then
+       if multilib_is_native_abi; then
                emake DESTDIR="${D}" install
        else
                emake DESTDIR="${D}" install-pkgconfigDATA



1.6                  sys-apps/dbus/dbus-1.8.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/dbus/dbus-1.8.0.ebuild?rev=1.6&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/dbus/dbus-1.8.0.ebuild?rev=1.6&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/dbus/dbus-1.8.0.ebuild?r1=1.5&r2=1.6

Index: dbus-1.8.0.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.8.0.ebuild,v
retrieving revision 1.5
retrieving revision 1.6
diff -u -r1.5 -r1.6
--- dbus-1.8.0.ebuild   26 Feb 2014 19:21:07 -0000      1.5
+++ dbus-1.8.0.ebuild   28 Apr 2014 17:43:02 -0000      1.6
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.8.0.ebuild,v 1.5 
2014/02/26 19:21:07 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.8.0.ebuild,v 1.6 
2014/04/28 17:43:02 mgorny Exp $
 
 EAPI=5
 PYTHON_COMPAT=( python2_7 )
@@ -107,7 +107,7 @@
                "$(systemd_with_unitdir)"
                )
 
-       if multilib_build_binaries; then
+       if multilib_is_native_abi; then
                docconf=(
                        --enable-xml-docs
                        $(use_enable doc doxygen-docs)
@@ -128,7 +128,7 @@
        einfo "Running configure in ${BUILD_DIR}"
        ECONF_SOURCE="${S}" econf "${myconf[@]}" "${docconf[@]}"
 
-       if multilib_build_binaries && use test; then
+       if multilib_is_native_abi && use test; then
                mkdir "${TBD}"
                cd "${TBD}"
                einfo "Running configure in ${TBD}"
@@ -141,7 +141,7 @@
 }
 
 multilib_src_compile() {
-       if multilib_build_binaries; then
+       if multilib_is_native_abi; then
                # after the compile, it uses a selinuxfs interface to
                # check if the SELinux policy has the right support
                use selinux && addwrite /selinux/access
@@ -149,7 +149,7 @@
                einfo "Running make in ${BUILD_DIR}"
                emake
 
-               if multilib_build_binaries && use test; then
+               if multilib_is_native_abi && use test; then
                        cd "${TBD}"
                        einfo "Running make in ${TBD}"
                        emake
@@ -165,7 +165,7 @@
 }
 
 multilib_src_install() {
-       if multilib_build_binaries; then
+       if multilib_is_native_abi; then
                emake DESTDIR="${D}" install
        else
                emake DESTDIR="${D}" install-pkgconfigDATA



1.415                sys-apps/dbus/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/dbus/ChangeLog?rev=1.415&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/dbus/ChangeLog?rev=1.415&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/dbus/ChangeLog?r1=1.414&r2=1.415

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v
retrieving revision 1.414
retrieving revision 1.415
diff -u -r1.414 -r1.415
--- ChangeLog   15 Mar 2014 08:27:43 -0000      1.414
+++ ChangeLog   28 Apr 2014 17:43:02 -0000      1.415
@@ -1,6 +1,12 @@
 # ChangeLog for sys-apps/dbus
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.414 2014/03/15 
08:27:43 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.415 2014/04/28 
17:43:02 mgorny Exp $
+
+  28 Apr 2014; Michał Górny <mgo...@gentoo.org> dbus-1.6.18-r1.ebuild,
+  dbus-1.8.0.ebuild:
+  Replace multilib_build_binaries with multilib_is_native_abi, in order to put
+  an end to the confusion introduced by having two functions, the proper one
+  suggesting it is just for binaries.
 
   15 Mar 2014; Samuli Suominen <ssuomi...@gentoo.org> -dbus-1.6.12.ebuild,
   -dbus-1.6.14.ebuild, -dbus-1.6.16.ebuild, -dbus-1.6.18.ebuild:




Reply via email to