ssuominen    14/07/11 12:28:07

  Modified:             kmod-9999.ebuild ChangeLog
  Added:                kmod-18-r1.ebuild
  Log:
  Include "keyword -lxc" in the kmod-static-nodes init script wrt #511642 by 
"Walter"
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
4868F14D)

Revision  Changes    Path
1.79                 sys-apps/kmod/kmod-9999.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild?rev=1.79&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild?rev=1.79&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild?r1=1.78&r2=1.79

Index: kmod-9999.ebuild
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v
retrieving revision 1.78
retrieving revision 1.79
diff -u -r1.78 -r1.79
--- kmod-9999.ebuild    22 Jun 2014 08:03:54 -0000      1.78
+++ kmod-9999.ebuild    11 Jul 2014 12:28:07 -0000      1.79
@@ -1,6 +1,6 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v 1.78 
2014/06/22 08:03:54 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-9999.ebuild,v 1.79 
2014/07/11 12:28:07 ssuominen Exp $
 
 EAPI=5
 
@@ -164,7 +164,7 @@
        insinto /lib/modprobe.d
        doins "${T}"/usb-load-ehci-first.conf #260139
 
-       doinitd "${FILESDIR}"/kmod-static-nodes
+       newinitd "${FILESDIR}"/kmod-static-nodes-r1 kmod-static-nodes
 }
 
 pkg_postinst() {



1.159                sys-apps/kmod/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/ChangeLog?rev=1.159&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/ChangeLog?rev=1.159&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/ChangeLog?r1=1.158&r2=1.159

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v
retrieving revision 1.158
retrieving revision 1.159
diff -u -r1.158 -r1.159
--- ChangeLog   22 Jun 2014 08:03:54 -0000      1.158
+++ ChangeLog   11 Jul 2014 12:28:07 -0000      1.159
@@ -1,6 +1,13 @@
 # ChangeLog for sys-apps/kmod
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.158 2014/06/22 
08:03:54 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/ChangeLog,v 1.159 2014/07/11 
12:28:07 ssuominen Exp $
+
+*kmod-18-r1 (11 Jul 2014)
+
+  11 Jul 2014; Samuli Suominen <ssuomi...@gentoo.org>
+  +files/kmod-static-nodes-r1, +kmod-18-r1.ebuild, kmod-9999.ebuild:
+  Include "keyword -lxc" in the kmod-static-nodes init script wrt #511642 by
+  "Walter"
 
 *kmod-18 (22 Jun 2014)
 



1.1                  sys-apps/kmod/kmod-18-r1.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-18-r1.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/kmod/kmod-18-r1.ebuild?rev=1.1&content-type=text/plain

Index: kmod-18-r1.ebuild
===================================================================
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-apps/kmod/kmod-18-r1.ebuild,v 1.1 
2014/07/11 12:28:07 ssuominen Exp $

EAPI=5

PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} )

inherit bash-completion-r1 eutils multilib python-r1

if [[ ${PV} == 9999* ]]; then
        
EGIT_REPO_URI="git://git.kernel.org/pub/scm/utils/kernel/${PN}/${PN}.git"
        inherit autotools git-2
else
        SRC_URI="mirror://kernel/linux/utils/kernel/kmod/${P}.tar.xz"
        KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 
~s390 ~sh ~sparc ~x86"
        inherit libtool
fi

DESCRIPTION="library and tools for managing linux kernel modules"
HOMEPAGE="http://git.kernel.org/?p=utils/kernel/kmod/kmod.git";

LICENSE="LGPL-2"
SLOT="0"
IUSE="debug doc lzma python static-libs +tools zlib"

# Upstream does not support running the test suite with custom configure flags.
# I was also told that the test suite is intended for kmod developers.
# So we have to restrict it.
# See bug #408915.
RESTRICT="test"

RDEPEND="!sys-apps/module-init-tools
        !sys-apps/modutils
        !<sys-apps/openrc-0.12
        lzma? ( >=app-arch/xz-utils-5.0.4-r1 )
        python? ( ${PYTHON_DEPS} )
        zlib? ( >=sys-libs/zlib-1.2.6 )" #427130
DEPEND="${RDEPEND}
        doc? ( dev-util/gtk-doc )
        lzma? ( virtual/pkgconfig )
        python? (
                dev-python/cython[${PYTHON_USEDEP}]
                virtual/pkgconfig
                )
        zlib? ( virtual/pkgconfig )"
if [[ ${PV} == 9999* ]]; then
        DEPEND="${DEPEND}
                dev-libs/libxslt"
fi

REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

DOCS="NEWS README TODO"

src_prepare() {
        if [ ! -e configure ]; then
                if use doc; then
                        gtkdocize --copy --docdir libkmod/docs || die
                else
                        touch libkmod/docs/gtk-doc.make
                fi
                eautoreconf
        else
                epatch "${FILESDIR}"/${PN}-15-dynamic-kmod.patch #493630
                elibtoolize
        fi

        # Restore possibility of running --enable-static wrt #472608
        sed -i \
                -e '/--enable-static is not supported by 
kmod/s:as_fn_error:echo:' \
                configure || die
}

src_configure() {
        local myeconfargs=(
                --bindir=/bin
                --with-rootlibdir="/$(get_libdir)"
                --enable-shared
                $(use_enable static-libs static)
                $(use_enable tools)
                $(use_enable debug)
                $(use_enable doc gtk-doc)
                $(use_with lzma xz)
                $(use_with zlib)
                --with-bashcompletiondir="$(get_bashcompdir)"
        )

        local ECONF_SOURCE="${S}"

        kmod_configure() {
                mkdir -p "${BUILD_DIR}" || die
                run_in_build_dir econf "${myeconfargs[@]}" "$@"
        }

        BUILD_DIR="${WORKDIR}/build"
        kmod_configure --disable-python

        if use python; then
                python_parallel_foreach_impl kmod_configure --enable-python
        fi
}

src_compile() {
        if [[ ${PV} != 9999* ]]; then
                # Force -j1 because of -15-dynamic-kmod.patch, likely caused by 
lack of eautoreconf
                # wrt #494806
                local MAKEOPTS="${MAKEOPTS} -j1"
        fi

        emake -C "${BUILD_DIR}"

        if use python; then
                local native_builddir=${BUILD_DIR}

                python_compile() {
                        emake -C "${BUILD_DIR}" -f Makefile -f - python \
                                VPATH="${native_builddir}:${S}" \
                                native_builddir="${native_builddir}" \
                                
libkmod_python_kmod_{kmod,list,module,_util}_la_LIBADD='$(PYTHON_LIBS) 
$(native_builddir)/libkmod/libkmod.la' \
                                <<< 'python: $(pkgpyexec_LTLIBRARIES)'
                }

                python_foreach_impl python_compile
        fi
}

src_install() {
        emake -C "${BUILD_DIR}" DESTDIR="${D}" install
        einstalldocs

        if use python; then
                local native_builddir=${BUILD_DIR}

                python_install() {
                        emake -C "${BUILD_DIR}" DESTDIR="${D}" \
                                VPATH="${native_builddir}:${S}" \
                                install-pkgpyexecLTLIBRARIES \
                                install-dist_pkgpyexecPYTHON
                }

                python_foreach_impl python_install
        fi

        prune_libtool_files --modules

        if use tools; then
                local bincmd sbincmd
                for sbincmd in depmod insmod lsmod modinfo modprobe rmmod; do
                        dosym /bin/kmod /sbin/${sbincmd}
                done

                # These are also usable as normal user
                for bincmd in lsmod modinfo; do
                        dosym kmod /bin/${bincmd}
                done
        fi

        cat <<-EOF > "${T}"/usb-load-ehci-first.conf
        softdep uhci_hcd pre: ehci_hcd
        softdep ohci_hcd pre: ehci_hcd
        EOF

        insinto /lib/modprobe.d
        doins "${T}"/usb-load-ehci-first.conf #260139

        newinitd "${FILESDIR}"/kmod-static-nodes-r1 kmod-static-nodes
}

pkg_postinst() {
        if [[ -L ${ROOT%/}/etc/runlevels/boot/static-nodes ]]; then
                ewarn "Removing old conflicting static-nodes init script from 
the boot runlevel"
                rm -f "${ROOT%/}"/etc/runlevels/boot/static-nodes
        fi

        # Add kmod to the runlevel automatically if this is the first install 
of this package.
        if [[ -z ${REPLACING_VERSIONS} ]]; then
                if [[ ! -d ${ROOT%/}/etc/runlevels/sysinit ]]; then
                        mkdir -p "${ROOT%/}"/etc/runlevels/sysinit
                fi
                if [[ -x ${ROOT%/}/etc/init.d/kmod-static-nodes ]]; then
                        ln -s /etc/init.d/kmod-static-nodes 
"${ROOT%/}"/etc/runlevels/sysinit/kmod-static-nodes
                fi
        fi

        if [[ -e ${ROOT%/}/etc/runlevels/sysinit ]]; then
                if [[ ! -e ${ROOT%/}/etc/runlevels/sysinit/kmod-static-nodes 
]]; then
                        ewarn
                        ewarn "You need to add kmod-static-nodes to the sysinit 
runlevel for"
                        ewarn "kernel modules to have required static nodes!"
                        ewarn "Run this command:"
                        ewarn "\trc-update add kmod-static-nodes sysinit"
                fi
        fi
}




Reply via email to