idella4     15/07/22 01:44:28

  Modified:             ChangeLog
  Added:                roccat-tools-3.4.0.ebuild
  Log:
  add -3.4.0 by request of proxy maintainer in bug #548388
  
  (Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 
0xB8072B0D)

Revision  Changes    Path
1.18                 sys-apps/roccat-tools/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/roccat-tools/ChangeLog?rev=1.18&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/roccat-tools/ChangeLog?rev=1.18&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/roccat-tools/ChangeLog?r1=1.17&r2=1.18

Index: ChangeLog
===================================================================
RCS file: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v
retrieving revision 1.17
retrieving revision 1.18
diff -u -r1.17 -r1.18
--- ChangeLog   21 Jul 2015 08:20:46 -0000      1.17
+++ ChangeLog   22 Jul 2015 01:44:28 -0000      1.18
@@ -1,6 +1,11 @@
 # ChangeLog for sys-apps/roccat-tools
 # Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.17 
2015/07/21 08:20:46 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/roccat-tools/ChangeLog,v 1.18 
2015/07/22 01:44:28 idella4 Exp $
+
+*roccat-tools-3.4.0 (22 Jul 2015)
+
+  22 Jul 2015; Ian Delaney <idel...@gentoo.org> +roccat-tools-3.4.0.ebuild:
+  add -3.4.0 by request of proxy maintainer in bug #548388
 
 *roccat-tools-3.5.0 (21 Jul 2015)
 *roccat-tools-3.5.0-r1 (21 Jul 2015)



1.1                  sys-apps/roccat-tools/roccat-tools-3.4.0.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/roccat-tools/roccat-tools-3.4.0.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-apps/roccat-tools/roccat-tools-3.4.0.ebuild?rev=1.1&content-type=text/plain

Index: roccat-tools-3.4.0.ebuild
===================================================================
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: 
/var/cvsroot/gentoo-x86/sys-apps/roccat-tools/roccat-tools-3.4.0.ebuild,v 1.1 
2015/07/22 01:44:28 idella4 Exp $

EAPI=5

inherit readme.gentoo cmake-utils gnome2-utils udev user

DESCRIPTION="Utility for advanced configuration of Roccat devices"

HOMEPAGE="http://roccat.sourceforge.net/";
SRC_URI="mirror://sourceforge/roccat/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE_INPUT_DEVICES="
        input_devices_roccat_arvo
        input_devices_roccat_isku
        input_devices_roccat_iskufx
        input_devices_roccat_kone
        input_devices_roccat_koneplus
        input_devices_roccat_konepure
        input_devices_roccat_konepuremilitary
        input_devices_roccat_konepureoptical
        input_devices_roccat_konextd
        input_devices_roccat_konextdoptical
        input_devices_roccat_kovaplus
        input_devices_roccat_lua
        input_devices_roccat_pyra
        input_devices_roccat_savu
        input_devices_roccat_ryosmk
        input_devices_roccat_ryostkl
        input_devices_roccat_tyon
"
IUSE="${IUSE_INPUT_DEVICES} lua"
REQUIRED_USE="
        lua? ( input_devices_roccat_ryosmk )
"

RDEPEND="
        >=dev-libs/libgaminggear-0.10
        x11-libs/gtk+:2
        x11-libs/libnotify
        media-libs/libcanberra
        virtual/libusb:1
        dev-libs/dbus-glib
        virtual/libgudev:=
        lua? ( || ( dev-lang/lua:5.1 dev-lang/lua:0 ) )
"

DEPEND="${RDEPEND}"

pkg_setup() {
        enewgroup roccat
}

src_configure() {
        local UDEVDIR="$(get_udevdir)"/rules.d
        local MODELS=${INPUT_DEVICES//roccat_/}
        mycmakeargs=(
                -DDEVICES=${MODELS// /;} \
                -DUDEVDIR="${UDEVDIR/"//"//}"
        )
        if use lua ; then
                mycmakeargs+=( -DWITH_LUA=5.1 )
        fi
        cmake-utils_src_configure
}
src_install() {
        cmake-utils_src_install
        local stat_dir=/var/lib/roccat
        keepdir $stat_dir
        fowners root:roccat $stat_dir
        fperms 2770 $stat_dir
        readme.gentoo_src_install
}
pkg_preinst() {
        gnome2_icon_savelist
}
pkg_postinst() {
        gnome2_icon_cache_update
        readme.gentoo_print_elog
        ewarn
        ewarn "Starting from version 3.0.0, executables were renamed and now 
prefixed with 'roccat',"
        ewarn "so konextdconfig is now roccatkonextdconfig and so on"
        ewarn "Everything that was ryos is now ryosmk to distinguish it from 
the ryostkl product range"
        ewarn
}

pkg_postrm() {
        gnome2_icon_cache_update
}




Reply via email to