[gentoo-commits] gentoo-x86 commit in sys-auth/sssd: sssd-1.9.6-r3.ebuild ChangeLog

2014-05-26 Thread Markos Chandras (hwoarang)
hwoarang14/05/26 18:15:55

  Modified: ChangeLog
  Added:sssd-1.9.6-r3.ebuild
  Log:
  Revbump for multiple fixes. See bug #511530, #499584 and 511528
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
09BF4F54C2BA7F3C!)

Revision  ChangesPath
1.53 sys-auth/sssd/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/ChangeLog?rev=1.53&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/ChangeLog?rev=1.53&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/ChangeLog?r1=1.52&r2=1.53

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v
retrieving revision 1.52
retrieving revision 1.53
diff -u -r1.52 -r1.53
--- ChangeLog   26 May 2014 11:21:49 -  1.52
+++ ChangeLog   26 May 2014 18:15:55 -  1.53
@@ -1,6 +1,11 @@
 # ChangeLog for sys-auth/sssd
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v 1.52 2014/05/26 
11:21:49 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v 1.53 2014/05/26 
18:15:55 hwoarang Exp $
+
+*sssd-1.9.6-r3 (26 May 2014)
+
+  26 May 2014; Markos Chandras  +sssd-1.9.6-r3.ebuild:
+  Revbump for multiple fixes. See bug #511530, #499584 and 511528
 
   26 May 2014; Markos Chandras  metadata.xml:
   Take over maintainership



1.1  sys-auth/sssd/sssd-1.9.6-r3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/sssd-1.9.6-r3.ebuild?rev=1.1&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/sssd-1.9.6-r3.ebuild?rev=1.1&content-type=text/plain

Index: sssd-1.9.6-r3.ebuild
===
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/sssd-1.9.6-r3.ebuild,v 1.1 
2014/05/26 18:15:55 hwoarang Exp $

EAPI=5

PYTHON_DEPEND="python? 2:2.6"

AUTOTOOLS_IN_SOURCE_BUILD=1
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_PRUNE_LIBTOOL_FILES=all

inherit python multilib pam linux-info autotools-utils systemd

DESCRIPTION="System Security Services Daemon provides access to identity and 
authentication"
HOMEPAGE="http://fedorahosted.org/sssd/";
SRC_URI="http://fedorahosted.org/released/${PN}/${P}.tar.gz";

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="autofs doc +locator netlink nls +manpages python selinux sudo ssh test"

COMMON_DEP="
virtual/pam
>=dev-libs/popt-1.16
dev-libs/glib:2
>=dev-libs/ding-libs-0.2
>=sys-libs/talloc-2.0.7
>=sys-libs/tdb-1.2.9
>=sys-libs/tevent-0.9.16
>=sys-libs/ldb-1.1.17-r1:=
>=net-nds/openldap-2.4.30[sasl]
>=dev-libs/libpcre-8.30
>=app-crypt/mit-krb5-1.10.3
>=sys-apps/keyutils-1.5
>=net-dns/c-ares-1.7.4
>=dev-libs/nss-3.12.9
selinux? (
>=sys-libs/libselinux-2.1.9
>=sys-libs/libsemanage-2.1
>=sec-policy/selinux-sssd-2.20120725-r9
)
>=net-dns/bind-tools-9.9[gssapi]
>=dev-libs/cyrus-sasl-2.1.25-r3[kerberos]
>=sys-apps/dbus-1.6
nls? ( >=sys-devel/gettext-0.18 )
virtual/libintl
netlink? ( dev-libs/libnl:3 )
"

RDEPEND="${COMMON_DEP}
|| ( <=sys-libs/glibc-2.16. >=sys-libs/glibc-2.17[nscd] )
"
DEPEND="${COMMON_DEP}
test? ( dev-libs/check )
manpages? (
>=dev-libs/libxslt-1.1.26
app-text/docbook-xml-dtd:4.4
)
doc? ( app-doc/doxygen )"

CONFIG_CHECK="~KEYS"

PATCHES=(
"${FILESDIR}"/${P}*.patch
)

pkg_setup(){
if use python; then
python_set_active_version 2
python_pkg_setup
python_need_rebuild
fi
linux-info_pkg_setup
}

src_prepare() {
autotools-utils_src_prepare
}

src_configure(){
local myeconfargs=(
--localstatedir="${EPREFIX}"/var
--enable-nsslibdir="${EPREFIX}"/$(get_libdir)
--with-plugin-path="${EPREFIX}"/usr/$(get_libdir)/sssd
--enable-pammoddir="${EPREFIX}"/$(getpam_mod_dir)
--with-ldb-lib-dir="${EPREFIX}"/usr/$(get_libdir)/samba/ldb
--without-nscd
--with-unicode-lib="glib2"
--disable-rpath
--enable-silent-rules
--sbindir=/usr/sbin
$(use_with selinux)
$(use_with selinux semanage)
$(use_with python python-bindings)
$(use_enable locator krb5-locator-plugin)
$(use_enable nls )
$(use_with netlink libnl)
  

[gentoo-commits] gentoo-x86 commit in sys-auth/sssd: sssd-1.9.6-r3.ebuild ChangeLog

2014-05-26 Thread Michal Gorny (mgorny)
mgorny  14/05/27 06:32:32

  Modified: sssd-1.9.6-r3.ebuild ChangeLog
  Log:
  Convert to python-single-r1.
  
  (Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 
EFB4464E!)

Revision  ChangesPath
1.2  sys-auth/sssd/sssd-1.9.6-r3.ebuild

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/sssd-1.9.6-r3.ebuild?rev=1.2&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/sssd-1.9.6-r3.ebuild?rev=1.2&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/sssd-1.9.6-r3.ebuild?r1=1.1&r2=1.2

Index: sssd-1.9.6-r3.ebuild
===
RCS file: /var/cvsroot/gentoo-x86/sys-auth/sssd/sssd-1.9.6-r3.ebuild,v
retrieving revision 1.1
retrieving revision 1.2
diff -u -r1.1 -r1.2
--- sssd-1.9.6-r3.ebuild26 May 2014 18:15:55 -  1.1
+++ sssd-1.9.6-r3.ebuild27 May 2014 06:32:32 -  1.2
@@ -1,16 +1,16 @@
 # Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/sssd-1.9.6-r3.ebuild,v 1.1 
2014/05/26 18:15:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/sssd-1.9.6-r3.ebuild,v 1.2 
2014/05/27 06:32:32 mgorny Exp $
 
 EAPI=5
 
-PYTHON_DEPEND="python? 2:2.6"
+PYTHON_COMPAT=( python2_7 )
 
 AUTOTOOLS_IN_SOURCE_BUILD=1
 AUTOTOOLS_AUTORECONF=1
 AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
 
-inherit python multilib pam linux-info autotools-utils systemd
+inherit python-single-r1 multilib pam linux-info autotools-utils systemd
 
 DESCRIPTION="System Security Services Daemon provides access to identity and 
authentication"
 HOMEPAGE="http://fedorahosted.org/sssd/";
@@ -67,11 +67,7 @@
 )
 
 pkg_setup(){
-   if use python; then
-   python_set_active_version 2
-   python_pkg_setup
-   python_need_rebuild
-   fi
+   use python && python-single-r1_pkg_setup
linux-info_pkg_setup
 }
 
@@ -110,6 +106,7 @@
 
 src_install(){
autotools-utils_src_install
+   use python && python_optimize
 
insinto /etc/sssd
insopts -m600
@@ -119,8 +116,6 @@
insopts -m644
newins "${S}"/src/examples/logrotate sssd
 
-   use python && python_clean_installation_image
-
newconfd "${FILESDIR}"/sssd.conf sssd
 
systemd_dounit "${FILESDIR}/${PN}.service"
@@ -135,12 +130,4 @@
elog "You must set up sssd.conf (default installed into /etc/sssd)"
elog "and (optionally) configuration in /etc/pam.d in order to use SSSD"
elog "features. Please see howto in 
http://fedorahosted.org/sssd/wiki/HOWTO_Configure_1_0_2";
-
-   use python && \
-   python_mod_optimize 
SSSDConfig/{ipachangeconf,sssd_upgrade_config}.py
-}
-
-pkg_postrm() {
-   use python && \
-   python_mod_cleanup 
SSSDConfig/{ipachangeconf,sssd_upgrade_config}.py
 }



1.54 sys-auth/sssd/ChangeLog

file : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/ChangeLog?rev=1.54&view=markup
plain: 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/ChangeLog?rev=1.54&content-type=text/plain
diff : 
http://sources.gentoo.org/viewvc.cgi/gentoo-x86/sys-auth/sssd/ChangeLog?r1=1.53&r2=1.54

Index: ChangeLog
===
RCS file: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v
retrieving revision 1.53
retrieving revision 1.54
diff -u -r1.53 -r1.54
--- ChangeLog   26 May 2014 18:15:55 -  1.53
+++ ChangeLog   27 May 2014 06:32:32 -  1.54
@@ -1,6 +1,9 @@
 # ChangeLog for sys-auth/sssd
 # Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v 1.53 2014/05/26 
18:15:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/sssd/ChangeLog,v 1.54 2014/05/27 
06:32:32 mgorny Exp $
+
+  27 May 2014; Michał Górny  sssd-1.9.6-r3.ebuild:
+  Convert to python-single-r1.
 
 *sssd-1.9.6-r3 (26 May 2014)