[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-office/magicpoint: ChangeLog magicpoint-1.12a.ebuild

2007-09-25 Thread Christian Faulhammer
Mike Frysinger [EMAIL PROTECTED]:

   I know the difference, but thanks.  That comment has been added
  because I tried it with emake -j1...it still failed, so I chose to
  use make. And then forgot to remove the comment.
 i dont see how (in the normal case) `emake -j1` would fail where
 `make` does not ... they expand to the same effective behavior
 `emake -j1` would generally turn into `make -j2 -j1` which has the
 same behavior as the default `make`

 To prove you wrong, I tried it again...commit is on the way.
Whatever happened the first time...

V-Li

-- 
Christian Faulhammer, Gentoo Lisp project
URL:http://www.gentoo.org/proj/en/lisp/, #gentoo-lisp on FreeNode

URL:http://www.faulhammer.org/


signature.asc
Description: PGP signature


[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-office/magicpoint: ChangeLog magicpoint-1.12a.ebuild

2007-09-24 Thread Donnie Berkholz
On 09:58 Mon 24 Sep , Christian Faulhammer (opfer) wrote:
 opfer   07/09/24 09:58:29
 
   Modified: ChangeLog
   Added:magicpoint-1.12a.ebuild
   Log:
   version bump, a lot of bugfixes; on Gentoo side we have better Emacs 
 support; in total fixing bugs 150312, 83313 and 186754
   (Portage version: 2.1.3.9)

   # no parallel make possible!
   make -j1 Makefiles || die emake failed
   make clean || die emake clean failed
   make BINDIR=/usr/bin LIBDIR=/etc/X11 || die emake failed
   use emacs  cp contrib/*.el ${S}  \
   elisp-compile *.el || die elisp-compile failed
 }
 
 src_install() {
   make \
   DESTDIR=${D} \
   BINDIR=/usr/bin \
   LIBDIR=/etc/X11 \
   install || die make install
 
   make \
   DESTDIR=${D} \
   DOCHTMLDIR=/usr/share/doc/${PF} \
   MANPATH=/usr/share/man \
   MANSUFFIX=1 \
   install.man || die emake install.man failed

Why not emake for all of these?

Thanks,
Donnie
-- 
[EMAIL PROTECTED] mailing list



[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-office/magicpoint: ChangeLog magicpoint-1.12a.ebuild

2007-09-24 Thread Christian Faulhammer
Donnie Berkholz [EMAIL PROTECTED]:

 On 09:58 Mon 24 Sep , Christian Faulhammer (opfer) wrote:
  opfer   07/09/24 09:58:29
  
Modified: ChangeLog
Added:magicpoint-1.12a.ebuild
Log:
version bump, a lot of bugfixes; on Gentoo side we have better
  Emacs support; in total fixing bugs 150312, 83313 and 186754
  (Portage version: 2.1.3.9)
 
  # no parallel make possible!
  make -j1 Makefiles || die emake failed
  make clean || die emake clean failed
  make BINDIR=/usr/bin LIBDIR=/etc/X11 || die emake failed
[...]
  make \
[...]
  make \
[...]
 Why not emake for all of these?

 Because it fails, magicpoint's build system is really old and weird.
The comment above should state that, but the leftover -j1 I tried would
confuse the reader.  Plus the stupid die comments.

V-Li
 
-- 
Christian Faulhammer, Gentoo Lisp project
URL:http://www.gentoo.org/proj/en/lisp/, #gentoo-lisp on FreeNode

URL:http://www.faulhammer.org/


signature.asc
Description: PGP signature


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-office/magicpoint: ChangeLog magicpoint-1.12a.ebuild

2007-09-24 Thread Mike Frysinger
On Monday 24 September 2007, Christian Faulhammer wrote:
 Donnie Berkholz [EMAIL PROTECTED]:
  On 09:58 Mon 24 Sep , Christian Faulhammer (opfer) wrote:
   opfer   07/09/24 09:58:29
  
 Modified: ChangeLog
 Added:magicpoint-1.12a.ebuild
 Log:
 version bump, a lot of bugfixes; on Gentoo side we have better
   Emacs support; in total fixing bugs 150312, 83313 and 186754
   (Portage version: 2.1.3.9)
  
 # no parallel make possible!
 make -j1 Makefiles || die emake failed
 make clean || die emake clean failed
 make BINDIR=/usr/bin LIBDIR=/etc/X11 || die emake failed

 [...]

 make \

 [...]

 make \

 [...]

  Why not emake for all of these?

  Because it fails, magicpoint's build system is really old and weird.
 The comment above should state that, but the leftover -j1 I tried would
 confuse the reader.  Plus the stupid die comments.

most people associate emake with run in parallel when in reality, that is 
merely one of the things it provides

if something doesnt work in parallel, you use `emake -j1` ... using `make` 
generally doesnt make sense anywhere
-mike


signature.asc
Description: This is a digitally signed message part.


[gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-office/magicpoint: ChangeLog magicpoint-1.12a.ebuild

2007-09-24 Thread Christian Faulhammer
Mike Frysinger [EMAIL PROTECTED]:

   Because it fails, magicpoint's build system is really old and
  weird. The comment above should state that, but the leftover -j1 I
  tried would confuse the reader.  Plus the stupid die comments.
 most people associate emake with run in parallel when in reality,
 that is merely one of the things it provides
 if something doesnt work in parallel, you use `emake -j1` ... using
 `make` generally doesnt make sense anywhere

 I know the difference, but thanks.  That comment has been added because
I tried it with emake -j1...it still failed, so I chose to use make.
And then forgot to remove the comment.

V-Li

-- 
Christian Faulhammer, Gentoo Lisp project
URL:http://www.gentoo.org/proj/en/lisp/, #gentoo-lisp on FreeNode

URL:http://www.faulhammer.org/


signature.asc
Description: PGP signature


Re: [gentoo-dev] Re: [gentoo-commits] gentoo-x86 commit in app-office/magicpoint: ChangeLog magicpoint-1.12a.ebuild

2007-09-24 Thread Mike Frysinger
On Monday 24 September 2007, Christian Faulhammer wrote:
 Mike Frysinger [EMAIL PROTECTED]:
Because it fails, magicpoint's build system is really old and
   weird. The comment above should state that, but the leftover -j1 I
   tried would confuse the reader.  Plus the stupid die comments.
 
  most people associate emake with run in parallel when in reality,
  that is merely one of the things it provides
  if something doesnt work in parallel, you use `emake -j1` ... using
  `make` generally doesnt make sense anywhere

  I know the difference, but thanks.  That comment has been added because
 I tried it with emake -j1...it still failed, so I chose to use make.
 And then forgot to remove the comment.

i dont see how (in the normal case) `emake -j1` would fail where `make` does 
not ... they expand to the same effective behavior

`emake -j1` would generally turn into `make -j2 -j1` which has the same 
behavior as the default `make`
-mike


signature.asc
Description: This is a digitally signed message part.