Re: [geos-devel] getCoordinateDimension() - ticket 311

2010-05-26 Thread Mateusz Loskot

On 26/05/10 02:27, Frank Warmerdam wrote:

Martin Davis wrote:

Maybe strk is right, and this should be changed to an enum. Perhaps
the enum could be defined as

XY = 2
XYZ = 3
XYZM = 4
XYM = 5 ?

Or perhaps there is already a convention covering this?


My personal opinion is that the interpretation of the coordinate
dimensions should not be directly mixed into getting the number
of coordinate dimensions. But I could be wrong headed on this.



I second Frank's your opinion here.

Best regards,
--
Mateusz Loskot, http://mateusz.loskot.net
___
geos-devel mailing list
geos-devel@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/geos-devel


Re: [geos-devel] WKT / WKB Writer Output Dimension

2010-05-26 Thread strk
On Wed, May 26, 2010 at 12:41:53AM -0400, Frank Warmerdam wrote:

 Note that I'll default to writing the new syntax.  I'm not sure if I
 will support writing the old syntax or not via a flag.

If current WKTWriter didn't output old syntax it makes perfectly
sense to start the support with new syntax.
Keep up the good work !

--strk; 

  ()   Free GIS  Flash consultant/developer
  /\   http://strk.keybit.net/services.html
___
geos-devel mailing list
geos-devel@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/geos-devel


Re: [geos-devel] getCoordinateDimension() - ticket 311

2010-05-26 Thread strk
On Tue, May 25, 2010 at 09:27:16PM -0400, Frank Warmerdam wrote:

 I think we will have to change the values returned by the C API getDimension
 function to match C++ even though this introduces a modest risk of problems
 for applications using the undocumented current behavior.

What's the problem with deprecating it and use a new, more explicit name ?

 GEOSGeom_getSpatialDimension() maybe ?

Note that there are other functions which I think should be deprecated
so getDimension won't feel alone (the setOrdinate/getOrdinate ones
in particular, as they use 1-based index and in an undocumented way).

--strk; 

  ()   Free GIS  Flash consultant/developer
  /\   http://strk.keybit.net/services.html
___
geos-devel mailing list
geos-devel@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/geos-devel


Re: [geos-devel] getCoordinateDimension() - ticket 311

2010-05-26 Thread Martin Davis
getDimension follows the OGC spec.  Seems to me it's better to simply 
change it to match the spec and the C++ API.  This was clearly a bug in 
the first place, no?


strk wrote:

On Tue, May 25, 2010 at 09:27:16PM -0400, Frank Warmerdam wrote:

  

I think we will have to change the values returned by the C API getDimension
function to match C++ even though this introduces a modest risk of problems
for applications using the undocumented current behavior.



What's the problem with deprecating it and use a new, more explicit name ?

 GEOSGeom_getSpatialDimension() maybe ?

Note that there are other functions which I think should be deprecated
so getDimension won't feel alone (the setOrdinate/getOrdinate ones
in particular, as they use 1-based index and in an undocumented way).

--strk; 


  ()   Free GIS  Flash consultant/developer
  /\   http://strk.keybit.net/services.html
___
geos-devel mailing list
geos-devel@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/geos-devel

  


--
Martin Davis
Senior Technical Architect
Refractions Research, Inc.
(250) 383-3022

___
geos-devel mailing list
geos-devel@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/geos-devel


Re: [geos-devel] getCoordinateDimension() - ticket 311

2010-05-26 Thread Martin Davis
I have to disagree.  Mathematically speaking the topological dimension 
is a counting number (e.g. in the set {0,1,2,...}.  I don't see any 
reason why this shouldn't be represented as an integer value (and plenty 
of reasons why it should - e.g. ordering, comparison, etc)


strk wrote:

On Tue, May 25, 2010 at 01:56:25PM -0700, Martin Davis wrote:

  
Maybe strk is right, and this should be changed to an enum. Perhaps the 
enum could be defined as


XY = 2
XYZ = 3
XYZM = 4
XYM = 5 ?



My enum suggestion was for the spatial dimension, not coordinate dimension.
PUNTUAL/LINEAL/AREAL kind of enum.

--strk; 


  ()   Free GIS  Flash consultant/developer
  /\   http://strk.keybit.net/services.html
___
geos-devel mailing list
geos-devel@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/geos-devel

  


--
Martin Davis
Senior Technical Architect
Refractions Research, Inc.
(250) 383-3022

___
geos-devel mailing list
geos-devel@lists.osgeo.org
http://lists.osgeo.org/mailman/listinfo/geos-devel