Re: [PATCH][GSoC] revision: forbid --graph and --no-walk usage

2015-03-06 Thread Akshay Aurora
Thanks for replying. I'll try sending the patch directly using gmail
smtp servers next time.

Going by the description of the options. I doubt --graph and --no-walk
would ever make sense together.
So my patch forbids these two options together for all commands
calling setup_revisions(). And isn't specific to just `git log`.

Also, seeing other patches to this microproject. I think I should also
update Documentation for rev-list-options.

Do you think we need a test for this? Would a test using only `git
log` be suffice?

On Fri, Mar 6, 2015 at 2:07 PM, Max Kirillov m...@max630.net wrote:
 On Fri, Mar 6, 2015 at 7:08 AM, Akshay Aurora akshayaur...@yahoo.com wrote:
 Not sure, why this mail is not showing on Gmane.
 I used git to send the email, and tested it by sending the patch to
 myself before sending it to the list.

 Gmail knows: Why is this message in Spam? It has a from address in
 yahoo.com but has failed yahoo.com's required tests for
 authentication.  Learn more Probably filtering settings are less
 strict.

 I guess you should use authenticated SMTP thought your email hoster,
 yahoo here in git-send-email (something like --smtp-server and
 --smtp-user options, it will ask for password interactively) to avoid
 it.



-- 
AA
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [GSoC microproject help] Allow - as a short-hand for @{-1} in more places

2015-03-06 Thread Akshay Aurora
Hi Sundararajan,

Welcome to Git Community.

You need to look for commands dealing with branches, and allow  '-' as
shorthand for @{-1}.

You can look at patches already sent for this microproject. One of the
students has already started working on git reset command [0].

Junio, has raised some key issues you'll need to tackle on that
thread. Hopefully it should get you started.

Make sure the existing tests pass after making changes. You might also
need to add a new test case for your microproject.

[0] - http://thread.gmane.org/gmane.comp.version-control.git/264688

On Sat, Mar 7, 2015 at 1:35 AM, Sundararajan R dyou...@gmail.com wrote:
 Hi All,

 I am a sophomore at Indian Institute of Technology Kanpur and am a GSoC
 aspirant for git. Although I have been using git from a long time, this is
 the first occasion when I have picked up reading its source code. Can
 somebody please help me by telling me how to start off with the above
 mentioned microproject?

 Thank you very much.

 --
 To unsubscribe from this list: send the line unsubscribe git in
 the body of a message to majord...@vger.kernel.org
 More majordomo info at  http://vger.kernel.org/majordomo-info.html



-- 
AA
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH][GSoC] revision: forbid --graph and --no-walk usage

2015-03-06 Thread Akshay Aurora
Thanks Junio. Working on v2 for this patch.

On Sat, Mar 7, 2015 at 12:00 AM, Junio C Hamano gits...@pobox.com wrote:
 Akshay Aurora akshayaur...@yahoo.com writes:

 Signed-off-by: Akshay Aurora akshayaur...@yahoo.com
 ---
 This is my first patch for a GSoC Microproject, would be great to have your 
 feedback.

  revision.c | 3 ++-
  1 file changed, 2 insertions(+), 1 deletion(-)

 diff --git a/revision.c b/revision.c
 index bd027bc..d578652 100644
 --- a/revision.c
 +++ b/revision.c
 @@ -2248,7 +2248,8 @@ int setup_revisions(int argc, const char **argv, 
 struct rev_info *revs, struct s
*/
   if (revs-reverse  revs-graph)
   die(cannot combine --reverse with --graph);
 -
 + if (revs-no_walk  revs-graph)
 + die(cannot combine --no-walk with --graph);
   if (revs-reflog_info  revs-graph)
   die(cannot combine --walk-reflogs with --graph);
   if (!revs-reflog_info  revs-grep_filter.use_reflog_filter)

 Needs a new test to make sure log --no-walk --graph is rejected,
 and also you need to make sure all other existing tests that used to
 pass before this change still pass.




-- 
- Akshay Aurora
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH][GSoC] revision: forbid --graph and --no-walk usage

2015-03-05 Thread Akshay Aurora
Not sure, why this mail is not showing on Gmane.

I used git to send the email, and tested it by sending the patch to
myself before sending it to the list.

On Fri, Mar 6, 2015 at 12:40 AM, Akshay Aurora akshayaur...@yahoo.com wrote:
 Signed-off-by: Akshay Aurora akshayaur...@yahoo.com
 ---
 This is my first patch for a GSoC Microproject, would be great to have your 
 feedback.

  revision.c | 3 ++-
  1 file changed, 2 insertions(+), 1 deletion(-)

 diff --git a/revision.c b/revision.c
 index bd027bc..d578652 100644
 --- a/revision.c
 +++ b/revision.c
 @@ -2248,7 +2248,8 @@ int setup_revisions(int argc, const char **argv, struct 
 rev_info *revs, struct s
  */
 if (revs-reverse  revs-graph)
 die(cannot combine --reverse with --graph);
 -
 +   if (revs-no_walk  revs-graph)
 +   die(cannot combine --no-walk with --graph);
 if (revs-reflog_info  revs-graph)
 die(cannot combine --walk-reflogs with --graph);
 if (!revs-reflog_info  revs-grep_filter.use_reflog_filter)
 --
 2.3.1




-- 
AA
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[PATCH][GSoC] revision: forbid --graph and --no-walk usage

2015-03-05 Thread Akshay Aurora
Signed-off-by: Akshay Aurora akshayaur...@yahoo.com
---
This is my first patch for a GSoC Microproject, would be great to have your 
feedback.

 revision.c | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/revision.c b/revision.c
index bd027bc..d578652 100644
--- a/revision.c
+++ b/revision.c
@@ -2248,7 +2248,8 @@ int setup_revisions(int argc, const char **argv, struct 
rev_info *revs, struct s
 */
if (revs-reverse  revs-graph)
die(cannot combine --reverse with --graph);
-
+   if (revs-no_walk  revs-graph)
+   die(cannot combine --no-walk with --graph);
if (revs-reflog_info  revs-graph)
die(cannot combine --walk-reflogs with --graph);
if (!revs-reflog_info  revs-grep_filter.use_reflog_filter)
-- 
2.3.1

--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH] Rewrite diff-no-index.c:read_directory() to use is_dot_or_dotdot() and rename it to read_dir()

2014-03-15 Thread Akshay Aurora
Forgot to mention, this is one of the microprojects for GSoC this
year. Would be great to have some feedback.

On Fri, Mar 14, 2014 at 6:09 PM, Akshay Aurora akshayaur...@yahoo.com wrote:
 I have renamed diff-no-index.c:read_directory() to read_dir() to avoid name 
 collision with dir.c:read_directory()

 Signed-off-by: Akshay Aurora akshayaur...@yahoo.com
 ---
  diff-no-index.c | 9 +
  1 file changed, 5 insertions(+), 4 deletions(-)

 diff --git a/diff-no-index.c b/diff-no-index.c
 index 8e10bff..2a17c9f 100644
 --- a/diff-no-index.c
 +++ b/diff-no-index.c
 @@ -10,13 +10,14 @@
  #include blob.h
  #include tag.h
  #include diff.h
 +#include dir.h
  #include diffcore.h
  #include revision.h
  #include log-tree.h
  #include builtin.h
  #include string-list.h

 -static int read_directory(const char *path, struct string_list *list)
 +static int read_dir(const char *path, struct string_list *list)
  {
 DIR *dir;
 struct dirent *e;
 @@ -25,7 +26,7 @@ static int read_directory(const char *path, struct 
 string_list *list)
 return error(Could not open directory %s, path);

 while ((e = readdir(dir)))
 -   if (strcmp(., e-d_name)  strcmp(.., e-d_name))
 +   if (!is_dot_or_dotdot(e-d_name))
 string_list_insert(list, e-d_name);

 closedir(dir);
 @@ -107,9 +108,9 @@ static int queue_diff(struct diff_options *o,
 int i1, i2, ret = 0;
 size_t len1 = 0, len2 = 0;

 -   if (name1  read_directory(name1, p1))
 +   if (name1  read_dir(name1, p1))
 return -1;
 -   if (name2  read_directory(name2, p2)) {
 +   if (name2  read_dir(name2, p2)) {
 string_list_clear(p1, 0);
 return -1;
 }
 --
 1.8.5.3




-- 
With Thanks  Warm Regards
Akshay Aurora
iakshay.net
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html