[PATCH 00/16] Convert parts of refs.c to struct object_id

2015-03-20 Thread brian m. carlson
This is part 1 of n in converting code to use struct object_id.

refs.c, and the for_each_ref series of functions particularly, is the
source for many instances of object IDs in the codebase.  Therefore, it
makes sense to convert this series of functions to provide a basis for
further conversions.

This series is essentially just for_each_ref and friends, the callbacks,
and callers.  Other parts of refs.c will be converted in a later series,
so as to keep the number of patches to a reasonable size.

There should be no functional change from this patch series.

This series is based on top of the bc/object-id series in pu.  The
series will be rebased on next once bc/object-id makes it into next.

Available from the following repositories in either object-id-part1 or
object-id-part1-pu (will be rebased):

  https://github.com/bk2204/git.git
  https://git.crustytoothpaste.net/git/bmc/git.git

brian m. carlson (16):
  refs: convert struct ref_entry to use struct object_id
  refs: convert for_each_tag_ref to struct object_id
  refs: convert remaining users of for_each_ref_in to object_id
  refs: convert for_each_ref_in_submodule to object_id
  refs: convert head_ref to struct object_id
  refs: convert for_each_ref_submodule to struct object_id
  revision: remove unused _oid helper.
  refs: convert for_each_ref to struct object_id
  refs: convert for_each_replace_ref to struct object_id
  refs: convert namespaced ref iteration functions to object_id
  refs: convert for_each_rawref to struct object_id.
  refs: rename do_for_each_ref_oid to do_for_each_ref
  refs: convert for_each_reflog to struct object_id
  refs: rename each_ref_fn_oid to each_ref_fn
  Remove unneeded *_oid functions.
  refs: convert struct ref_lock to struct object_id

 Documentation/technical/api-ref-iteration.txt |   2 +-
 bisect.c  |   8 +-
 builtin/branch.c  |   4 +-
 builtin/checkout.c|   4 +-
 builtin/describe.c|  12 +--
 builtin/fetch.c   |   6 +-
 builtin/for-each-ref.c|   4 +-
 builtin/fsck.c|  18 ++---
 builtin/name-rev.c|   6 +-
 builtin/pack-objects.c|  14 ++--
 builtin/receive-pack.c|   4 +-
 builtin/reflog.c  |   8 +-
 builtin/remote.c  |  14 ++--
 builtin/replace.c |  14 ++--
 builtin/rev-parse.c   |   8 +-
 builtin/show-branch.c |  24 +++---
 builtin/show-ref.c|  16 ++--
 builtin/tag.c |   8 +-
 fetch-pack.c  |  18 -
 help.c|   2 +-
 http-backend.c|  14 ++--
 log-tree.c|  10 +--
 notes.c   |   2 +-
 reachable.c   |   4 +-
 refs.c| 104 +-
 refs.h|   6 +-
 remote.c  |   8 +-
 replace_object.c  |   4 +-
 revision.c|  18 +++--
 server-info.c |   6 +-
 sha1_name.c   |   4 +-
 shallow.c |   8 +-
 submodule.c   |   6 +-
 transport.c   |  10 +--
 upload-pack.c |  28 +++
 walker.c  |   4 +-
 36 files changed, 224 insertions(+), 206 deletions(-)

-- 
2.2.1.209.g41e5f3a

--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 00/16] Convert parts of refs.c to struct object_id

2015-03-20 Thread Junio C Hamano
brian m. carlson sand...@crustytoothpaste.net writes:

 This is part 1 of n in converting code to use struct object_id.

OK --- 'n' up there looked funny ;-)

I'd like to see the series reviewed by those who recently worked
heavily on the subsystem involved (namely, refs API); please do not
forget to include area experts to Cc the next time around when you
update the other areas with the same theme.  On the other hand, once
the struct object_id design is settled and everybody agrees that
it is good enough, those who were involved in the review of that
framework do not necessarily have to be on the Cc list (of course
they are welcome to participate).  But reviews by area experts are
more important to avoid breaking the users in the individual areas
that are now going to use the new object-id infrastructure.

Thanks.
--
To unsubscribe from this list: send the line unsubscribe git in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 00/16] Convert parts of refs.c to struct object_id

2015-03-20 Thread brian m. carlson
On Fri, Mar 20, 2015 at 12:52:20PM -0700, Junio C Hamano wrote:
 brian m. carlson sand...@crustytoothpaste.net writes:
 
  This is part 1 of n in converting code to use struct object_id.
 
 OK --- 'n' up there looked funny ;-)

It is, unfortunately, a large task.  I wish I could quantify it better
than N, but I expect it will be a progressive task stretching out over
several versions.

 I'd like to see the series reviewed by those who recently worked
 heavily on the subsystem involved (namely, refs API); please do not
 forget to include area experts to Cc the next time around when you
 update the other areas with the same theme.  On the other hand, once
 the struct object_id design is settled and everybody agrees that
 it is good enough, those who were involved in the review of that
 framework do not necessarily have to be on the Cc list (of course
 they are welcome to participate).  But reviews by area experts are
 more important to avoid breaking the users in the individual areas
 that are now going to use the new object-id infrastructure.

Okay, I'll do that next time around.  I expect to do at least one
reroll, so I'll CC them with the next iteration if they don't pipe up at
first.
-- 
brian m. carlson / brian with sandals: Houston, Texas, US
+1 832 623 2791 | http://www.crustytoothpaste.net/~bmc | My opinion only
OpenPGP: RSA v4 4096b: 88AC E9B2 9196 305B A994 7552 F1BA 225C 0223 B187


signature.asc
Description: Digital signature