[PATCH 1/3] Make read_index_data() public

2013-04-12 Thread Lukas Fleischer
This allows for reusing the function in convert.c later.

Also, move it from attr.c to read-cache.c and add a use_index parameter
to specify a custom index_state since we are no longer enable to access
the static use_index variable from attr.c.

Signed-off-by: Lukas Fleischer 
---
I am not totally sure whether read-cache.c is the best place for this...

 attr.c   | 35 +--
 cache.h  |  1 +
 read-cache.c | 33 +
 3 files changed, 35 insertions(+), 34 deletions(-)

diff --git a/attr.c b/attr.c
index 689bc2a..2e1ce7b 100644
--- a/attr.c
+++ b/attr.c
@@ -381,46 +381,13 @@ static struct attr_stack *read_attr_from_file(const char 
*path, int macro_ok)
return res;
 }
 
-static void *read_index_data(const char *path)
-{
-   int pos, len;
-   unsigned long sz;
-   enum object_type type;
-   void *data;
-   struct index_state *istate = use_index ? use_index : &the_index;
-
-   len = strlen(path);
-   pos = index_name_pos(istate, path, len);
-   if (pos < 0) {
-   /*
-* We might be in the middle of a merge, in which
-* case we would read stage #2 (ours).
-*/
-   int i;
-   for (i = -pos - 1;
-(pos < 0 && i < istate->cache_nr &&
- !strcmp(istate->cache[i]->name, path));
-i++)
-   if (ce_stage(istate->cache[i]) == 2)
-   pos = i;
-   }
-   if (pos < 0)
-   return NULL;
-   data = read_sha1_file(istate->cache[pos]->sha1, &type, &sz);
-   if (!data || type != OBJ_BLOB) {
-   free(data);
-   return NULL;
-   }
-   return data;
-}
-
 static struct attr_stack *read_attr_from_index(const char *path, int macro_ok)
 {
struct attr_stack *res;
char *buf, *sp;
int lineno = 0;
 
-   buf = read_index_data(path);
+   buf = read_index_data(path, use_index);
if (!buf)
return NULL;
 
diff --git a/cache.h b/cache.h
index ba5a47c..a71e443 100644
--- a/cache.h
+++ b/cache.h
@@ -471,6 +471,7 @@ extern int add_file_to_index(struct index_state *, const 
char *path, int flags);
 extern struct cache_entry *make_cache_entry(unsigned int mode, const unsigned 
char *sha1, const char *path, int stage, int refresh);
 extern int ce_same_name(struct cache_entry *a, struct cache_entry *b);
 extern int index_name_is_other(const struct index_state *, const char *, int);
+extern void *read_index_data(const char *path, struct index_state *use_index);
 
 /* do stat comparison even if CE_VALID is true */
 #define CE_MATCH_IGNORE_VALID  01
diff --git a/read-cache.c b/read-cache.c
index 5a9704f..39e3424 100644
--- a/read-cache.c
+++ b/read-cache.c
@@ -1899,3 +1899,36 @@ int index_name_is_other(const struct index_state 
*istate, const char *name,
}
return 1;
 }
+
+void *read_index_data(const char *path, struct index_state *use_index)
+{
+   int pos, len;
+   unsigned long sz;
+   enum object_type type;
+   void *data;
+   struct index_state *istate = use_index ? use_index : &the_index;
+
+   len = strlen(path);
+   pos = index_name_pos(istate, path, len);
+   if (pos < 0) {
+   /*
+* We might be in the middle of a merge, in which
+* case we would read stage #2 (ours).
+*/
+   int i;
+   for (i = -pos - 1;
+(pos < 0 && i < istate->cache_nr &&
+ !strcmp(istate->cache[i]->name, path));
+i++)
+   if (ce_stage(istate->cache[i]) == 2)
+   pos = i;
+   }
+   if (pos < 0)
+   return NULL;
+   data = read_sha1_file(istate->cache[pos]->sha1, &type, &sz);
+   if (!data || type != OBJ_BLOB) {
+   free(data);
+   return NULL;
+   }
+   return data;
+}
-- 
1.8.2.675.gda3bb24.dirty

--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 1/3] Make read_index_data() public

2013-04-12 Thread Jeff King
On Fri, Apr 12, 2013 at 07:26:11PM +0200, Lukas Fleischer wrote:

> This allows for reusing the function in convert.c later.
> 
> Also, move it from attr.c to read-cache.c and add a use_index parameter
> to specify a custom index_state since we are no longer enable to access
> the static use_index variable from attr.c.

I'm all for removing duplicated code, but, but I think the name
"read_index_data" is a bit misleading for a global function. I would
expect it to read data from the index (and the argument "path" does not
help clarify that at all).

Can we rename it read_blob_data_from_index_path() or something?

-Peff
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: [PATCH 1/3] Make read_index_data() public

2013-04-13 Thread Lukas Fleischer
On Fri, Apr 12, 2013 at 03:40:12PM -0400, Jeff King wrote:
> On Fri, Apr 12, 2013 at 07:26:11PM +0200, Lukas Fleischer wrote:
> 
> > This allows for reusing the function in convert.c later.
> > 
> > Also, move it from attr.c to read-cache.c and add a use_index parameter
> > to specify a custom index_state since we are no longer enable to access
> > the static use_index variable from attr.c.
> 
> I'm all for removing duplicated code, but, but I think the name
> "read_index_data" is a bit misleading for a global function. I would
> expect it to read data from the index (and the argument "path" does not
> help clarify that at all).
> 
> Can we rename it read_blob_data_from_index_path() or something?

Pretty long function name... I agree that it is better to have a verbose
function name instead of something short that gives a wrong impression
of what the function does and I can't think of a shorter, yet
descriptive way to name the function.

If nobody comes up with an alternative suggestion, I will change it to
read_blob_data_from_index_path() and resubmit.

> 
> -Peff
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html