Re: What's cooking in git.git (Aug 2016, #01; Tue, 2)

2016-08-04 Thread Junio C Hamano
Johannes Schindelin  writes:

>> > Something like this will make the test more consistent with the rest of
>> > the file:
>> > 
>> > diff --git a/t/t5533-push-cas.sh b/t/t5533-push-cas.sh
>> > index 5f29664..e5bbbd8 100755
>> > --- a/t/t5533-push-cas.sh
>> > +++ b/t/t5533-push-cas.sh
>> > @@ -220,7 +220,7 @@ test_expect_success 'new branch already exists' '
>> >(
>> >cd src &&
>> >git checkout -b branch master &&
>> > -  test_commit c
>> > +  test_commit F
>> >) &&
>> >(
>> >cd dst &&
>> 
>> Confirmed. This patch fixes the issue!
>
> Funny. I worked heads-down to have some kind of Continuous Integration to
> run on my laptop, and this breakage came up. I fixed it locally, and only
> then did it occur to me that it might have been fixed already, and then I
> found this mail with a patch identical to mine.
>
> Will send out the patch in a moment.

Thanks.
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: What's cooking in git.git (Aug 2016, #01; Tue, 2)

2016-08-04 Thread Johannes Schindelin
Hi Lars & John,

On Thu, 4 Aug 2016, Lars Schneider wrote:

> > On 04 Aug 2016, at 13:32, John Keeping  wrote:
> > 
> > On Thu, Aug 04, 2016 at 10:03:39AM +0200, Lars Schneider wrote:
> >> 
> >>> * jk/push-force-with-lease-creation (2016-07-26) 3 commits
> >>> - push: allow pushing new branches with --force-with-lease
> >>> - push: add shorthand for --force-with-lease branch creation
> >>> - Documentation/git-push: fix placeholder formatting
> >>> 
> >>> "git push --force-with-lease" already had enough logic to allow
> >>> ensuring that such a push results in creation of a ref (i.e. the
> >>> receiving end did not have another push from sideways that would be
> >>> discarded by our force-pushing), but didn't expose this possibility
> >>> to the users.  It does so now.
> >>> 
> >>> Will merge to 'next'.
> >> 
> >> t5533-push-cas.sh "16 - new branch already exists" seems to be broken 
> >> for OSX on next. Git bisect indicates that "push: add shorthand for 
> >> --force-with-lease branch creation" might be the culprit.
> >> 
> >> https://travis-ci.org/git/git/jobs/149614431
> >> https://api.travis-ci.org/jobs/149614431/log.txt?deansi=true (non-JS)
> > 
> > It seems that the test script has already done "test_commit C", so the
> > newly added "test_commit c" does nothing on a case-insensitive
> > filesystem.
> > 
> > Something like this will make the test more consistent with the rest of
> > the file:
> > 
> > diff --git a/t/t5533-push-cas.sh b/t/t5533-push-cas.sh
> > index 5f29664..e5bbbd8 100755
> > --- a/t/t5533-push-cas.sh
> > +++ b/t/t5533-push-cas.sh
> > @@ -220,7 +220,7 @@ test_expect_success 'new branch already exists' '
> > (
> > cd src &&
> > git checkout -b branch master &&
> > -   test_commit c
> > +   test_commit F
> > ) &&
> > (
> > cd dst &&
> 
> Confirmed. This patch fixes the issue!

Funny. I worked heads-down to have some kind of Continuous Integration to
run on my laptop, and this breakage came up. I fixed it locally, and only
then did it occur to me that it might have been fixed already, and then I
found this mail with a patch identical to mine.

Will send out the patch in a moment.

Thanks,
Dscho
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: What's cooking in git.git (Aug 2016, #01; Tue, 2)

2016-08-04 Thread Lars Schneider

> On 04 Aug 2016, at 13:32, John Keeping  wrote:
> 
> On Thu, Aug 04, 2016 at 10:03:39AM +0200, Lars Schneider wrote:
>> 
>>> 
>>> * jk/push-force-with-lease-creation (2016-07-26) 3 commits
>>> - push: allow pushing new branches with --force-with-lease
>>> - push: add shorthand for --force-with-lease branch creation
>>> - Documentation/git-push: fix placeholder formatting
>>> 
>>> "git push --force-with-lease" already had enough logic to allow
>>> ensuring that such a push results in creation of a ref (i.e. the
>>> receiving end did not have another push from sideways that would be
>>> discarded by our force-pushing), but didn't expose this possibility
>>> to the users.  It does so now.
>>> 
>>> Will merge to 'next'.
>> 
>> t5533-push-cas.sh "16 - new branch already exists" seems to be broken 
>> for OSX on next. Git bisect indicates that "push: add shorthand for 
>> --force-with-lease branch creation" might be the culprit.
>> 
>> https://travis-ci.org/git/git/jobs/149614431
>> https://api.travis-ci.org/jobs/149614431/log.txt?deansi=true (non-JS)
> 
> It seems that the test script has already done "test_commit C", so the
> newly added "test_commit c" does nothing on a case-insensitive
> filesystem.
> 
> Something like this will make the test more consistent with the rest of
> the file:
> 
> diff --git a/t/t5533-push-cas.sh b/t/t5533-push-cas.sh
> index 5f29664..e5bbbd8 100755
> --- a/t/t5533-push-cas.sh
> +++ b/t/t5533-push-cas.sh
> @@ -220,7 +220,7 @@ test_expect_success 'new branch already exists' '
>   (
>   cd src &&
>   git checkout -b branch master &&
> - test_commit c
> + test_commit F
>   ) &&
>   (
>   cd dst &&

Confirmed. This patch fixes the issue!

Thanks,
Lars
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: What's cooking in git.git (Aug 2016, #01; Tue, 2)

2016-08-04 Thread John Keeping
On Thu, Aug 04, 2016 at 10:03:39AM +0200, Lars Schneider wrote:
> 
> > 
> > * jk/push-force-with-lease-creation (2016-07-26) 3 commits
> > - push: allow pushing new branches with --force-with-lease
> > - push: add shorthand for --force-with-lease branch creation
> > - Documentation/git-push: fix placeholder formatting
> > 
> > "git push --force-with-lease" already had enough logic to allow
> > ensuring that such a push results in creation of a ref (i.e. the
> > receiving end did not have another push from sideways that would be
> > discarded by our force-pushing), but didn't expose this possibility
> > to the users.  It does so now.
> > 
> > Will merge to 'next'.
> 
> t5533-push-cas.sh "16 - new branch already exists" seems to be broken 
> for OSX on next. Git bisect indicates that "push: add shorthand for 
> --force-with-lease branch creation" might be the culprit.
> 
> https://travis-ci.org/git/git/jobs/149614431
> https://api.travis-ci.org/jobs/149614431/log.txt?deansi=true (non-JS)

It seems that the test script has already done "test_commit C", so the
newly added "test_commit c" does nothing on a case-insensitive
filesystem.

Something like this will make the test more consistent with the rest of
the file:

diff --git a/t/t5533-push-cas.sh b/t/t5533-push-cas.sh
index 5f29664..e5bbbd8 100755
--- a/t/t5533-push-cas.sh
+++ b/t/t5533-push-cas.sh
@@ -220,7 +220,7 @@ test_expect_success 'new branch already exists' '
(
cd src &&
git checkout -b branch master &&
-   test_commit c
+   test_commit F
) &&
(
cd dst &&
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: What's cooking in git.git (Aug 2016, #01; Tue, 2)

2016-08-04 Thread Lars Schneider

> 
> * jk/push-force-with-lease-creation (2016-07-26) 3 commits
> - push: allow pushing new branches with --force-with-lease
> - push: add shorthand for --force-with-lease branch creation
> - Documentation/git-push: fix placeholder formatting
> 
> "git push --force-with-lease" already had enough logic to allow
> ensuring that such a push results in creation of a ref (i.e. the
> receiving end did not have another push from sideways that would be
> discarded by our force-pushing), but didn't expose this possibility
> to the users.  It does so now.
> 
> Will merge to 'next'.

t5533-push-cas.sh "16 - new branch already exists" seems to be broken 
for OSX on next. Git bisect indicates that "push: add shorthand for 
--force-with-lease branch creation" might be the culprit.

https://travis-ci.org/git/git/jobs/149614431
https://api.travis-ci.org/jobs/149614431/log.txt?deansi=true (non-JS)

- Lars
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: What's cooking in git.git (Aug 2016, #01; Tue, 2)

2016-08-03 Thread Junio C Hamano
On Wed, Aug 3, 2016 at 5:24 AM, Jakub Narębski  wrote:>
> Could you apply the first part (the first patch) of the series,
> namely:
>
>- clarify %f documentation

Thanks. That's a good idea.

> P.S. I guess that filter..process series is considered
>  pre-cooking?

Yes. I've been waiting to see that the amount and quality of
comments from others indicate that the series passed
the phase that goes through frequent rerolls. Having a
serious review in the thread that demonstrates and
concludes that it is well designed, well implemented,
and ready to go would help, of course.
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


Re: What's cooking in git.git (Aug 2016, #01; Tue, 2)

2016-08-03 Thread Jakub Narębski
W dniu 03.08.2016 o 00:24, Junio C Hamano pisze:

> --
> [Stalled]
> 
> * jh/clean-smudge-annex (2016-08-01) 9 commits
>  - use smudgeToFile filter in recursive merge
>  - use smudgeToFile filter in git am
>  - better recovery from failure of smudgeToFile filter
>  - warn on unusable smudgeToFile/cleanFromFile config
>  - use smudgeToFile in git checkout etc
>  - use cleanFromFile in git add
>  - add smudgeToFile and cleanFromFile filter configs
>  - clarify %f documentation
>  - Merge branch 'cc/apply-am' into HEAD
>  (this branch uses cc/apply-am.)
> 
>  The interface to "clean/smudge" filters require Git to feed the
>  whole contents via pipe, which is suboptimal for some applications.
>  "cleanFromFile/smudgeToFile" commands are the moral equilvalents
>  for these filters but they interact with the files on the
>  filesystem directly.
> 
>  This is starting to bit-rot, as the topic it is built upon keeps
>  getting rerolled.  I _think_ I rebased it correctly, but I would
>  not be surprised if I made a mistake.
> 
>  Will discard if/when I have to do another rebase, preferring to
>  have a fresh reroll directly from the author.

Could you apply the first part (the first patch) of the series,
namely:

   - clarify %f documentation

> * da/subtree-2.9-regression (2016-07-26) 2 commits
>   (merged to 'next' on 2016-07-26 at 9d71562)
>  + subtree: fix "git subtree split --rejoin"
>  + t7900-subtree.sh: fix quoting and broken && chains
>  (this branch is used by da/subtree-modernize.)
> 
>  "git merge" in Git v2.9 was taught to forbid merging an unrelated
>  lines of history by default, but that is exactly the kind of thing
>  the "--rejoin" mode of "git subtree" (in contrib/) wants to do.
>  "git subtree" has been taught to use the "--allow-unrelated-histories"
>  option to override the default.
> 
>  Will merge to 'master'.

Good. At least one Git user was bitten by this bug, see
<1bed74c8-2e4c-4ca7-b785-f0666b69c...@gmail.com>


P.S. I guess that filter..process series is considered
 pre-cooking?

-- 
Jakub Narębski
--
To unsubscribe from this list: send the line "unsubscribe git" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html


What's cooking in git.git (Aug 2016, #01; Tue, 2)

2016-08-02 Thread Junio C Hamano
Here are the topics that have been cooking.  Commits prefixed with
'-' are only in 'pu' (proposed updates) while commits prefixed with
'+' are in 'next'.  The ones marked with '.' do not appear in any of
the integration branches, but I am still holding onto them.

On the 'master' front, the individual commit count now exceeds 400
since the last major release, which is a good pace.  We may want to
start slowing down once the current crop of topics in 'next' hits
the 'master' and switch our attention to regression hunting.  The
'maint' branch has been accumulating enough material to make it the
next maintenance release v2.9.3.

You can find the changes described here in the integration branches
of the repositories listed at

http://git-blame.blogspot.com/p/git-public-repositories.html

--
[New Topics]

* ab/gitweb-link-html-escape (2016-08-01) 1 commit
 - gitweb: escape link body in format_ref_marker

 The characters in the label shown for tags/refs for commits shown
 in "gitweb" output are now properly escaped for proper HTML output.

 Will merge to 'next'.


* ew/build-time-pager-tweaks (2016-08-01) 1 commit
 . pager: move pager-specific setup into the build

 The build procedure learned PAGER_ENV knob that lists what default
 environment variable settings to export for popular pagers.  This
 mechanism is used to tweak the default settings to MORE on FreeBSD.

 Waiting for a reroll.


* ib/t3700-add-chmod-x-updates (2016-08-01) 3 commits
 - t3700: add a test_mode_in_index helper function
 - t3700: merge two tests into one
 - t3700: remove unwanted leftover files before running new tests

 The t3700 test about "add --chmod=-x" have been made a bit more
 robust and generally cleaned up.

 Will merge to 'next'.


* jt/format-patch-from-config (2016-08-01) 1 commit
 - format-patch: format.from gives the default for --from

 "git format-patch" learned format.from configuration variable to
 specify the default settings for its "--from" option.


* rs/st-mult (2016-08-01) 1 commit
 - pass constants as first argument to st_mult()

 Micro optimization of st_mult() facility used to check the integer
 overflow coming from multiplication to compute size of memory
 allocation.

 Will merge to 'next'.


* rs/use-strbuf-addstr (2016-08-01) 1 commit
 - use strbuf_addstr() for adding constant strings to a strbuf

 Will merge to 'next'.


* sb/submodule-update-dot-branch (2016-08-01) 7 commits
 - submodule update: allow '.' for branch value
 - submodule--helper: add remote-branch helper
 - submodule-config: keep configured branch around
 - submodule--helper: fix usage string for relative-path
 - submodule update: narrow scope of local variable
 - submodule update: respect depth in subsequent fetches
 - t7406: future proof tests with hard coded depth

 A few updates to "git submodule update".

 Will merge to 'next'.


* jc/hashmap-doc-init (2016-08-02) 1 commit
 - hashmap: clarify that hashmap_entry can safely be discarded

 The API documentation for hashmap was unclear if hashmap_entry
 can be safely discarded without any other consideration.  State
 that it is safe to do so.

--
[Stalled]

* jh/clean-smudge-annex (2016-08-01) 9 commits
 - use smudgeToFile filter in recursive merge
 - use smudgeToFile filter in git am
 - better recovery from failure of smudgeToFile filter
 - warn on unusable smudgeToFile/cleanFromFile config
 - use smudgeToFile in git checkout etc
 - use cleanFromFile in git add
 - add smudgeToFile and cleanFromFile filter configs
 - clarify %f documentation
 - Merge branch 'cc/apply-am' into HEAD
 (this branch uses cc/apply-am.)

 The interface to "clean/smudge" filters require Git to feed the
 whole contents via pipe, which is suboptimal for some applications.
 "cleanFromFile/smudgeToFile" commands are the moral equilvalents
 for these filters but they interact with the files on the
 filesystem directly.

 This is starting to bit-rot, as the topic it is built upon keeps
 getting rerolled.  I _think_ I rebased it correctly, but I would
 not be surprised if I made a mistake.

 Will discard if/when I have to do another rebase, preferring to
 have a fresh reroll directly from the author.


* sb/bisect (2016-04-15) 22 commits
 . SQUASH???
 . bisect: get back halfway shortcut
 . bisect: compute best bisection in compute_relevant_weights()
 . bisect: use a bottom-up traversal to find relevant weights
 . bisect: prepare for different algorithms based on find_all
 . bisect: rename count_distance() to compute_weight()
 . bisect: make total number of commits global
 . bisect: introduce distance_direction()
 . bisect: extract get_distance() function from code duplication
 . bisect: use commit instead of commit list as arguments when appropriate
 . bisect: replace clear_distance() by unique markers
 . bisect: use struct node_data array instead of int array
 . bisect: get rid of recursion in count_distance()
 . bisect: