[gwt-contrib] Re: Added method to change the size of a MutableArray. Added factory method to construct a nonempty ... (issue319801)

2010-04-13 Thread rchandia

http://gwt-code-reviews.appspot.com/319801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

To unsubscribe, reply using remove me as the subject.


[gwt-contrib] Re: Added method to change the size of a MutableArray. Added factory method to construct a nonempty ... (issue319801)

2010-04-13 Thread rchandia

Dan, Freeland:

Please disregard this last patch. I will not submit it. Actually I do
not know why it got appended to this issue instead of becoming a new
issue.

Do I need to do something else to clean up?

On 2010/04/13 18:36:44, rchandia wrote:




http://gwt-code-reviews.appspot.com/319801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors


[gwt-contrib] Re: Added method to change the size of a MutableArray. Added factory method to construct a nonempty ... (issue319801)

2010-04-12 Thread fabbott

LGTM, too

http://gwt-code-reviews.appspot.com/319801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

To unsubscribe, reply using remove me as the subject.


[gwt-contrib] Re: Added method to change the size of a MutableArray. Added factory method to construct a nonempty ... (issue319801)

2010-04-08 Thread rchandia

http://gwt-code-reviews.appspot.com/319801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

To unsubscribe, reply using remove me as the subject.


[gwt-contrib] Re: Added method to change the size of a MutableArray. Added factory method to construct a nonempty ... (issue319801)

2010-04-08 Thread rchandia


http://gwt-code-reviews.appspot.com/319801/diff/1/3
File bikeshed/src/com/google/gwt/collections/MutableArray.java (right):

http://gwt-code-reviews.appspot.com/319801/diff/1/3#newcode150
bikeshed/src/com/google/gwt/collections/MutableArray.java:150: *
truncated. If {...@code newSize} is greater than the current size the array
us grown and
On 2010/04/07 15:53:58, Dan Rice wrote:

us - is


Done.

http://gwt-code-reviews.appspot.com/319801/diff/1/3#newcode166
bikeshed/src/com/google/gwt/collections/MutableArray.java:166: } else if
(elems == null) {
On 2010/04/07 15:53:58, Dan Rice wrote:

Probably clearer to start a new if() since the first two clauses

return

Done.

http://gwt-code-reviews.appspot.com/319801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

To unsubscribe, reply using remove me as the subject.


[gwt-contrib] Re: Added method to change the size of a MutableArray. Added factory method to construct a nonempty ... (issue319801)

2010-04-07 Thread rice

LGTM


http://gwt-code-reviews.appspot.com/319801/diff/1/3
File bikeshed/src/com/google/gwt/collections/MutableArray.java (right):

http://gwt-code-reviews.appspot.com/319801/diff/1/3#newcode150
bikeshed/src/com/google/gwt/collections/MutableArray.java:150: *
truncated. If {...@code newSize} is greater than the current size the array
us grown and
us - is

http://gwt-code-reviews.appspot.com/319801/diff/1/3#newcode166
bikeshed/src/com/google/gwt/collections/MutableArray.java:166: } else if
(elems == null) {
Probably clearer to start a new if() since the first two clauses return

http://gwt-code-reviews.appspot.com/319801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

To unsubscribe, reply using remove me as the subject.