[jira] [Commented] (HDDS-240) Implement metrics for EventQueue

2018-07-09 Thread Hudson (JIRA)


[ 
https://issues.apache.org/jira/browse/HDDS-240?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16537534#comment-16537534
 ] 

Hudson commented on HDDS-240:
-

SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #14546 (See 
[https://builds.apache.org/job/Hadoop-trunk-Commit/14546/])
HDDS-240. Implement metrics for EventQueue. Contributed by Elek, Marton. 
(aengineer: rev 2403231c8c3685ba08cd6bdf715d281cae611e45)
* (edit) 
hadoop-hdds/framework/src/main/java/org/apache/hadoop/hdds/server/events/EventQueue.java
* (edit) 
hadoop-hdds/framework/src/main/java/org/apache/hadoop/hdds/server/events/SingleThreadExecutor.java
* (edit) 
hadoop-hdds/framework/src/test/java/org/apache/hadoop/hdds/server/events/TestEventQueue.java


> Implement metrics for EventQueue
> 
>
> Key: HDDS-240
> URL: https://issues.apache.org/jira/browse/HDDS-240
> Project: Hadoop Distributed Data Store
>  Issue Type: Improvement
>  Components: SCM
>Reporter: Elek, Marton
>Assignee: Elek, Marton
>Priority: Major
> Fix For: 0.2.1
>
> Attachments: HDDS-240.001.patch
>
>
> The heart of the SCM is the lightweight EventQueue which is implemented in 
> HDDS-25.
> The main advantage to use a centralized EventQueue API is that all the thread 
> handling could be implemented in one central place (with unified the 
> monitoring, thread naming, lifecycle management).
> In this jira I propose to create basic metrics for EventQueue. As (in the 
> current implementation) each handler has an own executor which has already 
> some metrics (for check when the unit tests could be stoped), it's quite easy 
> to convert the atomic counters to real hadoop metrics.
> For the sake of simplicity I also propose to remove the addHandlerGroup. The 
> method supported the case when the Executor was shared between multiple 
> handlers. It's a special case, it's more harder to monitor (we need tricky 
> naming convention) and can't see real demand. We can restore it when we will 
> see the requirements.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



[jira] [Commented] (HDDS-240) Implement metrics for EventQueue

2018-07-09 Thread Anu Engineer (JIRA)


[ 
https://issues.apache.org/jira/browse/HDDS-240?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16537458#comment-16537458
 ] 

Anu Engineer commented on HDDS-240:
---

+1, I will commit this shortly.

> Implement metrics for EventQueue
> 
>
> Key: HDDS-240
> URL: https://issues.apache.org/jira/browse/HDDS-240
> Project: Hadoop Distributed Data Store
>  Issue Type: Improvement
>  Components: SCM
>Reporter: Elek, Marton
>Assignee: Elek, Marton
>Priority: Major
> Fix For: 0.2.1
>
> Attachments: HDDS-240.001.patch
>
>
> The heart of the SCM is the lightweight EventQueue which is implemented in 
> HDDS-25.
> The main advantage to use a centralized EventQueue API is that all the thread 
> handling could be implemented in one central place (with unified the 
> monitoring, thread naming, lifecycle management).
> In this jira I propose to create basic metrics for EventQueue. As (in the 
> current implementation) each handler has an own executor which has already 
> some metrics (for check when the unit tests could be stoped), it's quite easy 
> to convert the atomic counters to real hadoop metrics.
> For the sake of simplicity I also propose to remove the addHandlerGroup. The 
> method supported the case when the Executor was shared between multiple 
> handlers. It's a special case, it's more harder to monitor (we need tricky 
> naming convention) and can't see real demand. We can restore it when we will 
> see the requirements.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

-
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org



[jira] [Commented] (HDDS-240) Implement metrics for EventQueue

2018-07-09 Thread genericqa (JIRA)


[ 
https://issues.apache.org/jira/browse/HDDS-240?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=16536763#comment-16536763
 ] 

genericqa commented on HDDS-240:


| (/) *{color:green}+1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:blue}0{color} | {color:blue} reexec {color} | {color:blue}  0m 
25s{color} | {color:blue} Docker mode activated. {color} |
|| || || || {color:brown} Prechecks {color} ||
| {color:green}+1{color} | {color:green} @author {color} | {color:green}  0m  
0s{color} | {color:green} The patch does not contain any @author tags. {color} |
| {color:green}+1{color} | {color:green} test4tests {color} | {color:green}  0m 
 0s{color} | {color:green} The patch appears to include 1 new or modified test 
files. {color} |
|| || || || {color:brown} trunk Compile Tests {color} ||
| {color:green}+1{color} | {color:green} mvninstall {color} | {color:green} 27m 
39s{color} | {color:green} trunk passed {color} |
| {color:green}+1{color} | {color:green} compile {color} | {color:green}  0m 
23s{color} | {color:green} trunk passed {color} |
| {color:green}+1{color} | {color:green} checkstyle {color} | {color:green}  0m 
16s{color} | {color:green} trunk passed {color} |
| {color:green}+1{color} | {color:green} mvnsite {color} | {color:green}  0m 
25s{color} | {color:green} trunk passed {color} |
| {color:green}+1{color} | {color:green} shadedclient {color} | {color:green} 
10m 56s{color} | {color:green} branch has no errors when building and testing 
our client artifacts. {color} |
| {color:green}+1{color} | {color:green} findbugs {color} | {color:green}  0m 
30s{color} | {color:green} trunk passed {color} |
| {color:green}+1{color} | {color:green} javadoc {color} | {color:green}  0m 
21s{color} | {color:green} trunk passed {color} |
|| || || || {color:brown} Patch Compile Tests {color} ||
| {color:green}+1{color} | {color:green} mvninstall {color} | {color:green}  0m 
23s{color} | {color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} compile {color} | {color:green}  0m 
17s{color} | {color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} javac {color} | {color:green}  0m 
17s{color} | {color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} checkstyle {color} | {color:green}  0m 
10s{color} | {color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} mvnsite {color} | {color:green}  0m 
20s{color} | {color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} whitespace {color} | {color:green}  0m 
 0s{color} | {color:green} The patch has no whitespace issues. {color} |
| {color:green}+1{color} | {color:green} shadedclient {color} | {color:green} 
11m 41s{color} | {color:green} patch has no errors when building and testing 
our client artifacts. {color} |
| {color:green}+1{color} | {color:green} findbugs {color} | {color:green}  0m 
34s{color} | {color:green} the patch passed {color} |
| {color:green}+1{color} | {color:green} javadoc {color} | {color:green}  0m 
18s{color} | {color:green} the patch passed {color} |
|| || || || {color:brown} Other Tests {color} ||
| {color:green}+1{color} | {color:green} unit {color} | {color:green}  0m 
30s{color} | {color:green} framework in the patch passed. {color} |
| {color:green}+1{color} | {color:green} asflicense {color} | {color:green}  0m 
30s{color} | {color:green} The patch does not generate ASF License warnings. 
{color} |
| {color:black}{color} | {color:black} {color} | {color:black} 56m 12s{color} | 
{color:black} {color} |
\\
\\
|| Subsystem || Report/Notes ||
| Docker | Client=17.05.0-ce Server=17.05.0-ce Image:yetus/hadoop:abb62dd |
| JIRA Issue | HDDS-240 |
| JIRA Patch URL | 
https://issues.apache.org/jira/secure/attachment/12930815/HDDS-240.001.patch |
| Optional Tests |  asflicense  compile  javac  javadoc  mvninstall  mvnsite  
unit  shadedclient  findbugs  checkstyle  |
| uname | Linux a2f2c4d648a3 4.4.0-130-generic #156-Ubuntu SMP Thu Jun 14 
08:53:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux |
| Build tool | maven |
| Personality | /testptch/patchprocess/precommit/personality/provided.sh |
| git revision | trunk / 43f7fe8 |
| maven | version: Apache Maven 3.3.9 |
| Default Java | 1.8.0_171 |
| findbugs | v3.1.0-RC1 |
|  Test Results | 
https://builds.apache.org/job/PreCommit-HDDS-Build/465/testReport/ |
| Max. process+thread count | 435 (vs. ulimit of 1) |
| modules | C: hadoop-hdds/framework U: hadoop-hdds/framework |
| Console output | 
https://builds.apache.org/job/PreCommit-HDDS-Build/465/console |
| Powered by | Apache Yetus 0.8.0-SNAPSHOT   http://yetus.apache.org |


This message was automatically generated.



> Implement metrics for EventQueue
> 
>
> Key: HDDS-240
> URL: https://issues.apache.org/jira/browse/HDDS-240
> Project: Hadoop Distributed